PDA

View Full Version : Kaypro II restoration - request for comments



retrobits
September 17th, 2012, 12:14 PM
Hi all,

Picked up a Kaypro II over the weekend. It is partially functional, but has some issues. Thought I'd post about my experience, and validate the next steps.

The machine has been sitting in a closet for perhaps up to 20 years. The seller had powered it up to show that the screen works (prompts for boot disk). No original disks came with it.

Using Imagedisk, a 360K 5.25 drive, and DOS, I created a Kaypro II CP/M 2.2 boot disk. Since the seller had already powered it up once, I decided to risk another boot before internal inspection. At first, the Kaypro wouldn't boot, but after a few minutes (perhaps the drives need to re-loosen after the years?) it started booting reliably. Once the A> prompt appeared, a DIR yielded the file list. However, attempting to run any COM file resulted in BDOS sector error. The drives are obviously still not completely all there.

Also, the machine was in a smoker's home, so it does have a smoke smell and potential degredation of the moving parts and circuit boards.

Next steps:

To make the disks work, I am assuming I should clean the heads, check the belts for tightness and cleanliness, and then try again. I don't have a strobe to check for disk RPM. Remarkably, after all these years, I've never cleaned the heads on a floppy drive. Any best practices here? Also, any other comments?

I'm much less clear on how to clean the smoke residue out of the system. I can dismantle the case and the keyboard and clean what I can. Cleaning circuit boards seems to be less of an exact science. Some people say to use warm water and mild detergent (making sure to completely dry out prior to re-use, of course). Others say to use alcohol or acetone, but some say that's hazardous. What to do?

Thanks for any comments! This Kaypro II is in really nice cosmetic shape, and the circuitry seems to be functional. The screen is very crisp. Looking forward to restoring it to its 1982 glory.

- Earl

Maverick1978
September 17th, 2012, 12:54 PM
For the disk drive, start out with cleaning the heads. If that works, leave it be... though if you're really obsessed (like most of us here *grin*) - you'll clean and lube the drive rails while you're in there, regardless :) You're lucky in that you're already able to read disks, for the most part. That hopefully means that the alignment is ok. That can be tricky - Tezza has a good article about how tricky it can be. (http://www.classic-computers.org.nz/blog/2009-01-18-kaypro-drive-repair.htm)

As for the other... personally for me, airing out the system does wonders. Though when I clean boards, I usually wipe them down using alcohol and q-tips and paper towels. I have yet to do the dishwasher method, and frankly, would never consider doing it on a working board, though YMMV.

Either way, it seems that you're off to a good start! Don't forget to check out some of the other threads here as well as Tezza's site (http://www.classic-computers.org.nz/blog/index.htm) for repair articles (Tezza, in particular, documents his repairs really well). And don't forget to update the thread as you progress!

tezza
September 17th, 2012, 08:18 PM
A Kaypro II. Good find Earl.

I'd clean those heads for a start. I use a cotton bud and alcohol (I think you call cotton buds Q-tips over there?). I've found those old drives can sometime drift off their rotational speed so yes, it would be worth checking that too. One nice thing about the Kaypro II is that it has two virtually identical drives so by swapping them, you can trace a fault either to a drive or the drive controller.

As to washing the board, I wouldn't do the dishwasher thing unless you really think you have to. I've washed a few boards in my time but usually because they were covered with mouse droppings or were Mac boards with leaky caps. Even for the latter I'd now use a different method (http://www.classic-computers.org.nz/blog/2012-01-09-classic-ii-cottonbud-solution.htm). I have had the experience where a PS/2 board stopped working when I washed it. It may have been because of static electricity from me but that made me wary of dishwashing unless its a last resort. I have used alcohol as a board wash successfully an Apple IIe. Most alcohol is diluted with some water though, so make sure you dry the board well afterwards.

Thanks for those kind words about my articles Ian. They are not so much documented repair guides as "adventures" where I stumble (bumble) my way through to a result (or not). They could be helpful though.

Are you sure the smoke smell is from the smoker owner and not blown filter caps in the power supply? These can give a machine a strong smokey odour (http://www.classic-computers.org.nz/blog/2010-01-15-fixing-blown-caps-on-kaypro.htm) (and those blown caps don't stop the machine from working).

Tez

Maverick1978
September 18th, 2012, 05:07 PM
Thanks for those kind words about my articles Ian. They are not so much documented repair guides as "adventures" where I stumble (bumble) my way through to a result (or not). They could be helpful though.
(I'm David - no worries!) As for the stumble/bumble, well, at least you're considerate enough and dedicated enough to document most of the foibles and successes! Most of us, I think, fit into the category that we'll stumble through it, post about the difficult ones for a bit, answer any questions that anyone asks (usually over and over as the questions are repeated over the years), but never take the time to create a decent write-up on the topic. Guys like you, Modem7. Mike Brutman, and others... you guys are the ones that inspire me. Except that most of my bumbling around has already been documented, so my site remains relatively empty! (that and because I haven't taken the time to continue working on it like I should!)

tezza
September 18th, 2012, 08:34 PM
Opps, sorry Dave. Seeing your handle I got confused with Ian Mavric (TRS-Ian). (Duh). Anyway, thanks. One of the advantage of writing things is that I can go back and check what I did. Otherwise I'm bound to forget and hard won experience would be lost.

Tez

acollins22
September 19th, 2012, 10:23 AM
Hi Earl,

I'm deeply jealous of you and the Kaypro, it's on my list of must-haves.

Best of luck getting it running well. Please post your progress.


All the best,

Andy.

retrobits
September 25th, 2012, 08:37 PM
Summary...it works!

Details...

The machine I have is labeled "Kaypro 2" not "Kaypro II". However, it is NOT what they call a "2'84", because the ROM version is 81-232, and the mainboard is 81-240 - the same as the later ones labeled "Kaypro II". Unlike the original Kaypro II, the keyboard is all black, as opposed to the Kaypro II's blue numeric keypad. It's kind of a tweener, it would seem. I saw pictures of a couple others on the web like mine. As mentioned before, the machine is in very nice cosmetic condition, although I've temporarily messed that up (see below).

Recap from original post: Upon first power up, the screen lit up and asked me to put a system disk in drive A. Task 1 - get a system disk. Through Tez's site, I found Dave Dunfield's (http://www.classiccmp.org/dunfield/kaypro/index.htm) awesome pages, where I found both the disks I needed, and the ImageDisk utility to cook them. Luckily, I have a DOS machine with a 5.25" 360K drive handy. Voila, I had CP/M 2.2F for the Kaypro. But...it didn't boot. At first, that is. After a few tries, it did come up to the A> prompt. However, after that, nothing worked right. I tried to run programs, and got a BDOS error. This happened in both drive A: and B:.

Now the rest of the story:

I opened the machine up, and found that the Kaypro design is elegant in its simplicity. What a nice machine! Like working on my old '68 Cougar. Anyhow, I was able to get the drives out, clean the heads, and check the belt tightness. After this, I put it back together, and tried again. Still no good. Booted to CP/M, but no go after that.

Next step was to verify that the problem wasn't the machine I was using to produce the disks. So, I dug out my trusty IBM 5160 with Tandon 5.25" full height drive, and proceeded to make another boot disk. Amazing that ImageDisk works just great on the oldest of hardware! But, alas, still no joy on getting the Kaypro to cooperate even with this newly minted disk. BTW, I had tried other media along the way, just in case that was the issue...

OK, time for a fresh idea. I thought perhaps the alignment or speed of the Tandon TM-100-1A drives in the Kaypro might be off. So I took the A: drive out of the Kaypro, attached it (after properly setting the drive select) to the 5160, and tried again to make the media. The process started, but encountered errors along the way on certain sectors. Rats, looks like the drives are really out of kilter.

Guess it's time to swap some hardware - I removed the full-height Tandon drives from the Kaypro, and replaced them with half-height Qume QumeTrak 142 DS/DD 5.25" drives. This, as you can imagine, looks ridiculous. It does, however, function quite well! The Kaypro was happily booting and on its feet.

At this point, I wondered if the ROM in my machine could support double-sided drives. Lo and behold, it likes them just fine, and with the right formatting program (snaked from a Kaypro 4 disk), it happily formats and uses DS/DD media to score me 390K per floppy! (Had I acquired an older Kaypro II model with the previous ROM, I would have been out of luck on this, I found.)

So, long story longer - the Kaypro 2 is working, and looks awful from the front (but so do I). I'm hoping to find some Tandon full-height double-sided drives to replace the Qume drives I'm currently using. And I'm happily familiarizing myself with Kaypro's history, line of machines, and prepping to do a podcast on said subject!

Pics and more of the story to come...

- Earl

tezza
September 26th, 2012, 02:18 AM
Great progress Earl.

Yea, those Tandon TM-100 drives are not the most reliable of beasts. Checking and adjusting the speed is normally pretty straightforward. You probably noticed the strobe pattern on the bottom and there is an adjuster on the drive somewhere.

Radial alignment is a little tricker but here is o (http://www.classic-computers.org.nz/blog/2010-06-28-alignment-tandon-m100.htm)ne method (http://www.classic-computers.org.nz/blog/2010-06-28-alignment-tandon-m100.htm). Note there is an appendum to the article which offers an alternative way where a TRS-80 Model III is not needed, just a PC!

Good luck!

Tez

geneb
October 2nd, 2012, 01:20 PM
I've been going through the Micro Cornucopia archive on archive.org and their Kaypro column mentions the frequent problems to be had with those Tandon drives. You'd almost be better off crafting some plates to cover the gaps around the 1/2 height drives...

g.

frotz
October 18th, 2012, 01:49 AM
I acquired a Kaypro II that had its floppy drives replaced with a pair of half-heights. The resulting space was turned into a cubbyhole for disks, the keyboard cable, and whatever. I haven't played with it for some time and I haven't checked to see if I have a II or a 2. I was under the impression that the II (or 2) was electrically incapable of addressing the other side of a floppy.

Got pics?