View Full Version : MOVCPM....doesn't?

October 10th, 2012, 01:31 PM
I'm working on getting the KayPlus ROM (http://www.microcodeconsulting.com/z80/kayplus.htm) installed in my Kaypro 4. This was _supposed_ to be pretty straightforward. *sigh*

The issue I'm having right now is that the KPCNFG84 utility (I have a Universal board) is reporting that I have a 63k CP/M system and the max permitted is 62k. No problem right? Just do a MOVCPM 62 *, followed by a SYSGEN and we're off to the races.


When booting, it reports (as ever) a 63K system. I figured that maybe this is just some kind of static Kaypro sign on banner.


Running KPCNFG84 reports the same error message. I've tried going down to 61k and I still get the same issue.

I've tried this before and after using the FIX22F utility (I've got CP/M 2.2f on this machine).

Any suggestions on what else I can try to get this going?

Thanks all.


October 11th, 2012, 04:04 PM
Dont know about the rest... but
Ive found that it needs more 'moving room' IOT get the relocation done... for example
moving 63k down to 56k would work... THEN you could do it again from 56k up to 61k...
or down to 48k then back up to 61...

The point is that there needs to be more room... just how much Im not sure, but I AM sure those numbers work FOR ME with Montezuma CPM on 'the dinosaur'...

Hope that helps! :D

October 12th, 2012, 06:01 AM
Well I gave that a shot - this time starting at 62k and moving down.

MOVCPM at 62, 61, 60 and 59 (without using the "*" parameter) result in a locked up Kaypro.

It turned out I was using SYSGEN incorrectly - it's been 25 years, so I had a good excuse. :)

Even after using SYSGEN properly, (htting return on the SOURCE DRIVE prompt) and using a 56K TPA image, it doesn't work.

The boot banner flashes briefly and the machine hangs. Is this an inherent problem with CP/M 2.2F on the Kaypro? I don't recall ever seeing this weirdness on either the Royal AlphaTronic, Pied Piper or H-89 CP/M systems I've used in the past.



October 12th, 2012, 08:37 AM
You have to understand that SYSGEN (and MOVCPM) to a large extent are vendor-specifc programs for most systems. MOVCPM as supplied by DRI contained only the BDOS and CCP parts of CP/M, along with a page reloication table--not boot loader or BIOS, as those were vendor-specific. Similarly, SYSGEN would only write a system if the system layout followed the OEM (8" SSSD) layout. Vendors modified both programs to accommodate their own systems--or not. If not, you did a MOVCPM and SAVED the image to a file, then createed a full image with a boot loader and BIOS binary and used your own PUTSYS (see the Alteration Guide) to write the system out. Many vendors didn't bother with memory size changes, as systems were often sold in one particular system configuration--there was no point to it.

In my own work, I've had to write unique SYSGENs as, for example, in one case, the system ROM would only load programs in Intel HEX format.

October 12th, 2012, 09:42 AM
The MOVCPM and SYSGEN came from the Kaypro 4 system disks I got from Dave's website, so they're not the generic DRI provided versions.


October 12th, 2012, 10:09 AM
... but the 56k DID OPERATE/come back up once MOVCPM was done?

When you ran SYSGEN and skipped SOURCE did you also skip DEST and then save the changed SYSGEN with the SAVE XX SYSGEN2.COM before trying to write to a drive?
Not 100% that is the problem since Im so used to kludging my way thru these things... but worth a try?