View Full Version : Apple Mac Power PC

June 4th, 2006, 06:47 AM
Not sure what catigory this belongs in, Mac or PC clone??? Another weekend, another trash and treasure market. I just picket up another little toy, a macintosh power PC. Pluged it in to some power and a keyboard and monitor.... Where the hell is the power switch??? How the hell do I turn it on to see if it works??? Maybe I'm suffering from a bad case of blindness, but there doesn't seem to be an "ON" switch.... Any advice will be apreaciated...

The Sinister Dragon

June 4th, 2006, 06:52 AM
Well a PPC would be a Mac, the CPU's I believe where (& still are) manufactured by IBM. Have you tried looking for a round button that looks like a circle w/ a line going through it? LOL!

I have a trashed-up PowerPC in my shed, & the power button never stays put. Maybe it fell into the case; open it up & look for a button soldered on/connected to the motherboard.

June 4th, 2006, 07:40 AM
At least on my PowerPC, the "on" switch is (as you look at the case) bottom left

June 4th, 2006, 08:31 AM
Its a button on the keyboard Look at the number pad, see the enter key? GO ALL te way to th top and there will be a button with a triangle looking thing pointing left. Press that and it should power on. Somtimes the manual power button was on the back, it depended on the model. But the Keyboard button is the usual way to trun them on. Let me know if you can't find it, I can get a picture to help you if you need me to.


Terry Yager
June 4th, 2006, 10:30 AM
My 7200 has a little round power switch located on the back. If this switch is in the 'off' position, then the keyboard switch won't work, IIRC.


June 4th, 2006, 10:33 AM
Well of course. That's the PS switch. A keyboard can't turn something on if it's not recieving any power...

June 6th, 2006, 12:34 PM
i had a performa that didnt have any switch on the machine [that i noticed]. it took me an hour to get around to attaching the keyboard and pressing that button:confused:

June 6th, 2006, 12:48 PM
So it works now?

June 6th, 2006, 12:54 PM
me or sinisterdragon?

yeah, i got the performa working, i didnt keep it around long tho. too bloody big.

i did like the way the motherboard slide in and out, tho. that was nice.

June 7th, 2006, 05:31 AM
Thanks for all the replies guys... Obviously this unit doesn't have a switch on the main system... Must be on the keyboard which I dont have... Oh well,m into storage it goes, I'll have to look out for a suitable keyboard for it and take it form there....

The Sinister Draogn...

June 7th, 2006, 06:23 AM
It's a Mac. So now it's in the Mac area. :-)