PDA

View Full Version : cp/m-86 vmware workstation



Jimmy
December 19th, 2012, 02:55 AM
I have created a virtual machine using vmware workstation for CP/M-86. I have it configured with 2 floppies and a 8 meg hard drive. I have it up and running okay. Most of the programs work, but with some of the programs I get a "MEMORY NOT AVAILABLE" error when I try to execute the program. I tried the communications program "Terminal.cmd" and get the error, I also got the error with the "CBasic" compiler. Wordstart 3.3, TED Editor and others work fine.

When I boot to CP/M-86 it reports 639k of memory.

I created a floppy disk and loaded the same programs and they execute on my tweener withour errors. I believe I have configuration issues with vmware workstation.

I have also ordered a IDE Flash Card adapter and have an 8 meg flash card, going to try and install it as a hard drive for CP/M on my tweener. I know the drive has to be no more than 1024 logical sectors.

Any advice or direction would be greatly appreciated.

Thanks,

Jimmy

lotonah
December 19th, 2012, 09:10 PM
Sorry, I don't have any help to offer. I would appreciate it, once you do get it working, if you could share your VM machine 'cause I would love to use this, too. Right now my CP/M machine is either running an Apple emulator w/Z-80 support, or an Atari ST emulator with command shell software, or to actually pull out one of my old CP/M machines.

Thanks!

billdeg
December 20th, 2012, 03:17 AM
Vmware? Can you be more specific? Do you mean *the* VMware (ESXi) or the generic term for an emulator? Tell us more about the network, OS, memory allocation, and otherplatform details.

"Memory not available" likely means your memory map for one thing is not the memory map used for another, cbios stuff.

Jimmy
December 20th, 2012, 12:05 PM
I installed CP/M-86 on VMWare's Workstation Version 8, but I think it would work just as well on their free Virtual Machine Player. VM Workstation Host is installed on Windows 7 premium. The guest is configured with 640 MB Memory, a single processor, CD/DVD set to autodect, two 1.44 floppies. I booted up to BIOS and configured the first hard drive as user with 512 Cylinders, 8 Heads and 171 Sectors for 36MB Drive. I disabled Multi-Sector Transfers, LBA Control, 32 Bit I/O, Ultra DMA Mode and the transfer mode is set to Standard.

I used the following link to download a floppy image with 1.44 support http://www.cpm.z80.de/download/144cpm86.zip

I then used 22Disk running under MSDos 6.22 in a virtual host to add the additional programs to the floppy image I downloaded. I did have to convert the the image into a different track order (no alternating heads, just one side and then the second side, prior and after adding the programs with 22Disk.

I used the Utility HDMaint on the Floppy Image to partition the hard disk and then PIP to copy the files to the hard disk. It boots okay. I did configure a virtual com port, but I am not sure I have it configured correctly.

I tried a few of the programs I had loaded using 22Disk. WordStar 3.3 works fine, do did the Text Editor Ted. I tried a communications program named Terminal.Cmd and recieved the error. I also tried a program ComSet.Cmd, so I may have some issues with defining a virtual serial port.

When I tried to load Microsoft Basic, it crashed the virtual host. I am going to experiment with some other programs, hopefully to get a better understanding of what I am doing wrong.

If anyone is interested I will be happy to post any of my files.

billdeg
December 20th, 2012, 12:27 PM
awesome, thanks for the details. I thought you'd have to do that on XP. I had been talking to a friend about setting up a VICE emulator to run C-64 on VMware too, I better get cracking.

As far as your MS BASIC issue, you may have a bad disk or a re-located BIOS version, who knows. I bet you'll have to deal with this kind of thing, but it has nothing to do with the emulator. Does your software work in an actual machine running CP/M? I'd want to try that if you have one. I don't like to make promises I can't keep due to my busy schedule, but I or someone could possibly send you another version of the MS BASIC software to try.

Jimmy
December 20th, 2012, 01:29 PM
Bill:

Yes it does, MBasic does not give the memory error, it crashes the guest. I tried DR's basic compiler CB86 version 2.2 and it compiled a source deck okay. I do have the assembler source for the Terminal Program, I thought I would take a look at it after the holidays.

Jimmy
December 22nd, 2012, 11:31 AM
Okay after a few hours on working on the Virtual Machines I now have CP/M-86 1.1 installed on VMWare workstation 8 and Windows 7 Virtual PC. The problem I had with the "MEMORY NOT AVAILABLE" I believe had to do with how 22Disk was writing the virtual floppy. I switched to CPMTools to create the floppy added the programs I wanted and then I converted the the image into a different track order (no alternating heads, just one side and then the second side for the Virtual Floppies and everything seems to work.

I am going to compose some notes on what I did to create the Virtual Machines. Post the notes, the virtual machines images and the virtual floppies for VMWare, VirtualPC and CPMTools on my FTP site.

lotonah
December 22nd, 2012, 05:35 PM
Awesome. Looking forward to seeing if I can get it working with VMWare for Mac. :)