PDA

View Full Version : Kaypro 10 problem



phogren
December 22nd, 2012, 11:00 AM
I recently got my second Kaypro 10. It was dead on arrival due to a FUBAR floppy drive.
I can get it to boot of a temporary floppy drive and I can access the hard drive.
When I try to reload the kaypro 10 disks it will not let me write to the Hard Disk. Can it be write protected?
It's an IMI 5012H

pjh
December 27th, 2012, 09:17 AM
Your Kaypro 10 issues may not be exactly the same as mine, but I will offer what solved my problem. Several years ago,
I acquired a Kaypro 10 that had a motherboard assembly 81-469 with a boot rom 81-478. The system would not boot up and I kept getting floppy boot errors, so I finally tried substituting the boot rom with an 81-302 and was able to boot from floppy. I then discovered that there were problems with the data on the hard drive because of a botched reinstall by the
previous owner, so, having corrected the boot issue, was able to then reinstall the Kaypro 10 system disks.

Hope this helps.

BCC_Mechanic
February 24th, 2013, 06:19 PM
I also have a Kaypro 10 and had not powered it on for many years. There were 2 issues, the first was that the power supply just did not have enough current output to spin up the full height Micropolis 10Mb drive....it took about 10 minutes of being powered on, and then by recycling the AC switch I got it to power up. I fugured the "stiction" of the drive had come into play, but I had the same problem after replacing the drive with a half height Seagate 20Mb drive. Finally I located a replacement Power supply and that solved the issue.
Second issue was with the floppy drive head assembly not able to easily step from track to track. Moving the head assembly manually with power off showed me that some lubrication or grease on the head assembly rails had hardened and was acting more like old dried honey. Removing the drive and liberally spraying off the head assembly rails, allowing to dry, a very slight covering of the rails with silicon lubricant and them I could get the reload diskettes to work correctly. Kaypro CP/M implementation isn't as user friendly as other implementations I have worked with, so some intuitive guesswork finally paid off.

vanderk
March 7th, 2013, 03:54 AM
Can you remove the drive and test it on a PC (i.e., run a low-level format/diagnostics on a XT with a MFM controller)? This may rule out an issue with your Kaypro's WD1002 controller. I also echo BCC_Mechanic's recommendation. I had to recap my Kaypro's power supply (the electrolytics were leaky) and replace some resistors. On a similar note, the video board was also recapped due to leaky electrolytics and video problems.