PDA

View Full Version : Epson Equity 1



billdeg
June 16th, 2006, 06:29 PM
Just picked one of these up locally. Starts to read Epson DOS 2.11 boot disk, it posts "Equity Loading..." for about a 1/2 second and then poops out with "Non system disk or disk error.." Any other working DOS results in "Boot Failure" and the computer locks up. The dip switch settings appear correct. I tried flip-flopping the disk drives and connections to the motherboard. No luck. The drive connectors are not your standard IBM PC drive connectors so I can't try any other drives. I have used a high % iso alcohol to clean the heads. Disk controller embedded in motherboard. I don't really feel like taking the whole computer apart to get to the motherboard. Do you think it's worth trying to fix? I feel like I am restoring an 86 Toyota, not really worth it...Comments?

follow up - no error beeps or messages upon initializing system. There does not seem to be a way to get into BASIC.

mbbrutman
June 16th, 2006, 06:58 PM
Besides cleaning the drive heads (very carefully at that), have you tried to lubricate the rails that the heads move back and forth on?

modem7
June 16th, 2006, 07:44 PM
I agree with mbbrutman. Only a week or so ago, I fixed on non-booting Sotec PHC-16 by lubricating (with silicone based lubricant) the slide rails in its floppy drive. Worth a try.

billdeg
June 16th, 2006, 08:34 PM
I'll give it a try. thanks.

Chris2005
June 17th, 2006, 08:47 AM
Epson had a number of weird drives, though I'm surprised to hear they used something as non-standard on the Equity 1. It was a fairly common clone back in the day. The QX-10, which didn't even have any IBM compatibility save for the aftermarket Titan 8088 board, had really strange floppies. Later they released the Qx-16 that had it's own 8088 (and retained the z80). I think the TIPC used some weird Epson drives also, or at least were available to it as an option (and the TIPCs drives were not yer run of the mill drive).