PDA

View Full Version : Micron Transport NX / Chicony MP989 laptop dip switch settings.



Jonah
January 23rd, 2013, 05:22 PM
I'm guessing this is too modern to qualify as "vintage", but as a novice to all this I'm unsure if there is anywhere better to ask?

I'm trying to resurrect a Chicony MP989 laptop, my first computer, dating from late '98/early '99. I've learnt it has an i440bx chipset and I'd like to upgrade the cpu from the present Pentium II 266mhz to make it more useable, but I haven't been able to find any solid info about how the dip switch settings change on the main board for different cpu frequencies. I've found them for the i440 on other boards, but not much directly relevant to the Chicony. Chicony in the US and Germany have not been able to provide any documentation as they stopped laptop manufacture over 10 years ago.

If anyone can help, point me in the direction of someone who can, or where I might find a service manual, I'd be very grateful.

partist
February 7th, 2013, 02:20 AM
I have an Artist Eton Pro (see http://wwwhomes.uni-bielefeld.de/achim/laptop/mp989.html)
with a PII 366 MHz.

There is a block with 6 switches under my keyboard.
Number 1-4 and 6 are set to OFF, number 5 is set to on.

P.S.
If you can read German then you may have a look at:
http://de.comp.sys.notebooks.narkive.com/xicm4b02/mmc-2-cpu-type-compatibel
It seams that PII 400 or Cel 433 is the best you can install.

---
Oh, there is somebody with a PIII installed! He took the MP999 Bios to get that cpu recognized.
http://www.notebookforum.at/alle-anderen-hersteller/8036-altes-maxdata-989-eton-pro-tunen-tweaken-wie.html

Jonah
February 12th, 2013, 03:18 PM
Thanks, and sorry for the slow response, but I've only just seen your reply.

I had spotted those links, I even joined the forum and emailed a couple of people from the last link. I got no reply, but those threads are pretty old.

This link for the earlier mp979 seems to suggest switch 5 is cpu voltage, and the other switches relate to the LCD display, so maybe they don't relate to cpu frequency at all?
http://ptm2.cc.utu.fi/ftp/devices/mainboards/Chicony/MP797/orphanlaptops/MP979%20FAQ.htm

I have tried a Speedstep 600/500mhz PIII cpu and it works, but runs at the lower 500mhz speed because the board doesn't support speedstep (as I understand it). It is unstable however, and will crash. Also I get "Warning: SPD Not Found At DIMM(s)..." before the operating system launches, which I assume is related to the PIII FSB being 100mhz instead of 66mhz of the PII?

Mine is a PII 266 and the dip switches are set OFF OFF OFF ON ON OFF, but it has the 14.1" display and I'm assuming as yours is an Artist Eto Pro it will be 15", so maybe that accounts for the difference at switch 4? Lots of questions, not many answers!

I managed to pick up an Artist Eton Pro from German ebay a couple of days ago, so hopefully when it arrives that won't be a 366mhz, and it will provide another piece of the puzzle. It will give me another machine to experiment on at least. I think I'll get a bios chip flashed with the mp999 bios and see what that does.

Thanks again. :D

partist
February 20th, 2013, 02:03 AM
My display is 36 cm (14.1 "). Perhaps switch 4 has another task.

I've just managed to install a DVD-ROM drive.
I'm still locking forward to get my two 256MB 16 Chip memory form far east. That will take up to 6 weeks for shipping.
I hope the memory will work.

USB 2.0 would be fine, but I think that is out of reach. USB 2.0 cards works only with a 32 BIT PCMCIA slot.

Installing a CF-Drive is another idea.

Maybe I should buy a faster hard drive.

Jonah
February 23rd, 2013, 11:54 AM
Ah OK, 14.1 that's good to know.

A couple of Dell C600s donated some pc100 256mb memory modules for mine, 2 Samsung and a Kingston. The Kingston is conveniently smaller than the Samsungs and fits nicely next to the cmos battery. Quite an increase from the original 64mb, and all 768mb appears to work too.

I had hoped to use a USB 2 PC Card, the bottom of this page says "und 2x PC-Card Slots (entweder 2x II oder I+III), 32bit Cardbus" ?
http://wwwhomes.uni-bielefeld.de/achim/laptop/mp989.html

I fitted a 30GB 5400rpm Samsung MP0302H hard disc, beautifully quiet compared to the horribly noisy original Hitachi 3.2GB 4200rpm drive, although I may fit a 16GB SSD if I can get the Pentium III to work properly.

My Eton Pro arrived from Germany yesterday, it's a PII 400 with 15" screen, and the switches are set the same as yours: OFF OFF OFF OFF ON OFF. I swapped the 400mhz cpu into my 266mhz Chicony and it works fine, without moving any of the switches. Moving switch 4 makes the display funny, so it looks like the switches are related to the display and probably don't have anything to do with cpu frequency at all.

So, I'll try the mp999 bios and see how that works out.

partist
February 28th, 2013, 02:39 AM
To be correct: 14.1 visible size!


My 2x 256 MB memory arrived today. They are 16 Chip modules.
They work fine together with one of my 65 MB modules in the middle slot, where a screw prevents to put one of the 256 into without removing at least a little part of of the screw holder.


The right slot with the Battery is a little little bit to small for a 256 MB, but it fits into anyway.

Are all of your 256 MB memory modules 16 Chip modules?

I think that it could be right that we have got a 32 Bit Cardbus.
I googeld and it seems to be that about 1997 the manufactures of notebooks switched to 32 Bit.
My Eton Pro is from 1999.

A look into the slot should definitely answer that question. But I don't know how I can see the difference.
Or if a 32 Bit card fits into the slot than it's a 32 Bit slot. But I have no 32 bit card.

Jonah
March 7th, 2013, 02:27 AM
Yes, all the modules are 16 chip.

I removed the plastic screw holder to give room for the module in the middle slot, the casing can still be secured by the aluminium tab that is left behind.

http://i1099.photobucket.com/albums/g397/yonky-f88/023.jpg

http://i1099.photobucket.com/albums/g397/yonky-f88/022.jpg

I've got hold of 32bit usb 2 PC Card, and it fits fine.

So, that's all the good news.

The bad news is, although the 32bit card fits I can't get it to work properly. If I insert a memory stick I can see the contents, but if I click on it to access it the computer locks up and has to be rebooted. I've installed the drivers that came with the card, but the result is the same. :-?

More disappointingly, I've tried the mp999 bios and it doesn't work. The computer will boot, register Pentium III and the correct frequency (the higher of the 2 speedstep frequencies), but will then freeze before the operating system launched, or crash just afterwards.

So it looks like the mp999 has more than just a bios change to run the PIII, and the best cpu the mp989 can use is the PII 400. :(

partist
March 9th, 2013, 12:53 AM
PCMCIA:
My usb pcmcia-card is on the way. I hope that I can tell you more in a few days.

What operating systems have tried?
How about WIN XP "Lite"? Or a kind of Linux? (Puppy, Fedora, DSL, Ubuntu, ...)?


PIII:
What is your exact model?
It can be the FSB. But what about Vcore and thermal heat?
(http://en.wikipedia.org/wiki/List_of_Intel_Pentium_III_microprocessors
compare it with the PII specs in http://en.wikipedia.org/wiki/List_of_Intel_Pentium_II_microprocessors)

It's said that the FSB of the memory modules is also of interest.

32 GB bug
Before I forget it:
There is a patched (but untested) bios for hard drives above 32 GB for the mp989:
http://wims.rainbow-software.org/ajz/
http://www.wimsbios.com/forum/topic7932.html

(May be patching the bios would be something for the PIII problem, but I don't think that this is as easy as patching the 32 GBit bug)

Jonah
March 10th, 2013, 05:33 AM
I've only tried with XP so far, but I thought I might try Xubuntu.

I have a couple of the PIII mmc-2 modules, a 600mhz - PMM60002101AB , and a 750mhz - PMM75002201AB. The Vcore on them is the same as the PII versions at 1.6v. I wouldn't have thought the extra heat generated by the faster PIII processors would be an issue at start up, at least not until running for a while?

All the ram modules are pc100 so they're compatible with both 66mhz PII, and the 100mhz PIII.

As you say, I don't think that bios would fix the PIII issue, but it could be worth a try.

partist
March 10th, 2013, 11:47 PM
I agree, raising the Thermal Design Power from 13 to 17 W shouldn't be the problem at startup.
But operating in "Battery Optimized mode" can lower the head: (see specs at http://thinkpad-forum.de/archive/index.php/t-30923.html?).

Until what booting stage do you come with the PIII? Stabilization efforts could be done at bootloader time, for example in GRUB.

Overclocking a PII is also possible. I remember having seen a page where they modified the cpu module. But a PII 400 is likely not very good overclockable, because it's the fastest of it's type.


---
Maybe there is a 3rd option:
Running your 750 or a PMM85002201AA at 66 FSB.

Jonah
March 11th, 2013, 04:26 AM
I don't have a good battery to try without the AC supply, and all the batteries I can find on-line are very expensive.

I only tried a few times, but it did boot to different stages with the mp999 bios and PIII, sometimes it froze on the first bios screen, but I also got XP to launch before it crashed. It is actually more stable using the PIII with original mp989 bios.

I don't know how you would get the PIII to run at 66mhz, but, as I understand it, the i440bx chipset is designed for 100mhz operation so it shouldn't be a problem? The GRUB bootloader package is unfortunately beyond my level of understanding...

It's frustrating that the PIII mmc-2 module is a straight swap for the PII module, but it doesn't work properly! :mad:

I'd love to get it to work, I may have found an 850mhz PIII.... :p

partist
March 11th, 2013, 07:11 AM
<Battery>
You can try to exchange the cells like in http://daniel-wedepohl.de/blog/?page_id=1185
(There are some other instructions, even in English, but I didn't find them again)

<Bios>
The 32gb Patch Bios from my posting #8 is really only 16 byte different from the original maxdata bios. (I've managed to extract 6 form 7 files with cbrom and #7, original.tmp with modbin. Only original.tmp is different in 16 bytes. Therefore Testing that bios with a hard drive over 32 GB is worth a try.)

You can also access hidden bios options via the programm modbin. http://www.bios-info.de/_progs/modbin45a.zip

Instructions for bios modding are at http://home.arcor.de/frogge/pepper/bmreport1.html. Is it right that he is adding microcode for suppporting further cpu's?

<Cpu moduls>
One can modify the cpu modul. http://thinkwiki.de/MMC-2-Prozessoren_modifizieren (sorry again in German).
I think that a FSB mod, like reducing FSB from 100 to 66 should be possible that way. The problem is to find the internet page with delivers the instructions for that modification.


---
"MMC2 connector pin 34B. Signal name is FQS. 0=66MHz, 1= 100MHz.

According to Intel spec document it should be hardwired with 10kohm resistor to GND at PII MMC2 module."
(source: http://www.wimsbios.com/forum/topic4046-45.html)

As far a I can understand that, for the opposite mod, pin 34b on a pIII mmc2 module shoul'd be hard set to 0.
But I guess that modding FSB implies that you probably has to mod AGB from 2/3 to 1/1.

partist
March 13th, 2013, 05:55 AM
If I insert a memory stick I can see the contents, but if I click on it to access it the computer locks up and has to be rebooted. (

my PCMCIA USB 2.0 Card arrived, and I encountered the same problems under Windows XP.

But Puppy Wary 5.3 Linux worked with that card properly. Unfortunately I can't say whether it's running under Linux in USB 1.1 or USB 2.0 mode.

Under Windows XP I was able to run HD Tune with showed a data transfer rate of 8 MByte/sec with my USB Stick.
But if I want to read a file ...
---
I found other people with similar problems.
http://forum.chip.de/windows-xp-aeltere-versionen/usb-2-0-pcmcia-317618.html (German!)


Have you put external 5 V to your card?

If you have an old pure usb 1.1 hub, you can try to plug it between the pcmcia card and your stick. That's what's posting #1 in above link found out to be working for his card.


I would say it's a windows xp usb 2.0 driver problem. Or something similar.

---

Here a discussion in English with a probable solution.
http://forums.windrivers.com/showthread.php?58476-USB-2.0-NEC-chipset-PCMCIA-card-freezes-OS

Jonah
March 20th, 2013, 10:25 AM
Sorry for the slow reply, busy at work!

I have rebuilt a screwdriver power pack with new cells before, I may give that a try.

Those bios mods confuse me :?, but it does look like he is adding code to support other cpus.

It would be a shame to reduce the 100mhz FSB of the PIII to 66mhz, the 440 chipset is designed for 100mhz operation, so I don't think that is the main problem.

External power to my PC card made no difference unfortunately.

I've tried the solution in the last link, using a different driver, but the computer thinks the PC card is a usb 1.1 port, then it crashes!