View Full Version : 486 I/O card problems

June 24th, 2006, 02:37 AM
I received the I/O card for the floppy and hard drives today for my 486, but I'm having problems in getting it working.

The hard drive already has DOS 6.22 installed on it. When it's plugged in, the BIOS can detect it, however I cannot seem to boot from it. On starting, the computer hangs just after the "press <del> for BIOS" text, where it says "wait..." on the screen just when you expect it to beep. I've tried unplugging the HDD and only using the floppy, but it does the same thing. It does actually recognise a floppy is there (it reads from it for about a second) but then pauses.

Any ideas? :)

June 24th, 2006, 07:26 AM
How big is the HD? Does the bios have a section for LBA?

June 24th, 2006, 02:37 PM
It's a 400-something MB hard drive. Not sure on the LBA, I'd have to get back to you on that one.

It's a 486SX25 with 4MB RAM.

Even if it was a problem with the drive or it's settings, I still can't get the floppy to read?

June 24th, 2006, 08:01 PM
Floppy could be full of dust, look into that.Make sure the drrive is setup correctly in the bios for size and type.

June 25th, 2006, 06:27 AM
Guys .. it's a very PC specific question on an old, but not vintage. I'm moving it to the PC area.

Please, for the sake of everybody else who might ever try to read our postings, get them in the right area. I'm not scolding anybody in particular, but for a bunch of regulars you really are irregular about where to post!

As for the problem, it doesn't sound like the hard drive is at fault. It sounds more like you have an IRQ or port conflict on the machine, hence the hang whether the hard disk is in or not. Would the machine boot if the controller was not in the machine? If so, then the new card you added is the problem. Get the documentation somehow, check the jumpers, and make sure there is nothing else in the system that will conflict with it.

(Yep, that's a pretty tall order, especially if you don't have all of the docs.)

June 25th, 2006, 06:35 AM
I put the post in the other section, as that was where my other 486 post was moved :)

Unfortunately I don't have docs for the card, and I can't find any online. The machine does boot when the card is removed, but obviously displays an error message saying that no disks where found.

I'll take out the sound card so I only have the I/O and VGA cards in the machine. I'll try swapping them around to see if it solves anything.

The card is labelled "LCS-6623 Rev D1"


June 25th, 2006, 07:06 AM
Now, I can get it booting from floppy disks :D

Also, when I plug in the HDD, it detects in the BIOS, but it hangs before beeping as before. the only way to get it to boot from floppy is to upplug the drive, and set to "no drive" in bios ???

June 25th, 2006, 07:38 AM
I'm trying to be consistent about where posts land .. If it's PC related and it's old, I think it goes here. If it's PC related and new (off-topic), then it goes to off-topic. If it is a general hardware question that applies to other types of machines besides IBM compatibles, then either 'hardware' or this area is appropriate.

So what did you change that got it to boot from floppy?

Good luck finding the docs for that card. There were so many generic IDE adapters made back then ..

June 25th, 2006, 07:49 AM
That's ok, I wasn't complaining, it's just a little confusing as to where to post about a "borderline vintage" machine like a 486 :lol:

I've got it working by hard drive now, I have replaced the 425.3MB drive with a 20GB drive I had. It worked, booted and formatted (but to 503.96MB!) and now works with DOS 6.22.

So why doesn't it work with my 425.3MB drive ??? Both of the drives work perfectly when I attached them to a AMD 333Mhz with Win98 ?!?

June 25th, 2006, 07:51 AM
IDE is a really crappy spec .. A lot of the older drives are not interoperable with other drives or controllers. Your newer controller in the Win98 machine might be more tolerant of drives reporting funny sizes or geometries than your old salvage controller.

June 25th, 2006, 09:24 AM
It's strange. I still can't get it to work with the 425MB drive. I've now swapped the 20GB for a 4GB one.

There's another problem occuring now (sorry).

I installed DOS 6.22, and when it boots there is an error message just after it loads the XMS driver:

ERROR: Unable to control A20 line.
XMS driver not installed.

HMA not available: Loading DOS low

Any ideas? It won't let me install Windows 3.11 unless I fix this, and I can't so far...

June 25th, 2006, 12:21 PM
Fixed it after playing in the BIOS settings. The 486 is (finally) alive! :D