View Full Version : Emulator that will Run Kaypro II, & Radio Shack Model 4, Montezuma Micro CP/M

March 13th, 2013, 04:55 PM
I'm trying to get My Radio Shack Model 4's Montezuma Micro CP/M Ver 2.31 to boot and run under the "MYZ80" Emulator. I can't seem to find the correct
information to get it working. The Emulator is supposed to be capable of running Different CP/M OS's, but I just cant find the correct information to make
it work.

Has anyone been able to run the Kaypro II, and/or the Montezuma Micro CP/M Ver 2.31 on an Emulator?

I've tried under Slackware 14 (32 Bit) running DOSBox, with myz80 ver 1.44

Ideas? Suggestions?

What about z80pack or YAZE-AG? I haven't researched them yet!



March 13th, 2013, 09:14 PM
What about z80pack or YAZE-AG? I haven't researched them yet!

I used z80pack as the starting point for my Heathkit H89 emulator - http://heathkit.garlanger.com/emulator/
Basically used the Z80 CPU emulator, but had to implement all the Heathkit specific hardware (ports, controllers, timers, etc.).


March 14th, 2013, 08:09 AM
SDLTRS (the fancier version of xtrs) is supposedly capable of running Model IV CP/Ms, with specific support for Montezuma Micro's version (http://www.classiccmp.org/cpmarchives/trs80/Miscellany/Emulatrs/xtrs/cpmutil.html).

March 15th, 2013, 06:03 AM
I've tried SDLTRS, but it has a few problems with Real Disk drives, which I never did get to the bottom of, so I sent Mark a detailed letter of the items
I have corrected. I also asked him to follow up on the Drive issues, but I don't recall seeing an update.

I've run Montezuma Micro Ver 2.31 on SDLTRS, so I know it works.

I looked through your Source code for trs_sdl_interface.c, and found the problems with the Drive Size,
Drive Step, and the difference for stepmap of 0 & 1 vs 1 & 2. I changed your source to match your
Documentation, (which also matches the xtrs code) so now it once again should match the command
line functionality of xtrs. Plus, your code now saves the correct parameters, and retrieves
the correct settings.

I still need you to find create a Keystroke sequence that reproduces the OLD CP/M functionality of CNTL C
to do a disk read. This will fix the problem of a system hang. If your included disk image at:


is loaded into drive B: and a DIR B: is executed you can duplicate the problem. If you then do a CNTL C
you will see the problem. The system will HANG, and the correct way to exit any CP/M system hang is to
do a CNTL C until it either exits, or gives a ABORT, SKIP, or Boot Message. at this point on my
Emulator I can't do a F8 or F10.

So, bottom line is there are three things left to do:

1. Merge my changes for trs_sdl_interface.c to your source fixing the previous problems.
2. Create another set of Keystrokes (like Windows C or ALT C) to replicate the functionality of xtrs,
and the code of xtrs that does a CNTL C, but using your new Keystrokes.
3. Update your Webpage HTML and Documentation for the switch -turborate x (where x can be 2 thru 5. Default of 5)
I think it was left out of the -switch commands.

Let me know if you agree with the changes.



March 15th, 2013, 10:51 AM

I can run Montezuma CP/M just fine under Model 4 mode in Matthew Reed's TRS32 emulator. That might be an option?