PDA

View Full Version : Board/Detection freeze at hard disk detection, why?



RaptorZX3
May 20th, 2013, 05:46 AM
I found that the board seem to freeze after detecting the hard disk. Here are 2 photos i took:
http://thumbnails104.imagebam.com/25546/fe9412255455954.jpg (http://www.imagebam.com/image/fe9412255455954) http://thumbnails102.imagebam.com/25546/d34562255455983.jpg (http://www.imagebam.com/image/d34562255455983)

When i remove the hard disk from this setup, it detect the CDRom "ATAPI CDRom"...something, it's a 32x cdrom drive (but doesn't boot from CD though), and it try to find a boot disk in the 3.5" floppy drive and (of course) it say "boot fail" etc.. (i'll have to create a Windows 98 bootable install floppy)

When trying to enter "512" in Sec (for Sectors, or "Bytes the Sector?") it says "E" for error, and seem to detect up to 8gb only.

Is it just something stupid like "your 40gb hard disk is too big or the ATA speed is too fast to be recognized by this old Pentium CPU" or something?
Because i remember the 3.5gb hard disk i had on my Pentium 200 MMX at the time, it had something written on it like "AT-compatible", it was a WD Caviar. Does that mean i should start looking for an old 3gb-10gb hard disk?

I tried resetting the CMOS, and restoring normal default settings (in the BIOS, you have the choice of "default, optimized, turbo")

i tested the 40gb hard disk on my other Pentium 3 computer and it get detected without freezing. So i just need to know if it's just too "new" or too big for the Pentium 1 MMX to get detected just right.

EDIT: i did more tests, and the setup, without a hard disk, after updating the BIOS to "R3.C0" (i created a system floppy with command.com on another PC with Windows 98, and placed BIOS flash software and ROM), is able to boot from cdrom drive.

Chuck(G)
May 20th, 2013, 08:19 AM
It's almost a lead-pipe cinch that your P1 system will only handle up to 8GB. A DDO may solve that--some IDE drives have a jumper to limit size reporting to 8GB. There are a couple of technical bulletins about this problem in the Seagate ftp site.

Stone
May 20th, 2013, 10:09 AM
I think that Chuck nailed it. 8GB is probably that system's limit. If so, a DDO will *not* resolve this issue -- only a BIOS upgrade will do what you want.

RaptorZX3
May 20th, 2013, 12:19 PM
well...i reformatted the hard disk (on my Pentium 3 PC), in FAT32, and the hard disk is now detected correctly and doesn't freeze. I remembered the 80gb and 40gb i have here are both formatted in NTFS, so that might have caused problems in detection(?). What's good is it detect the full size of the 40gb hard disk.

Now i just need to find a couple of PS/2 mouse connectors with the cable going to the board.
it should look like this:
13413

Unless you can tell me HOW to make a COM port work for a mouse with a COM-to-PS/2 adapter? Because i tried many ways, and it doesn't work.

Stone
May 20th, 2013, 02:17 PM
... I remembered the 80gb and 40gb i have here are both formatted in NTFS, so that might have caused problems in detection(?).Nope, the detection routine doesn't delve into the type of format on the partition(s). It will detect the drive's geometry with or without anything on the drive.

njroadfan
May 20th, 2013, 02:24 PM
The motherboard appears to be an AOpen AP53. The latest BIOS revision was released in late 1997, so it likely doesn't support the Int 13h extensions that break the 8.4GB barrier. Generally BIOS that have that support are dated 1998 or later.

RaptorZX3
May 21st, 2013, 01:22 AM
it does detect the full 40gb finally. But since it look like a big mess on the floor (everything held on boxes though), i packed it all back in those boxes, knowing it work, i won't be using most of those until i find an AT case to put them in.