PDA

View Full Version : Pentium 166(mmx) Hangs when executing programs in Pure DOS



Xeauron
June 14th, 2013, 01:08 PM
Hi all,
Glad to be here, I've got a question I'm hoping someone can help me shed some light on. I've recently built a pentium 166 computer (well I bought the base and added to it), but for reasons I don't understand it's hanging when launching programs (games mostly) in Pure DOS mode ( Restart in MS-DOS mode from Windows 98 ). I'll type DUKE3D for example and the cursor moves down two lines and sits there. The only way out is to hit ether reset or ctrl-alt-del and reset the PC.

The strange thing is that it works randomly, sometimes after I boot into DOS mode I'll go to run Duke again and it loads no problem, I come back to it an hour later and it hangs again. It's not something that's happening only when first turned on or after it's been on a while, it's just random as far as I can tell...

Programs work fine from F8 Command Prompt at boot up or if I select a custom Autoexec + Config when using the 'Exit to dos' shortcut. Though the Awe64 isn't working properly after doing this as it isn't detected, I've tried running the CTCM program myself and booting games, which works but I don't get any music (just says you should be able to hear music in Duke 3d setup but nothing is heard).

Specs:

OS: Windows 98se (fake service pack 1 installed) - Wouldn't even boot into MD-DOS prompt before I installed this
CPU: Pentium 166MMX
Board: SOYO - SY-5TF - 256k cache (Flashed with Wims BIOS up to 128gb HDD)
RAM: Samsung 32MB RAM
HDD: Maxtor 120GB HDD (2x Fat32 partitions --==-- 1x 14GB / 1x 99GB)
Floppy: 1.44mb (A) and 1.2mb (B) Installed
Drives: DVD Rom installed (working fine)
Video: 3dfx Voodoo 3 3000 (SD Ram Ver)
Sound: Sound Blaster Awe64 GOLD
Network: 3Com 10/100 Card - Can't remember the model but I can check if it's pertinent.
USB header bracket installed and working like a treat.


Anyone have any ideas on how to debug this thing, or how I can find out why it hangs?

I've been in and out of the BIOS and tinkered with almost every setting, actually I may have messed with all of them (obviously I've returned them to previous values afterwards).

Seems to be a problem only when restarting into MS-DOS prompt.

Thanks to everyone who reads this in advance.

Chuck(G)
June 14th, 2013, 01:24 PM
Start by removing cards down to the absolute minimum (start with the network card).

Stone
June 14th, 2013, 02:06 PM
Try booting from a floppy. DOS mode is not necessarily the same as DOS.

Xeauron
June 14th, 2013, 03:18 PM
Thanks guys,
Like I said before, if I restart into MS-DOS mode using a shortcut to create a custom Autoexec and config.sys then everything works fine, no problem. It also works if I hit F8 and go into command prompt when booting. The only thing that doesn't seem to function in those scenarios is the sound card, not sure how to set it up above and beyond running the CTCM program which should be all it needs. I'm just trying to figure out why it would hang after executing a program when entering dos mode from windows using the shutdown button.

I've tried disabling the on board USB, I have the BIOS, Video and System shadows disabled, I've tried memory hole at 15-16m, nothing seems to curb the problem.

If I have no drivers enabled for network or anything other than the sound card, could they (other cards) really be interfering here?

Agent Orange
June 14th, 2013, 03:21 PM
Try booting from a floppy. DOS mode is not necessarily the same as DOS.

Do what Chuck(G) & Stone recommended then check your RAM. Download this free program from the following Link: http://www.memtest.org/ .
You may want to do this before you tun-in for the night, as it's about exciting as watching grass grow. You need to isolate any potential RAM problems before you start in-depth troubleshooting. Good luck

P.S. The next think on my list (after thoroughly checking all mobo and CPU settings) would be the video card. Also, update your forum profile so we know where you are. ;)

Xeauron
June 14th, 2013, 03:54 PM
Hi again, thanks for all the advise :)

I've now got the sound working when booting into dos using a short cut with custom autoexec and config. So the major hurdle is over really. It's like a splinter in my mind now the fact is doesn't run anything if I select shut down into MSDOS though.

I've spent the last few days installing a Live! card in my P4 3Ghz rig (for DOS audio support as the audigy2 doesn't support it properly) and some Sata drives with win98 on there and ironing out conflicts so I can play some SVGA games on there and anything up to the early 2000s natively (blood ran like s**t on my 166 lol). That way I can switch between xp and 98 by selecting the boot device in the BIOS.

Anyway huge tangent (sorry) but I've been running HDD utils and ram tests on that rig to check everything was ok, I also ran memtest on my 166 out of curiosity at the same time, the ram came back fine. As did the HDD when I ran Hdat2 on there as well before I installed it. So the hardware is clean, the voodoo was flashed with the latest bios and is working fine, not had any issues from the sound card whatsoever since installation ether. I also reinstalled windows 98 from a different disc and the same problem occurs. Forgot to mention, problem also occurs with my cirrus logic card installed which is what the rig came with initially.

The RTC (ODIN) wasn't working when I got it so I modified that with an external button cell and holder and that's purring like a kitten now. But the original settings were obviously lost. However I've downloaded the manual and been through every setting and nothing remedies the problem. Wierd!

SpidersWeb
June 14th, 2013, 05:31 PM
One thing I wanted to mention is that being a PnP OS, when you start Windows 98 it may move things around.
You rely on the drivers to 'undo' this when you shutdown to MS DOS Mode - but some don't do a good job of this.

This could explain why it's fine on a fresh DOS boot, but not a Shutdown to MSDOS Mode. I had an issue like this on my Compaq, the S3 video card driver didn't restore video correctly, so I'd get a blank screen and not be able to see in MS DOS Mode - very annoying - but there was a hotfix. I'd keep disabling things (not BIOS features, but serial/parallel/USB etc one at a time) and removing things (like every card except video) until it stops happening - eventually you'll find the culprit (I hope). Might be as simple as needing an updated driver.