PDA

View Full Version : XT Adv. Diagnostics diskette creation



mikey99
July 27th, 2006, 07:05 PM
I'm having problems creating an Adv Diags diskette for my XT.
Anyone have any advice on how to do this ? I think the problems
I'm having are because the image is a single sided diskette (180K) .

I have the image file, XTDGS225.DSK

I've tried LOADDSKF and Dskimage tools but am unable to create
a bootable diskette.

I've successfully formatted diskettes in the XT using FORMAT A: /1

I then take these diskettes to my other machine, running Win 98
which has a 5.25 (HD) drive.

I run LOADDSKF xtdgs225.dsk b:
Starts to write but fails with an error "cant format target"

I run LOADDSKF xtdgs225.dsk b: /f /c
It goes to 2% and gives an error "cant format target"

I tried using a diskette formatted to 360K and ran
LOADDSKF xtdgs225.dsk b: /f /c , it completes
successfully but the diskette wont boot in the XT
Surprised this even worked because the img file is 180K

I also tried Dskimage xtdgs225.dsk b: 1:40:1:9
it started unpacking but gave a bunch of errors
"Error reading from file"

I used loaddskf many times , years ago, and don't remember it ever
being this hard.

Any ideas on this ?

Terry Yager
July 27th, 2006, 07:26 PM
If you're trying to write a DD disk with an HD drive, you'll prob'ly have problems (Mike can explain the problem better than I can). If you want to accurately write DD disk images, it's best to use DD (360K) drive, if possible.

--T

chuckcmagee
July 27th, 2006, 07:31 PM
"fdimage" claims to support that disk size. http://fdos.org/ripcord/rawrite/fdimag15.zip

It is true about trying to use a DD drive instead of a HD one. Track step size is twice as big on a DD drive.

mbbrutman
July 27th, 2006, 08:21 PM
I would run LOADDSKF under native DOS, not Windows.

If you are having problems with it still, then I can send you a raw disk image of the diags disk. A loaddskf image might not be compatible with the utilities that others have mentioned because loaddskf can do compression and it adds meta-data to the file.

mikey99
July 28th, 2006, 10:58 AM
Thanks for the advice, I made a DOS boot diskette, put loaddskf and the
xtdgs225.dgs image on the diskette, booted, ran loaddskf xt225dgs.dsk b:
and it worked perfectly. Booted the diskette in my XT fine.

Now for the real problem :-) I recently acquired an XT from the original
owner, who claims this has been in storage since 1985. I believe them
because this system looks like new, even the keyboard and power supply
has no dust and it had the original box. Before shipping the system to me the owner was able to boot from the hard drive. After receiving the system
unfortunately the hard drive will not boot. As a matter of fact I cannot
access it at all. This has the original Xebec controller with a Seagate ST412

DOS 3.3 FDISK tries to start and gives an error "Error reading fixed disk"
I've tried low level formatting from the Adv Diag diskette,
the red light comes on, I hear some clicks in the drive, followed
by some clunks ....
the format runs for about 5 minutes and then just ends
with no error message or anything.
I think this should take an hour or more....
Running a seek test then fails, with an error "Check drive and adapter"
Fdisk still fails...

Even tried SpinRite, it gives a message that it can't find any fixed disk
subsystem in the PC. Have tried reseating the cables and adapter.

So, I'm thinking either the drive is toast, or possibly ....but unlikely the
adapter is bad. I dont think the owner parked the heads or anything
because he couldnt find any of the docs or software.

Is it possible to test this drive in an AT system ? I have an RLL
controller which I could use to see if its accessible at all. I think
I will need to low level format the drive with my RLL controller,
to test it . Probably need to make sure it doesnt really format
as RLL, just MFM. I dont want to risk doing anything that could
prevent the drive from working in the XT.

mbbrutman
July 28th, 2006, 11:46 AM
Another score for pure DOS!

Onto the drive ...

You can move the drive to an AT with an appropriate controller. Don't bother moving the controller over though - that's designed for an XT, and the AT has it's own built-in hard disk BIOS. You will wind up low level formatting it probably a few more times, but that's not so bad. If it is an MFM drive don't format it with an RLL controller - that's not going to work. Formatting an RLL drive with an MFM controller will work, but will reduce the advertised capacity of the drive.

A low level format on an XT with an original drives takes a very long time - over an hour I thought. So if the low level format from advanced diags stops quickly, that is probably a failure. The controller is probably good, otherwise it would not have attempted to try to format the disk. The disk might be suffering from 'stiction' - look it up on Google for more than you ever wanted to know. But remember, even though the drive might seem like toast, don't start slapping it around and mistreating it. You'd be a little cranky after sleeping for 21 years too.

mikey99
July 28th, 2006, 06:57 PM
I tried doing the low level format again, while watching the drive
with the case removed. The drive appears to be spinning I can see a large flywheel below thats turning. When I start the low level format the clicking
noise is coming from a small device, a stepper motor I think, located on the
right side of the drive. It clicks a few times, then the small arm on the motor starts turning very slowly counter-clockwise, while a slight clunking noise
can be heard. When the arm reaches the end of travel , after about 5 minutes, the format ends, and returns me to the prompt for diagnostics. At this point the arm is still at the point of end of travel. I tried running the "measurement test". This test causes the arm to move from one end to the other successfully several times. The selection on the diag menu, just says "Format Fixed Disk", it doesnt specify low level, but I guess that whats its trying to do. I also tried this format using the debug and int 13 calls I found somewhere on google, I get the same symptoms, runs for about 5 min then ends, but in this case I do get an assembler register dump, not that it means anything to me :-) Will the values give any additional clues ?

I realize I can probably pickup one of these drives pretty cheap, but as its original and this system is in such great physical condition, I hate to change anything. I still might try putting the drive in my AT and see if I can access it.

mikey99
July 28th, 2006, 07:19 PM
Ok, the diags do give an error, you just need to exit out of that section of the diags to see it, I didn't realize this before.

This one says: 1 fixed disk drive and adapter 1715 S

My friend Google says : 1715 Track 00 indicator error

which probably means the track 00 is bad, which probably means its toast.

chuckcmagee
July 28th, 2006, 08:14 PM
I'm not sure when "auto park drives" came about. Does sound like a "package toss 300g bounce" got the drive.

mbbrutman
July 30th, 2006, 06:35 AM
I don't think that it would hurt to try the low-level format again, or even on a different controller. You may not resolve the error, but just like on a floppy it is possible that it will clear up after a few attempts.

Luke
July 30th, 2006, 07:31 AM
I guess that drive died due shipping.
Did seller parked heads?

mbbrutman
July 30th, 2006, 07:45 AM
That is a bad assumption to make. Lots of things can kill a drive.

I can't find anything that tells me if the ST412 auto-parks the heads. If it does, then track 0 wouldn't be bad. If not, then a big bounce would have damaged some part of the platters where the head was over, and possibly the head as well.

Keep in mind these things are 20 years old, and they were designed to last 5. And they were absolutely crude compared to modern drives. Electronics age over time and it is possible that the drive is having a hard time even finding track0.

Just to make sure this isn't a thermal issue, the drive should be allowed to 'warm up' by letting it spin for a bit before doing another LL format. Also, there are 'drive exercisers' that will move the head around quite a bit doing random seeks, which is good for redistributing built-up lube that might be bunched up on particular tracks.

Luke
July 30th, 2006, 08:36 AM
In late '80 drives had auto-park. ST-412 is first HDD for XT's.

mikey99
August 15th, 2006, 04:00 PM
More updates on my ST-412 problems :-(

I tried attaching the ST-412 drive to the MFM controller in a PC/AT,
which has the original IBM controller. The controller has several part
numbers (IBM 68x3815 , 68x3814, WDC 60000110-04). I'm not familiar
with this part numbers, I thought the AT's all had a WD1003-WA2 or similar.
This controller works fine with a Type 2 drive I have.

This machine has a 386 motherboard. I set the drive to Type 1 in
the CMOS setup. The ST-412 drive is not even recognized by this controller.
The LLFormatting program I'm using gives an error that drive C: isnt
available.

With the ST-412 drive in the XT, attached to the Xebec controller, running
the LLformatting program shows bad tracks on all heads. This program
allows setting of the starting track for the format, and I've tried starting at higher tracks, like 200, 300, and all tracks show as bad. Which makes it appear that something else is wrong. I'd really like to try this drive on
another controller. Does anyone know for sure which controllers
the ST-412 would work with ?

Chris2005
August 16th, 2006, 01:27 PM
I also have various diag disks in ImageDisk format. If you want, I could send you those. You'll need a double density drive in a Windoze machine though. You could try it on something older, but Dave Dunfield recommends at least a 486.