PDA

View Full Version : Booting from Magneto Optical Drive with PCDOS



IBM Portable PC
August 26th, 2013, 03:19 AM
Okay, after much paying around I can boot PCDOS.

I had hoped to be able to boot a 3.5" 2.3GB MO, however they have 2048 Byte Sectors which PCDOS does not play with well......

I am now booting with a Trantor T130B and a 230MB MO and have ordered some 540MB, 512 bytes per sector disks on eBay.

Has anyone else played with MO booting DOS drives of late?

Cimonvg
September 27th, 2013, 08:58 AM
hello
did a quick test today. but can not read from MO drive on my 5150 (with Inboard).
SCSI controler : Future Domain 950 bios v8.2, and the bootscreen reads:
ID 0 LUN 0 TEAC OD-3000-00 Firmware Rev. 030a
..
ID 4 LUN 0 CONNER CP3040A-40mb-3.5Firmware Rev. 2.31

..and then the PC boots from the HD without error. But, in DOS (5.0 and 2000) there is only a C-drive no D-drive.
(yesterday the MO drive worked like a charm in a PentiumPro PC with NT4. The MO "floppy" appeared as "D" drive)
/cimonvg

k2x4b524[
September 27th, 2013, 10:18 AM
is it possible the MO might be not supported? Plus, don't you still need drivers to run the MO in dos like you would a cd-rom?

IBM Portable PC
September 29th, 2013, 01:57 PM
Drivers are not required however:

1. The media MUST be 512 byte sector and not the more common 2048 sector which DOS does not support natively.
2. The MO Drive MUST be in fixed disk mode and not optical disk mode.
3. The media CANNOT be formatted in Super Floppy format.
4. ISA 8bit SCSI controllers will not support drives over 1GB reliably, thus use 540MB media etc.

Tick off this list and DOS will boot!

Clem

Cimonvg
September 29th, 2013, 06:30 PM
thank you for info about what is required for MO drives..
but there has got to be some differences from card to card and bios to bios..
.. i tried my DTC-3250 scsi controler. And when i reconfigured like this:
"SCSI ID 1 CONNER CP3040A-40mb-3.52.31
SCSI ID 2 TEAC OD-3000-00 030A"
..then the DTC controler could acces the MO drive without driver. MO drive appeared as D-drive, when i booted on C-drive.
When mo-disk were replaced i had to reboot pc to get a refreshed directory reading. DTC writes in the manual " GSCSI4.EXE DTC3x50 removable cartridge DOS driver". (have not tried that GSCSI4 yet)
But. My Future domain 850 (with 950 chip), still do not read the drive ?? Have read the manual for the TMC850 and it says only a few lines about optical drives, MO not mentioned.
/cimonvg

IBM Portable PC
September 30th, 2013, 02:05 PM
1. Check to ensure MO drive is not in optical mode - most have a jumper for this. Must be in disk or hard drive mode.
2. Low level format and format the media with Windoze etc first using an MO Formatting tool from the drives manual, NOT as a Super Floppy.

I believe the problem is the MO drive or media and not the SCSI controller.

wesleyfurr
September 30th, 2013, 03:45 PM
The other riddle you need to solve is which SCSI ID boots. I think typically SCSI ID 0 is the boot drive. But...your details show your hard drive is ID 1 and booting. I would try making the MO ID 0 and see if that helps... Unless the SCSI card has a BIOS and lets you choose which one to boot from?

Wesley