PDA

View Full Version : DTC 7287 card floppy issues



SunDown79
September 30th, 2013, 10:06 AM
I am testing some cards and one of them is this Data Technology Corporation DTC7287 card.
See http://stason.org/TULARC/pc/hard-disk-floppy-controllers/C-D/DATA-TECHNOLOGY-CORPORATION-Two-RLL-ST506-412-driv-97.html#.Ukm2JlM8zzN

For now I am just trying to get the floppy drive going but it keeps on giving mee seek error's.
I am testing with a standard no thrills 3.5" 1.44MB drive (which I know is working, as well as the flatcable I am using).

The mainboard I am testing it on is a Syrix 286 board with 287 and it also has a simple BIOS.

As alternatives I tried disabling the BIOS on the card, changing the BIOS address, hardware/firmware select mode, but still the same.

Could it be that this card just won't work on this board and needs more like a traditional IBM AT board or so ?

Chuck(G)
September 30th, 2013, 11:38 AM
I've got one of those boards and I may have the installation instructions for it. I'm not certain (it's been too long) but I believe that this is one of the DTC cards that can be set up for 3 or 4 floppy drives--and that may be your problem.

I'll do a bit of checking. AFAIK, the FDC in these things is just a DTC-licensed NSC 8374.

Chuck(G)
September 30th, 2013, 06:26 PM
Located my 7287 and :happy: the installation guide. A curious thing about this adapter is to note that near the bracket (depending on the revision), you'll find pads for a DC37F connector that can allow for 2 external drives. Pretty cool...

Anyway here's the installation rundown.

1. There is no jumper W1, so don't bother looking for it.
2. W2 and W3 = both off, primary controller; both on, secondary
3. W4 - floppy data rate power up (250KHz, should be installed)
4. W5 - firmware/hardware select (hardware, should be installed)
5. W6 - auto-deselect enable (should be installed)
6. W7 - floppy precompensation, fixed/variable (variable, should be omitted)
7. W8 - must be installed
8. W9 - BIOS alternate address (C8000/D800; C8000, should be omitted)
9. W10 - BIOS ROM enable (enabled, should be installed)
10. J1 is the floppy connector; J2, J3, J4 are the hard drive connectors.

All of this agrees with the way my own board is set up. Use the usual DEBUG setup with G=C800:5 to start

SunDown79
October 1st, 2013, 09:59 AM
Very usefull info but it still wont boot a 3.5" (1.44MB) or 5.25" disk (360K and 1.2MB), and as long as I cant do that I cant use debug.
Or am I missing something ?

Perhaps the mainboard's BIOS is the culprit ? (eventhough its a 80286)

Chuck(G)
October 1st, 2013, 10:06 AM
Try booting with a 3.5" DSHD (1.44M) disk and W4 removed temporarily. It's worth a shot. I suppose that it's possible that the FDC circuitry on the 7287 is bad--there's a custom bit of LSI logic to support the 765 controller. I trust that the 286 motherboard doesn't have its own FDC that's causing conflicts.

I never had issues with my own card and used it quite a bit in the day.

SunDown79
October 1st, 2013, 10:30 AM
The 286 indeed has nothing onboard itself so nothing there that can get in the way (it is some Syrex board though and my experience is that they are a bit "weird" sometimes).
The seek error's are pretty random it seems and also just now I once got a RAM error.

I am going to put this card away for a bit I think and pick it up again when I have my AT out (even less tech that can get in the way ;) )

SunDown79
October 1st, 2013, 11:25 AM
Ok ok, I couldn't help myself, dug up the IBM AT already, replaced the IBM card with the DTC card and......same same.
So well, onto the other cards, if anyone reading this wants the card, let me know (it is a pretty card) :)

SunDown79
March 2nd, 2018, 11:31 AM
Ok ok ok, so I just posted this in a free-give-away post but now I found another one of these cards, sooooo, I am going to try that card with the jumpers it came with (which seems to be the default settings).
One question; the W4 (Floppy Data Rater jumper) when would you change that ?
Ow and I just read that you need to set drive select to 2 on the drives ? I presume that that is 2 if you start with 1 ? My drive's have DS0, DS1 etc so my DS1 is 2 correct?

modem7
March 2nd, 2018, 01:28 PM
Ow and I just read that you need to set drive select to 2 on the drives ? I presume that that is 2 if you start with 1 ? My drive's have DS0, DS1 etc so my DS1 is 2 correct?
Yes. The DTC7287 installation guide includes, "Drive Select Settings: All instructions regarding the drive selections assume that the Drive Selects are numbered 1-4."

Chuck(G)
March 2nd, 2018, 03:53 PM
I probably have the DTC installation leaflet for the thing, if you're interested.

modem7
March 2nd, 2018, 08:08 PM
I probably have the DTC installation leaflet for the thing, if you're interested.
If that is the Installation Guide you write of, then it is already available online. Example at [here (http://minuszerodegrees.net/manuals.htm#DTC)].

Chuck(G)
March 2nd, 2018, 09:48 PM
That looks like it. I've also got detailed documentation for several of the DTC SCSI controllers (not just installation guides).

SunDown79
March 3rd, 2018, 08:35 AM
Thanks guys, had a look at the documentation and I should be doing things right, there's nothing special about the installation it seems.
I even swapped the VGA card with a MDA card I have lying around and used my trusty 5151 monitor, just to see if there was perhaps some conflict but still no go.
The only thing I could perhaps think of is a problem with the terminator ? But then it also wouldn't work with the original controller I was thinking.

So right now when I turn on the system the motor runs for a split second from turning on the system and then nothing, no seeks, nothing. I am soooo lost on this.
I cant imagine me having two of the same controllers both broken.

Not giving up yet though, tips ?

Chuck(G)
March 3rd, 2018, 08:48 AM
Shouldn't the motor be running continuously? Do you perhaps have a cable on backwards?

SunDown79
March 3rd, 2018, 08:55 AM
If the cable would be the wrong way around then the light would burn constantly and the motor also run continuously (is my experience).
But lets just turn it around to see what happens.

SunDown79
March 3rd, 2018, 09:59 AM
As expected, when I turn around the cable the light burns continuously and the drive turn continuously.
So the cable orientation I have been using is correct.
Just to be sure everything else was still working I just put back my 62X1132 card and that works instantly.
I'll just give all the contacts a good clean as a next step.

Ow could anyone explain jumper W4 on the card ?

This is what is says in the manual :

W4 - Floppy Data Rate Jumper
The W4 jumper is used to control the power-up data
transfer rate for the floppy drives. The DTC7287 uses
the low-density 250kHz rate as a default because it
provides a power-up pathway for both high- and
low-density disks.
Installed: 250kHz
Not Installed: 500kHz

Chuck(G)
March 3rd, 2018, 10:19 AM
Isn't that pretty much self-explanatory. 250KHz says that it will set up the FDC initially for a DSDD floppy. 500Khz says the same, but with a DSHD floppy.

In reality, it probably doesn't matter, because the 5170 (and later) checks for data rate and adjusts accordingly. So leave it installed.

SunDown79
March 3rd, 2018, 10:26 AM
Eureka! I've got one of the two controllers working for the floppy drive.

I noticed that the 62X1132 card was sitting a lot deeper in the slot then the DTC so as I test I first removed the metal plate from the first problem 7287 card, that did perform a little more action from the drive but still didn't booted. I then did the same for the other 7287 card and it did a proper seek and booted straight ahead into dos 3.3 :)
Now the question is why the first controller still doesn't work, could it be a bad ROM or so ?

SunDown79
March 3rd, 2018, 11:03 AM
Pulled the ROM and compared the contents with the one found on http://www.minuszerodegrees.net/rom/rom.htm and they are 100% identical so ROM seems ok.

Chuck(G)
March 3rd, 2018, 11:57 AM
I don't recall if the ROM gives any sort of signon, but if one does and the other doesn't, you might want to figure out why, since the ROM code doesn't depend on the drive functioning.

SunDown79
March 4th, 2018, 02:45 AM
Ok, so the defective card is definitively broken as the other card is 100% up and running now and if I swap it out with the same jumpers etc it doesn't do anything.
The problem at the end with the working card was the position in the slot, it wasn't down far enough.
After I bent the metal plate a bit it was just fine :)