PDA

View Full Version : PS/2 Model 30 8530-021 HDD WDI-325Q Boot problem



grayb
October 31st, 2013, 02:31 PM
Hi
Am rekindling a beloved IBM PS/3 Model 30 - 8086 - 20MB HDD MDI-325Q. Boots just fine from floppy. HDD is suspect.
Was readable and managed to get 95% of files off but would love to see Win 2.03 fire up again !
Started from repeated "Abort, retry, fails etc messages and so have been trying many HDD tools and forum posts to make progress

Current HDD boot error message is "Non System disk or Disk error"

if I do a dir on c - its takes some time after showing the list before coming back to the C: prompt. Lots of seeks going on.

I can copy files and md on c: but CHKDSK reports FAT 1 is bad

Trying to re-Format c: /s doesnt get off Track 0 Head 1 then says "Invalid Media or Track 0 bad - disk unusable"

NDD Disk Diagnosis gets through MBR, FAT and Dir structure ok but surface analysis shows up trouble in cyl 611 which I believe is used for the MBR and FATs

Its tough to find HDD tools that run on this 8086 CPU

So my questions are

1) Any tips on really rebuilding an accurate FAT with bad sectors marked ? even by hand !

2) Any idea where I can get a MDI-325Q on the east side of the pond ?

3) Anyone hacked the disk connection to use another type of HDD ?

Living in hope ....!

Stone
October 31st, 2013, 02:59 PM
Try SpinRite II... you just might get lucky. Of course, if you've already tried unsuccessfully to LLF the drive then it's probably too late as even SpinRite needs a valid partition before it can work.

NeXT
October 31st, 2013, 05:55 PM
Check the ribbon cable just to make sure it's snug. Also, which side of the pond are you on?

Stone
October 31st, 2013, 07:12 PM
I thought 'east side' defined it quite definatively. :-)

NeXT
October 31st, 2013, 08:23 PM
Oh, read that as "this side". :oops:

grayb
November 1st, 2013, 12:01 PM
Thanks for the comments on Spinrite II - havent tried that one - as GRC say that I have to buy V6 to get the old version. mmm. I'll have to dig around.

Anyway have also tried zap.com and build up from there. Also tried the WD LL debug commands at http://support.microsoft.com/kb/60089
but that didnt work - I dont know controller is actually in the PS/2 M30 - as none of them run.

It seems like Track 0 is bad (patchy) hence my MBR/FAT seems to pass NDD but fails in use

Anyone any idea if its possible to deal with a bad track 0 and so point MBR somewhere else ?

grayb
November 3rd, 2013, 01:26 PM
Oh, read that as "this side". :oops:

Hi and thanks for the comments

GRC Spinrite tell me that they cant fix a bad track 0.

have recabled the drive - no change

My conclusion is that drive is a brick.
So on to my Q2

So I am on the topic of compatible PS/2 drives. The PS/2 Model 30 drive had a non-standard connector and there is virtually nothing in the IBM Tech Ref manual.

So I see there are a bunch of 4head 17SpT drives that were used in the PS/2 M30
Mine is a WDI-325Q
Seems there are also
WDI-325N
WDL-320

Also seen on a listing
http://www.cizgi-tagem.org/vfiles/dms_dosya/2076/pc_engineers_vol3dl.pdf
WD-336R and others

Anyone any info on disk compatibility for the 8530 (not its the -021 which is 8086 not 286 model) ?