PDA

View Full Version : Need help. PCI USB card in vintage ASUS P5A-B Mobo



Springbok
November 13th, 2013, 06:06 AM
Hey guys,

I need your help.

I am building a vintage gaming PC. Everything is working, except for the life of me I can't get a PCI USB card to function properly.

The system specs are as follows

ASUS P5A-B SuperSocket-7 Mobo
AMD K6II+ 400 Mhz CPU
300W AT Power Supply
768MB Memory
Creative CT4500 ISA Soundblaster
PCI Network Card
AGP S3 Savage4 Graphics card
IDE to Dual Sata Card (installed in primary IDE)

I have a 2.5" SATA HDD drive that allows me to swap out the drive to whatever OS I want at boot. I have 3 drives. One with DOS 6.22, one with Windows 98SE, and one with XP. Everything works great, until I plug in the PCI USB card. I have tried 2 different cards now. One with a VIA chipset. When I plug this one in the system boots, but the monitor does not turn on and remains in power save mode. The second card has a NEC chipset. The system boots, and the monitor turns on, but windows XP crashes left right and center. XP won't even repair with it plugged in. The repair crashes. Tried re-installing XP, but that crashes too. As a matter of fact, FDISK hangs verifying a partition with it plugged in.

I have the AWARD BIOS updated to the very latest version. I have tried both enabling and disabling onboard USB.

This is the PCI device listing shown at boot:

Device Class, Bus#, Device#, Func#, Vendor ID, Device ID, IRQ

Serial Bus Controller 0, 2, 0, 10B9, 5237, 9
Network Controller 0, 9, 0, 10EC, 8169, 10
IDE Controller 0, 15, 0, 10B9, 5229, 14/15
Display Controller 1, 0, 0, 5333, 8A22, 11

Not sure why the IDE controller is showing as a PCI device. Also the serial bus info is the same irrespective of whether or not the PCI USB card is plugged in o not. That line does however disappear if I disable USB from the BIOS (irrespective of whether or not the PCI USB card is plugged in.

I have tried the PCI card in multiple slots, with the same behavior in each.

I am at my wits-end. Any help would be greatly appreciated.

Stone
November 13th, 2013, 06:17 AM
Does the onboard USB work OK when enabled?

Have you tried the PCI USB card(s) in other slots?

Springbok
November 13th, 2013, 06:47 AM
Yup, tried in all slots, same thing. I am waiting for the special 18-pin card to test the on-board USB. It is only USB 1.1, so I was hoping to get USB 2.0 working through the card.

njroadfan
November 13th, 2013, 07:49 AM
Odd, I have a P5A & P5A-B here and they worked fine with a USB 2.0/Firewire combo card. The Aladdin V chipset isn't all that great for AGP, but I never had a problem with PCI cards. Make sure the card is screwed in, It could be a weird grounding issue. Do the cards work on another motherboard?

Springbok
November 13th, 2013, 07:52 AM
Can you link me to the card you are using.... I will buy that exact one.

njroadfan
November 13th, 2013, 08:39 AM
It was a generic brand from CompUSA, long out of business. It uses ULi branded chips for both interfaces. Even works in Macs.

Chuck(G)
November 13th, 2013, 08:52 AM
I've used a no-name PCI USB card with my P5A with no issues. I'll check to see what chipset it uses.

Agent Orange
November 13th, 2013, 09:16 AM
Springbok:

That's a tough one. Do you have the manual for your mobo? If so, check page 23. It's a long shot but you may be experiencing IRQ problems. You may want to try and boot with only the USB PCI plugged in and work out from there. That's a real nice mobo and I hope you can get that little (big) problem worked out.

http://www.motherboards.org/files/manuals/1/p5ab-107.pdf

Springbok
November 13th, 2013, 09:34 AM
Yeah... have the manual.

Problem with the mobo is that you have to have the AGP card plugged in. Without the AGP, the mobo will error. I pulled all cards except the USB PCI and AGP, and still experienced the error. I thought maybe the AGP and PCI 1 were shared and fighting for the IRQ, but I put the card in the other slots and was seeing the same issue.

This is a GREAT mobo, and I am really hoping to make it work.

Chuck(G)
November 13th, 2013, 10:04 AM
I think the mobo will also work iwth PCI display card, but I don't know if that will solve your problem.

I like the motherboard also--actually have 2 of them. With a K6-2, they run XP just fine.

Agent Orange
November 13th, 2013, 11:00 AM
It should boot with a VGA PCI when the sequence is set to "PCI/AGP". You may want to reset your BIOS to "Default" while tinkering. Also, if and when using the AGP video card, is the AGP mini port driver loaded? Another thing to try is to toggle the on-board USB (PNP/PCI section) to off, as there may be a conflict with your USB PCI card.

njroadfan
November 13th, 2013, 12:12 PM
The machine here with the P5A-B is running a PCI video card (ATI All-in-Wonder) without a problem. Do ANY PCI cards work with that motherboard?

Chuck(G)
November 13th, 2013, 12:36 PM
I'll add that what I have is a P5A (ALi AGPSet chip), not a P5A-B, so my experience may not matter.

Springbok
November 13th, 2013, 12:44 PM
I do have a VooDoo 2 PCI Graphics card. I tried installing it, and it gave POST error beeps on boot. I did not set the card order to PCI->AGP. It was set to AGP-PCI. Will try that tonight.

orion24
November 13th, 2013, 02:56 PM
Use the one with the NEC chipset, especially if you are interested in Windows 98SE. I had no problems with the P5A and the NEC card. It worked fine under Windows 98SE, but the VIA needs 2000 or XP to properly function and it had more problems than the NEC even under XP.

When it comes to Windows98SE, best way to make it work is like this:

- Use the latest mainboard BIOS
- Under the BIOS make sure the overclock settings for CPU/RAM are stable. Leave PCI latency value needs at default, PnP OS to "NO", AGP Aperture size at 64 or 128.
- Install Windows98SE with a fresh install and no PCI card installed (only the video card)
- Update Windows 98SE with the unofficial patch from MajorGeeks: http://www.majorgeeks.com/files/details/unofficial_windows98_se_service_pack.html (this patch is newer than the one I used in the past and might contain USB2 drivers inside. The one I used did not)
- Install the mainboard drivers. Particularly the ALI chipset drivers.
- Install the PCI cards one at a time
- Install the unofficial USB mass storage controller driver for Win98SE

This was working for me. Since you have the OS already installed, I'd try removing all USB drivers and install the unofficial service pack and USB driver.

RWallmow
November 14th, 2013, 06:29 AM
Is this possibly a 3.3V vs 5v PCI incompatibility issue? Just a stab in the dark, I am not familiar with OP's card nor this motherboard, but I know SOME cheap chinese import PCI cards (I've seen it in cheap USB2 cards) incorrectly key their cards as "universal" (2 notches, to fit both 3.3&5V PCI slots) when they are in fact 5V (or 3.3V) only cards.

njroadfan
November 14th, 2013, 07:39 AM
The only machines I have ever seen on the market with 3.3v PCI slots were the early Powermac G5s with PCI-X. Otherwise your run of the mill PC motherboard had 5v slots. Just about every USB controller is 5v compatible. I'm still curious if any PCI cards are working at all on the machine. Throw in an Ethernet card or something and see if it works.

Springbok
November 14th, 2013, 08:02 AM
Yup

Ethernet PCI works.