PDA

View Full Version : Willem Programmers



NeXT
December 23rd, 2013, 11:54 PM
So I jsut finished my conversion of a Willem programmer from a single board to a fully enclosed unit.

http://i11.photobucket.com/albums/a166/ballsandy/Computer%20related/CGS_0433.jpg
http://i11.photobucket.com/albums/a166/ballsandy/Computer%20related/CGS_0561.jpg
http://i11.photobucket.com/albums/a166/ballsandy/Computer%20related/CGS_0295.jpg


I checked and double checked my wring as I assembled it and never found any problems. I've discovered a major issue while setting up to burn a 27C512.
If DIP switches 1 and 3 (or 6 and 7) are both on the voltage at the green power LED jumps form 5v to 12v and the onboard regulator that takes the 12v from the wallwart and drops it to 5v overheats until the thermal cutout threshold is reached. Looking at the schematic (http://www.j-cell.de/willem-eprom/files/willem_eprom/documentation/pcb3m/sch3m.gif) the 12v I'm using is isolated to a very tiny region of the PCB. Looking over my work again I can't see a place where there could be a short or miswired connection. What's even more baffling is it's ONLY if switches 1 and 3 are up (or again, 6 and 7). If only one of the two are on then it doesn't happen. Just to confirm with anyone else with a Willem, this isn't the result of no chip being plugged in or the PC not being connected, right?
I'm based off the version 5.0e PCB originally. This is how it looked before it was stripped of all its headers. (http://www.mcumall.com/forum/uploaded/tel/201093032347_2009SMD.jpg)

Chuck(G)
December 24th, 2013, 08:18 AM
Nice packaging! What do you do about 40-pin 16-bit EPROMs?

NeXT
December 24th, 2013, 09:08 AM
There's adapters available that let you read and dump chips that won't fit in any of the onboard sockets.

http://www.mcumall.com/images%5C16BitEPROMAdaptor40PinZIF.jpg

platis
December 24th, 2013, 10:53 AM
Very nice!:D What computer software do you use with it? And are you happy with it? Is it both USB and RS232?

NeXT
December 24th, 2013, 01:57 PM
The Willem seems to be an open source programmer, hence why there's a billion chinese vendors selling them for about $30. Apparently there's a utility for Linux but mine came with the software for Windows 8x/2K/XP. It needs a "true" parallel port so no USB and a 12V power brick is needed to manage some of the more exotic programming voltages. I will need to modify the HTML-based manual I got because a lot of unlabeled jumpers are now switches.

Edited: I think my issue was both I need to be attached to a parallel port and I was setting the seitches to the 3B mode which emulates (?) another willem where the dip switches are upside-down.
Anyways, amongst that mass of wires it works!

http://i11.photobucket.com/albums/a166/ballsandy/Computer%20related/IMG_4824.jpg

Can successfully read a 2cC512, verify its contents and unsuccessfully write back to it (the chips need a proper wipe and the programmer errors out when it finds an address with data).

NeXT
December 24th, 2013, 10:15 PM
Huh, this is odd behaviour.

So if I take a blank chip and pop it in, I can confirm it's blank. If I read the blank chip, then verify the chip to the image I just made, no issues.
Now if I were to pop in say a 27C512 BIOS from an IBM I can read it in and see good data but verifying it back to the chip fails. It bunks early on at two or three different address spaces. Sounds like one of the solder joints are bunk, right? Not quite. I can throw in another chip whose contents I can read back but it will fail at two or three OTHER address spaces on verification.

From both of the above, If I burn the read-in image to a known blank EPROM it will pass the burn but again fail verification at one of the spots the original chip bonked the verification on. I've also downloaded and tried burning an EPROM image but again, it fails the verification. I have not yet tried burning a bin file full of 1's because I'm not sure how to easily make something like that.

NeXT
December 25th, 2013, 02:36 PM
Okay, I was just tired.

I forgot that the bank of five switches that replace J1 and J2 are required to be set. Centering them as the same as no jumpers at all which didn't exist so all this time I was effectively ignoring that setting.
I simply selected 3 B and suddenly writes were good, reads were good and verifications were passing. Hurrah!

http://i11.photobucket.com/albums/a166/ballsandy/Computer%20related/Specials.png

Because my copy of the manual is in HTML I'm going to have to modify it so I can remember that a bunch of settings changed.