PDA

View Full Version : Compaq Portable I (NOT plus) support for hard disk controllers



cr1901
January 19th, 2014, 02:41 PM
Sorry if this is a semi-repost (inside a different subforum to get more exposure), but I'm not finding a lot of information regarding this topic.

It is to my understanding that the Compaq Portable I (NOT plus) can support hard drives. This (http://www.vintage-computer.com/vcforum/showthread.php?20515-just-got-a-nice-Compaq-Portable-(first-model)-today) thread from Mike Chambers appears to confirm this.

However, after trying two hard drive controllers, I've not been able to successfully communicate with the hard drive or the controller from my Portable. I vaguely recall that most hard drive BIOS use a specific interrupt to perform processing (besides hooking int 0x13 floppy disk services), and that the Compaq Portable I's BIOS does not support this out of the box.

To that end, what is required to get the Compaq Portable I to support hard drives? BIOS upgrade? Older controller?

I think my BIOS might be a later revision, since it recognizes 640kB or RAM. I assumed that it would be analogous to a Revision 2 IBM PC BIOS, which has hard disk support, but I guess not.

per
January 19th, 2014, 03:04 PM
HDD stuff is also done at Int 13h, so I suggest you first of all check where in memory the Int 13h pointer goes at boot. It is correct that many HDD controllers hook different interrupts in addition to Int 13h for various reasons, but the main action always happens at Int 13h.

Another thing you can do is to check the first few bytes at memory location C800:0000. This is where the BIOS extension on the HDD controller typically map to.

cr1901
January 19th, 2014, 03:29 PM
Both BIOSes show up at c800:0000, so that's not an issue.

Interestingly enough, while trying g=c800:0005 in the Seagate BIOS crashes the system (somewhat expected, since the controller is supposed to ask for formatting during boot*), trying g=c800:0005 in debug on my WD 1002-27x runs until debug stops at an STI instruction.

SpeedStor claims the Seagate BIOS is "not ready", while all communication with the WD 1002-27x ends in failure

*In the Portable boot, the Seagate BIOS banner pops up, waits for about 30 seconds, and does nothing. Control is then passed to the bootstrap routine. It doesn't seem to attempt communication with the drive. In the WD controller, the classic 1701 error pops up. So option ROM initialization in the Portable BIOS DOES work.

mbbrutman
January 19th, 2014, 04:08 PM
What revision of the BIOS do you have in your machine? C is the latest and I think that is required for proper add-in BIOS support.

Have you downloaded the Compaq diagnostics and run them? It is a two disk set - one to inspect the machine and one to run tests. The inspection routines will tell you the BIOS revision.


Mike

cr1901
January 19th, 2014, 05:21 PM
Compaq diagnostics thinks it's a revision C BIOS... however, it also thinks there's two floppy disks installed (I forgot to change the switches), even though there was no 601 error or otherwise at boot. Could that be the culprit?

cr1901
January 19th, 2014, 06:44 PM
UGGGGGGGGGGGGGGGGGGGHHHHHH!!!

You know how most MFM cables tend to support two drives, and one of them most often has a twist (which for the life of me I still don't fully understand)? Well, I forgot that if you have a single hard drive that is terminated, you're supposed to use the section of the cable BEFORE the twist. You'd think after 3 years after owning an AT, I'd get this part right by now.

Drive is recognized by the portable now... of course, I get "Drive Parameter Activity Failed" 0x07, when I try to initialize it... whatever that means.

cr1901
January 19th, 2014, 11:26 PM
My embarrassment gets even better...

I tried all my remaining MFM drives on the two controllers I had, and they all failed. Thinking something was up, I took out the main hard drive (the original CMI drive- still works Mike ;)...) from my PC/AT and installed a number of the tested hard drives in... they worked just fine.

... turns out, both remaining controllers I had were RLL controllers... I don't have any RLL drives except for the dying Kalok Octagon.

wesleyfurr
January 21st, 2014, 05:33 PM
Isn't it amazing how much you can learn from the school of hard knocks? :-) Glad you got it figured out!

Wesley