PDA

View Full Version : Trying to get a 5150 up and running...



commodorejohn
January 31st, 2014, 04:19 PM
I rescued me an IBM PC from the recycle center yesterday. It's a bit weathered cosmetically, but the innards appear to be in good shape. It's a 64-256KB board (not sure how much it's actually got in it) with a 384KB RAM card, a serial-port card, a floppy controller, an MFM hard disk controller with ST-225, and a Persyst MDA clone. Not a bad haul for $12, but there's a bit of a snag - it won't power on. By disconnecting things, I narrowed it down to a problem with the motherboard - with the power disconnected from the motherboard, the PSU spins up happily and powers the drives, while with the motherboard plugged in, even with everything else disconnected, the PSU fan just gives a little jerk and then sits there.

Given that the PSU will power the big ol' MFM hard drive, which has to draw quite a bit more juice than the board, I don't think it's a fault with the PSU, and since the board causes the same issue whether it's in or out of the case, it can't be shorting against the case. Therefore, I conclude that there's a fault somewhere on the board, but this is pretty much where my expertise with electronics repair ends - can anybody help me figure out where the problem is? I see something on the back edge of the board that looks like a fuse, but it's not a standard glass-tube fuse you can just drop in a replacement for...

Chuck(G)
January 31st, 2014, 05:16 PM
On the 5150, it's usually one of the 3-legged electrolytics. Check the power connector pins against ground with a low-range ohmmeter to see if any of the power rails are shorted. You can work from there if you find one.

commodorejohn
January 31st, 2014, 05:38 PM
Yeah, I ran through the procedure in the service manual, and the connection between pins 5 and 3 is a little over 2 ohms, less than half what it should be. I'm gonna go over the 3-legged caps to see what I can find...

commodorejohn
January 31st, 2014, 07:05 PM
What I'm finding with the multimeter is that most of the caps show around 2 ohms, but there's a couple that are close to the 1k/∞ marker. Are those the faulty ones?

modem7
January 31st, 2014, 08:34 PM
Try the 5150 diagnostic procedure [here (http://www.minuszerodegrees.net/5150_5160/MDC/minimum_diag_config.htm)].

commodorejohn
January 31st, 2014, 09:23 PM
Try the 5150 diagnostic procedure [here (http://www.minuszerodegrees.net/5150_5160/MDC/minimum_diag_config.htm)].
Thanks for the tip. It led me to remove the caps on the +12v and -12v lines, and it's now powering on. I'll get a couple replacements from Mouser, but the guide says it's safe to run it without in the meantime, so huzzah!

commodorejohn
January 31st, 2014, 09:54 PM
It's running DOS 3.3 with Spinnaker DOS Manager, and apparently it belonged to Travelers Insurance...heh. I wonder when it was last in field use...

Edit: and here she is...
http://i.imgur.com/iYfiUjz.jpg?1?3609

modem7
January 31st, 2014, 10:40 PM
I have added your repair to my list at:

1. Goto http://www.minuszerodegrees.net/index.htm
2. Select link: 'History of 5150/5155/5160/5170 Motherboard Failure at the VCF'

commodorejohn
February 1st, 2014, 04:26 PM
Hmm, having a little difficulty here. I'm trying to establish serial communications in order to get some files copied (my intermediary system with a 5.25" disk drive is temporarily out of action,) but I'm having a heck of a time getting it to work. After setting the serial port on my Win2k machine to identical parameters as the serial port on the 5150 (9600,N,7,1,) the 5150 will happily send data to the Win2k machine (as tested with "copy con: com1:") but for some reason it won't pick up data going the other way - sometimes it will give an "abort, retry, ignore, fail?" prompt, or most of the time it just won't do anything, sitting waiting for data it won't pick up until I Ctrl+C out of the copy operation. I admit I'm not an expert on serial communication, but this is kind of baffling - the two ports should be set to the same parameters (and I've tried it at lower baud rates just to be sure, as well,) and I'm using a known-good null-modem cable. Does the fact that it works one way but not the other suggest that one of them is DTE and the other is DCE, and I need a straight-through cable instead? I'm lost...

Stone
February 1st, 2014, 05:50 PM
IIRC, this topic or one quite similar to it has been discussed in depth in another thread. I don't currently remember the thread or it's specific conclusions but I believe if you can temporarily get that 5" disk drive into the W2K machine you will then have implemented the simplest solution.

commodorejohn
February 1st, 2014, 06:01 PM
Not likely, it's a laptop. Although I might be able to do that with that Athlon box I've got kicking around...just seems like a lot of trouble to go to versus using the serial port...

Caluser2000
February 1st, 2014, 06:11 PM
I think Chuck linked to a program which allowed direct port access quite a while back but can't for the life of me remember the name of it.

Chuck(G)
February 1st, 2014, 06:24 PM
No, you need a "null modem" cable. That means each (DB25; convert the signals for DE9 connectors) end has 4-5 and 6-8-20 jumpered, 7 straight through to pin 7 on the other end and 2 and 3, swapped and connected to 3 and 2 on the other end. Are you using HyperTerm? It can handle a variety of file transmission protocols--dig it out of an XP distro if you really need it.

What comm program are you using on the 5150 end?

Stone
February 1st, 2014, 06:29 PM
No, you need a "null modem" cable...He's got that:

http://www.vintage-computer.com/vcforum/showthread.php?41258-Trying-to-get-a-5150-up-and-running&p=312541#post312541

commodorejohn
February 1st, 2014, 06:30 PM
I am currently using a null-modem cable, and I know it's a good one. I did make an attempt with HyperTerm, but I haven't gotten so far as to try any file-transfer protocols because A. the 5150 doesn't have any comm software on it, and B. it won't even receive plain text at the moment, even though it's perfectly capable of sending plain text.

Chuck(G)
February 1st, 2014, 09:03 PM
Let's see if your async card is receiving. Try a loopback connection (2-3, 4-5, 6-8-20 on a single DB25) and see if your serial card receives what it sends. It's not unusual for the line receiver IC on a card to get zapped by stray static discharge. I assume that you have some sort of terminal program on the 5150.

commodorejohn
February 1st, 2014, 09:10 PM
No, no terminal or other comm software on the 5150, I'm aiming to get one of the trick ASCII-only Kermit bootstraps onto it if I can get the freakin' serial working.

Gordon Zaft
February 1st, 2014, 09:27 PM
I wouldn't expect your serial ports to work if there's a problem with your +12 and -12 on the system since I'm pretty sure you need that for RS-232 comms.

commodorejohn
February 22nd, 2014, 06:11 PM
Just curious - I've got a Tecmar Bosun serial/parallel/gameport/timer card from the Compaq Deskpro I have, which is dealing with some issues at the moment. I'm thinking of installing it in place of the IBM serial card. Does anyone have information on the jumper configuration for this sucker, and/or software for reading the RTC? It shouldn't conflict with anything except the parallel port on the MDA, I'm just wondering.

modem7
February 22nd, 2014, 07:06 PM
Are you aware that you have the ability to transfer files to/from your 5150 via 720K diskettes?
See [here (http://www.minuszerodegrees.net/5150_5160/720k/5150_5160_boot_using_720k.htm)].


Just curious - I've got a Tecmar Bosun serial/parallel/gameport/timer card ... and/or software for reading the RTC?
Clock software for the Tecmar Captain card is [here (http://www.minuszerodegrees.net/rtc.htm#Tecmar)]. It may also work with your Tecmar Bosun card.

commodorejohn
February 22nd, 2014, 07:16 PM
You know, I wasn't. Thanks for the tip, I might just have to give that a try.

commodorejohn
February 23rd, 2014, 10:15 PM
I wouldn't expect your serial ports to work if there's a problem with your +12 and -12 on the system since I'm pretty sure you need that for RS-232 comms.
Well, I finally got around to replacing the caps on the +/-12V lines, but that didn't resolve the serial issue. I did narrow it down to being on the laptop end, though, since I tried connecting one of my terminals to the 5150 (using the same cable) and it talks with it just fine both ways...I'm gonna say "screw it" and just give the 720KB disk thing a try as soon as I find where the heck I put my Molex-to-Berg adapter for power...