PDA

View Full Version : Keyb.com crashes XT Clone



diskettenfett
February 8th, 2014, 06:48 AM
Hello,

I have a strange problem with an XT clone I recently received.
It seems to be an 8088 @ 4,77 MHz, 512 KB RAM, 3,5" MFM harddisk with 20 MB and Hercules Video.

After I resurrected the HD, it booted Commodore DOS happily and ran fine. However, as the harddisk suffered from stiction when I got it, I decided to reformat the disk using the controller's routine via debug. There was only DOS on the hard disk, so I had nothing to lose. The format went fine, no bad blocks at all.

Then, I tried to reinstall IBM DOS 3.3 which I own as original disks.
The disk booted fine and asked for date and time. I hit return once to skip entering the date, then it asked for the time and I wasn't able to enter any numbers or skip via the return key - the system crashed. Ctrl + Alt + Delete didn't give me any reaction, I had to push the reset key. I can replicate this behavior anytime.

The problem seems to be Keyb.com, because if I skip autoexec.bat by hitting ctrl+c on bootup, everything is fine, the system boots up to the prompt and I am able to use the machine reliably.
Whenever I manually load keyb.com after a successful boot (by skipping autoexec.bat), the systems hangs shortly after running it. It doesn't matter which keyboard layout (GR, US, UK...) i choose.

I remember owning a Panasonic portable 8088 XT clone years ago which had exactly the same problem: It crashed when using keyb.com on IBM DOS 3.3. I tried different DOS versions back then, and by coincidence, I tried a Commodore DOS (3.2?) bootdisk which worked fine with this machine.

Now I am curious as whether this is a known problem and what exactly causes this behavior. Any ideas are greatly appreciated. :-)

Thanks a lot,
Alex

SomeGuy
February 8th, 2014, 07:04 AM
Did you back up the Commodore OEM DOS software? 2.x and 3.x OEM versions of MS-DOS usually included customizations needed to make machines work 100%, or in some cases at all. In fact there wasn't even a "vanilla" Microsoft DOS release until version 3.2.

Unfortunately, I am not aware of any copies of Commodore OEM MS-DOS "floating around" out there.

Stone
February 8th, 2014, 08:15 AM
Sounds like if you remove keyb.com from your autoexec.bat file your problems will be over. It doesn't get much simpler than that. :-)

Agent Orange
February 8th, 2014, 11:47 AM
If you are in the US, I wouldn't think you would need to re-map your keyboard unless you're just experimenting. here's a couple of links that may help you out.

http://www.easydos.com/keyb.html
http://help.fdos.org/en/hhstndrd/base/keyb.htm