View Full Version : Nonstandard rates in HyperTerminal

February 11th, 2014, 11:52 AM
While working the Teletype project I noticed that HyperTerminal can't keep up with received text in native 7-bit mode but has no issues keeping up in 8-bit mode with forced 7-bit receive.


Is this a "feature" in HyperTerminal or more tied to the serial port hardware on the machine possibly emulating modes?

February 11th, 2014, 12:04 PM
What were the rest of your settings for both cases? I doubt that it's a hardware issue--more like handshaking.

February 11th, 2014, 12:13 PM

Only variables are that with 8 data bits I force 7-bit receive in the ASCII setup, otherwise I get garbled input.
I can switch flow control to Xon/Xoff but that doesn't change much.

February 11th, 2014, 03:02 PM
Try Mark parity (or Space, I don't reall) and 2 stop bits. That, if I recall correctly, is the usual TTY interface.

February 11th, 2014, 03:28 PM
Nope. That doesn't seem to be working. Give me a few minutes to pull out and try a real terminal.

Edited: Bizarre. I copied the settings into my VT100 and had no issues receiving from the teletype in any terminal mode. Copied the VT100's settings back to HyperTerminal and the problem returned. Let me try another computer.

February 11th, 2014, 03:38 PM
While you're at it, try RealTerm (http://realterm.sourceforge.net/). Lots of flexibility and configurability.

February 11th, 2014, 04:04 PM
Tried on an older Windows 98 laptop.

What the.....

So after some fiddling with your settings I found just adding Mark parity fixed it.


So I try the identical settings back on the other machine. No dice. Give me a few more minutes to try RealTerm.

Edited: that did it.

Not a problem. I can't remember the last time I ever had a problem with HyperTerminal. Odd.

Edited: Just Noticed that RealTerm indicates frame errors. After some fiddling I got both RealTerm and HyperTerminal behaving normally by setting to 110, 7, E, 1.

February 11th, 2014, 09:43 PM
Nice--but how do you know that your "S" key works? :)

February 12th, 2014, 12:57 PM
I did that how many times and didn't notice?


Doug G
February 12th, 2014, 07:49 PM
Another thought, possibly you need a different stop bits setting. Real teletypes used 1.5 or 2 stop bits iirc, and rattling around in my brain were stop-bit related problems on old 110 baud acoustic couplers.

February 12th, 2014, 09:15 PM
In RealTerm I was getting UART frame errors if I had 2 stop bits.

Doug G
February 13th, 2014, 06:55 PM
In RealTerm I was getting UART frame errors if I had 2 stop bits.Oh well, it was just a guess.