PDA

View Full Version : ADM-3A memory & communication issues



stragulus
February 22nd, 2014, 05:59 PM
Hey,

I have acquired a couple of ADM-3A serial terminals from the good old 70's, and none of them work. One of them has some rust spots that have caused ic's to break their legs, so I'll skip that one for now.

The first one, let's call that the Almost Working one, appears to behave as you'd expect. It came with a RG512 graphics card that was having issues, so I simply took that card out of the loop. Without it, it appears to work just fine. In half duplex mode, I can type characters and they appear on the screen. Line feed, return, clear etc all work as expected. When I short pin 2 & 3 on the modem connector, it even works in full duplex. However, for the life of me, I cannot get it to connect to anything.

I have an old pentium-M laptop with an actual serial port (db9). Hooked it up with a db9<->db25 adapter to the modem connector of the ADM-3A. I configured it as 8-bits data, 1 stop bit, no parity, and 9600 baud. In the terminal application on the laptop (ZOC Terminal), I configured it as a direct serial connection with 9600 8N1. Configured it to ignore the carrier detect. I get nothing though. Tried a couple of the other baud rates, same thing. The ADM-3A is configured in rs232 mode. I've also tried a cheap usb<->serial adapter but that thing is apparently so buggy I've just given up on that as I have no other serial device to confirm that it even works.

Any idea on how I could tackle this issue? According what I could dig up on the terminal, that should simply do the trick.


The second one is also challenging. It also does not connect, but it also has some character display issues. They can best be explained by a simple video (sorry about the music, I couldn't disable the audio): http://www.youtube.com/watch?v=wt350Cxbpn4 .

I think I know where to locate the memory IC that probably causes the $ sign to appear every now and then. Additionally, I expect there to be an issue with a counter given the strange duplicate lines and other not-entirely-random patterns on the screen. How would I locate that? And better; is there a way to trace issues with defective IC's in-circuit? I'm perfectably capable of swapping out IC's, but I have no experience with debugging live circuits, nor do I have the tools for this. Any advice on the matter would be greatly appreciated.

barrelshifter
February 23rd, 2014, 08:26 PM
Are you using a null modem cable? If not, you can get an adapter for a few dollars at the local electronics store.

NeXT
February 24th, 2014, 09:44 AM
I second that. You will require a Null Modem cable to connect the terminal to a modern computer, otherwise your RxD and TxD pins are reversed.

MikeS
February 24th, 2014, 10:46 AM
Test with a loopback adapter first, to eliminate any issues with the cable, baud rates, etc.:

http://www.ni.com/white-paper/3450/en/

Just connecting pins 2 and 3 together might even work.

stragulus
February 24th, 2014, 05:23 PM
Test with a loopback adapter first, to eliminate any issues with the cable, baud rates, etc.:

http://www.ni.com/white-paper/3450/en/

Just connecting pins 2 and 3 together might even work.

I tried that and that works. I didn't think to cross rx/tx though, so I'm impatiently awaiting delivery of a null modem cable now. Hopefully that will get the one terminal going.

edit: Yes, success! A little ductape and determination turned into a contraption with crossed wires, so I finally got the good one to connect!

Here it is, displaying a login banner for a MUD:

http://bram.name/pics/adm3a-outerspace-small.jpg

As for the other terminal, I'm thinking of rigging my Raspberry Pi as a simple logic analyzer using https://github.com/richardghirst/Panalyzer . With that, I hopefully can pinpoint the IC's that are bad. I think the counter at D10 is bad, which is a the character row counter. With the raspberry and a level shifter I should be able to hook up its 4 GPIO pins to 4 data lines of the counter and inspect if it properly counts up or not. I've done simple measurements on the 2102 1K memory IC's that I suspected are bad using my multimeter on the diode setting, but so far they all measure ok. I hoped for a simple short, but alas, no luck.