PDA

View Full Version : IBM 5150 Memory Error Help Needed



Springbok
February 23rd, 2014, 07:24 AM
Hey guys

So although the system I bought looks cherry on the outside, the Mobo seems to have a memory error.

It is a 64-256 board with ver 3 bios. The error I am getting is 4055 201.

I thought this meant the bad chip was in the 4th bank.

I pulled all the chips except bank 1 which are soldered. I changed the dip switch settings to indicate 1 bank and tried both the 128kb and 160kb dip switch settings.

Now I still get a memory error that start with 10xx.

Looking at the link below, an error code starting with 4 indicates an error on a memory expansion board. Problem is, I DON'T HAVE a memory expansion board plugged in. The only card I have plugged in is a Hercules card. I thought it may be the card so I plugged in a VGA card, but I get the same error with that.

http://www.minuszerodegrees.net/5150/ram/5150_ram_64_256.htm

Does anyone know if it is possible to test the banks sequentially like this? Does anyone know what size each bank is? Since it is 640KB, I just assumed that each bank is 160KB. This is driving me nuts.

Thanks

Stone
February 23rd, 2014, 07:35 AM
How can there be 640K on a 64K-256K board? :-)

The error is on the ram expansion card, not the motherboard.

Pull the card, adjust the switches and see if the error goes away.

And since you say you don't have a card you must have the switches set wrong.

Springbok
February 23rd, 2014, 07:53 AM
I'm such a noob and idiot. Face/Palm. Thanks stone. Set it to 256KB and all is well. I will go stick my head in the sand now/