PDA

View Full Version : IBM laptop PS/2 mod L40SX



Giulio Giulio
March 2nd, 2014, 12:46 AM
Hi all guys,

(first of all sorry for my english) I have this old laptop which I tried to make it run after many years. "Last time" (maybe 10 years ago) I can still remember it was working, dos 5.0 and Win3.1 were installed. But now, when I tried to switch it on I can hear the hard drive running and the monitor swithcing on (but remaining black with the backlight), then, after a couple of "beeps" from the speaker, operating system doesn't start. Is it becuse the internal battery is gone?
I tried to start the pc with the l4sx reference diskette or the msdos boot diskette, but nothing happens, only the two "beeps". Any suggestion? does anybody knows what kind of error code is the two beeps? Can I run any kind of diagnose to focus the problem?

Thanks a lot
Giulio

17529

mbbrutman
March 2nd, 2014, 08:44 AM
You can find a lot of information the web for this machine. I would look here first:

http://hpholm.dk/L40SX.html

If the CMOS battery is original then it surely is dead by this point. The machine actually has three batteries - the CMOS battery, a small battery to keep the memory "warm" while the machine is in standby, and the big rechargeable battery. They are all going to be marginal at this age at best. The CMOS battery is easy to find. I did not replace the other two batteries; I just run it using power from the wall and I don't use standby.

The hard drive is going to be another problem. The Connor hard drives these machines use all die due to old age even when not used. The good news is that a laptop IDE drive should work. I replaced my Connor drive with a "Disk On Module", which is basically FLASH storage that emulates an IDE hard drive:

http://www.brutman.com/L40SX_DOM/L40SX_DOM_Upgrade.html


Mike

Giulio Giulio
March 2nd, 2014, 01:31 PM
Hi Mike,

thanks for your reply. After posting my question I started browsing inside the forum and I found those useful links you told me. As first step, before any check on the hard drive I think I will just replace the two internal batteries (still the original ones and most likely dead after many years) and see if the operating system gets back from death. If not I'll try someting else...

Cheers

Giulio