PDA

View Full Version : Networking WfW and Windows 8.1



fjk61011
March 29th, 2014, 05:17 AM
I have a network and am having difficulty connecting WfW and Windows 8.1. I can ping both PCs but neither show up on their file managers. Windows 7 has no problem seeing the WfW PC.

luvit
March 29th, 2014, 05:41 AM
Can you network your win7 & win8 PCs?
This would be a good start, if you haven't done this.

fjk61011
March 29th, 2014, 07:14 AM
Yup. Sharing and all that is set.

SomeGuy
March 29th, 2014, 07:52 AM
You might consider trying a Freenas server as an intermediate. I find that useful as it also supports Apple file sharing that can talk to classic MacOS.

Later versions of Windows will need a registry setting changed to allow NTLM V1. At least hopefully that is still in Windows 8.1. BTW, NTLM v2 can be added to Windows 95.

The ability to show up in the server list or network neighborhood is dependent on one of the machines on the network acting as a browse master. Putting a Freenas server on the network might fix that, as a "server" it should take over the role of browse master from any clients.

But you can also manually add server names to your LMHOSTS file. Then at least you should be able to try and connect to a share by specifying its UNC path.

fjk61011
March 29th, 2014, 09:15 AM
You might consider trying a Freenas server as an intermediate. I find that useful as it also supports Apple file sharing that can talk to classic MacOS.

Later versions of Windows will need a registry setting changed to allow NTLM V1. At least hopefully that is still in Windows 8.1. BTW, NTLM v2 can be added to Windows 95.

The ability to show up in the server list or network neighborhood is dependent on one of the machines on the network acting as a browse master. Putting a Freenas server on the network might fix that, as a "server" it should take over the role of browse master from any clients.

But you can also manually add server names to your LMHOSTS file. Then at least you should be able to try and connect to a share by specifying its UNC path.

I shall give it a whirl later on

kb2syd
March 29th, 2014, 09:40 AM
I believe that by default there is an encryption setting in 7 and 8 that isn't compatible with other windows SMB networking. You have to disable it on the 7 and 8 machines. I run into this all the time when authenticating an older machine to an newer server.

Try this:
Windows 7 has forced encryption on samba traffic. You need to disable it from local security policy, go to (on your windows machine):

control panel -> administrative tools -> local security policy

There find folder

local policies -> security options

And change following policies to following settings:

Network Security: LAN Manager authentication level: Set Send "LM & NTLM responses"

Network Security: Minimium session security for NTLM SSP based (including secure RPC) servers: Disable Require 128-bit encryption

fjk61011
March 30th, 2014, 09:22 AM
I believe that by default there is an encryption setting in 7 and 8 that isn't compatible with other windows SMB networking. You have to disable it on the 7 and 8 machines. I run into this all the time when authenticating an older machine to an newer server.

Try this:
Windows 7 has forced encryption on samba traffic. You need to disable it from local security policy, go to (on your windows machine):

control panel -> administrative tools -> local security policy

There find folder

local policies -> security options

And change following policies to following settings:

Network Security: LAN Manager authentication level: Set Send "LM & NTLM responses"

Network Security: Minimium session security for NTLM SSP based (including secure RPC) servers: Disable Require 128-bit encryption

The Windows7 & WfW pc connects no problem.

It's the Windows 8 that won't connect. Only the Pro version has "local security policy

luvit
March 30th, 2014, 11:03 AM
.
post #2 - all new with correct information compared to my earlier post
Here are instructions from another forum, I think I had to add a line into the registry (a missing line that is in these instructions).
perhaps this is useful information for Windows 8, also -- luvit



Hi,
Based on my experience, DOS is not compatible with Windows 7, and I understood that disabling smb version2 didn't resolve the issue. For clarify the issue, please let me know if you try the steps correctly:
Step One: Disable SMBv2
1) Run the command below to disable SMB2 on win7.
sc config lanmanworkstation depend= bowser/mrxsmb10/nsi sc config mrxsmb20 start= disabled

2) Set the following registry key to 0 to disable SMB2 on the win7.
HKLM\System\CurrentControlSet\Services\LanmanServe r\Parameters
Value name: Smb2
Value type: REG_DWORD
0 = disabled
Note that: you must reboot the Windows 7 after changing this. (luvit did not reboot and had success, ymmv -- luvit)

Step Two: Reset the password on your DC.
Because we found the password or username is obviously rejected by DC during the authentication, so we only want to make sure if the password and username is 100% correct. To do this, please reset the password on the DC, then try the map drive again in the DOS.

Step Three: Check the NTLM on your DC
If there is no problem with your credential, then please export the MPS report on your DC for checking the configuration of your NTML and the event logs in the Security. Disable the GPO on your DC:

Network Security: Do not store LAN Manager hash value on next password change - SET TO DISABLE

If there is any concern, please feel free to let me know.

Thank you.

fjk61011
March 31st, 2014, 04:43 AM
.
post #2 - all new with correct information compared to my earlier post
Here are instructions from another forum, I think I had to add a line into the registry (a missing line that is in these instructions).
perhaps this is useful information for Windows 8, also -- luvit


I'll try that and report back.

fjk61011
March 31st, 2014, 05:09 AM
not getting anywhere with step one. just gives me Options info

fjk61011
March 31st, 2014, 05:48 AM
.
post #2 - all new with correct information compared to my earlier post
Here are instructions from another forum, I think I had to add a line into the registry (a missing line that is in these instructions).
perhaps this is useful information for Windows 8, also -- luvit

http://support.microsoft.com/kb/2696547

I used the info here. disabled smb2. set registry to false. key/local machine/ system/currentcontrolset/services/lanmanserver/parameters

I can now see the WfW pc from windows 8.1

the 8.1 doesn't show up on the WfW pc.

Agent Orange
March 31st, 2014, 05:59 AM
the 8.1 doesn't show up on the WfW pc.

Are you running 32 or 64 bit Windows 8.1?

fjk61011
March 31st, 2014, 06:14 AM
64-bit win 8.1

fjk61011
March 31st, 2014, 06:24 AM
ok I can copy to and from the WfW from the Windows8.1

That was my goal all along.

fjk61011
March 31st, 2014, 08:21 AM
not getting anywhere with step one. just gives me Options info

It was bowser with no r, as opposed to browser

SpidersWeb
April 2nd, 2014, 11:00 AM
I can now see the WfW pc from windows 8.1

the 8.1 doesn't show up on the WfW pc.

That's how you want it.
Windows 8 gives up on it's need for encryption and secure passwords etc to connect to the old machine, but keeps the requirements when other machines try to connect to it.

fjk61011
April 3rd, 2014, 06:31 AM
I can now copy files from the Windows 7 PC to the PS/1 WfW PC using the Windows 8.1 PC.