View Full Version : F800 ROM error on 5150 16KB-64KB board

August 31st, 2006, 11:18 AM
I'm having trouble with a very old IBM Personal Computer...

When I flip it on, I get a long beep and two short beeps, then it'll either boot into the BASIC ROM (V1.00!) or halt with the error "F800 ROM".

When I turned this system on for the first time in a few days, it booted into BASIC, but after running for a while I got some gobbledy-gook all over part of my screen and it froze like that. Power-cycling just gave me the F800 ROM error again.

I think the problem might be DIP switch-related, because I did change the settings when I took the two third-party memory expansions out...I'm pretty sure I got the settings right but I could be wrong!

Does anybody know the origin of this error, likely causes or solutions?

August 31st, 2006, 11:38 AM
Well, that's bad.

F800:0000 is where the system ROM or BASIC resides. It's the last 32K of memory in the memory map before the 1MB boundary.

You might have a loose chip on the motherboard - look for the BIOS chips and make sure they are inserted fully and that nothing is bridging the pins. Also look for anything else loose on the motherboard or cards that might be shorting an address line.

I think you are going to have to tear it down and build it back up to isolate the problem. Just the expansion cards .. That machine will boot just fine with a video card and the memory on the motherboard. Anything else is optional and should be removed until the problem is isolated.

Btw, when you do get it running I'd love to know the date on the BIOS. If that's a first revision BIOS I want a copy!

August 31st, 2006, 11:42 AM
canuck had similar problem and he replaced the chip.

It's problem with chip in U30.
Try to clean (no water ;)) it and re-seat few times.
Sometimes old chips just die...

By the way: When that PC was manufactured?

August 31st, 2006, 12:14 PM
I am not sure about the MFG date but it could be between 1981 and 1983, I guess...

I just turned it on again after letting it be and it booted into BASIC just fine...without doing anything, after a while, the keyboard won't respond.

If this was a modern PC I'd blame overheating.

I'll try to check the appropriate chip socket when I get the system home...

The only cards in the PC, by the way, are the mono video card and the floppy controller (which has a 37-pin external connector).

August 31st, 2006, 12:16 PM
Would be great, if the chip would need just re-seating.
And greater would be, if floppy drives are one-headed ;).

August 31st, 2006, 01:06 PM
How do I tell? I don't want to take them apart...

August 31st, 2006, 02:10 PM
How to tell what? The maufacture date? Or the BIOS date?

The manufacture date is usually on a sticky label between the PSU and right-hand drive bay. You'll have to open it up though.

You can tell the BIOS date by booting from the Advanced Diagnostics Disk - it will display the date there. There was a thread about creating one on here a while back. PM me if you need the advanced diag. disk.

August 31st, 2006, 03:53 PM
Actually I'd like to know about the floppy disk drives...they both have the IBM label on the front, full height, blah blah. They look just like the full-height drives in my TRS-80 Model IV.

The chip in socket U30 seemed to be a little loose, but pushing it in didn't help. I'll have to take it out completely and re-insert it, I guess.

August 31st, 2006, 04:04 PM
Not bother removing it and reinserting it. That risks more damage than is necessary.

Did you strip the floppy card out? Have you confirmed that there is nothing loose causing an intermittent short?

The BIOS date can be gotten using a simple BASIC program:

10 DEF SEG = &HF000
20 FOR I = 0 TO 7

August 31st, 2006, 08:51 PM
Risk damage? I've popped out more than a few DIP ICs in my day.

I already did it, to no effect, but it was worth a shot.

There's a good chance I can type that program in before it freezes :P but right now the PC is at the local gaming shop and I'm at home.

Nothing loose (such as power cables, memory ICs, etc). I'll try removing the floppy disk drive controller card when I get my hands on the system.

I can't seem to find any dates on the inside of the machine. I guess I'll try physically removing the FDDs to see if there are any date stickies inside.

Anybody have any idea what the long, short short beep pattern could be? I don't get an error message related to it and the computer boots into BASIC with no problems as long as the F800 ROM error doesn't pop up.

September 1st, 2006, 01:11 AM
This is first BASIC chip (there are three more in U31, U32 and U33).

And these beeps... look like you have issue with video card too:

One Long and Two Short Beeps - Video (Mono/CGA Display Circuitry) issue.

You can live with damaged BASIC chip, if you don't use it.
But it's v1.00... and there is big chence that you have first BIOS rev.

Great find ;).

September 1st, 2006, 07:56 AM
Figures, it's not the original video card - I left that at work accidentally (the big full-length IBM black white/parallel card).

It has some little SIIG video card at the moment.

September 1st, 2006, 08:28 AM
The dip switch settings might be incorrect if the card has been changed. Maybe you can put in CGA from your XT to test it (and set dip for CGA).

September 1st, 2006, 08:45 AM
Tragically, the XT is still at work, I quit my job, and the XT's CGA monitor was destroyed by demanufacturing (I do still have composite out from any of the cards I do have...).

I'll try and rescue the XT soon, one of my former coworkers will be able to help me out.

September 1st, 2006, 08:48 AM
Don't worry, I am sure you can save it!

To date the computer also check inside the metal cover. There is sometimes an ink date stamp on the "lid" and also on the inside of the front panel. You can also find dates on the mainboard. My XT says 8611 in the corner, which means the 11th week of 1986 :)

September 10th, 2006, 09:09 PM
I've been so busy I haven't had a chance to even go to the gaming shop and look at the PC, let alone take it home and work on it!

I'll try to get cracking on this one and the XT setup as well, I promise! :P

September 11th, 2006, 12:42 PM
you can relieve an ic component of it's oxides sometimes by simply prying it out and reinsterting it. Alot of times it makes sense to clean the whole board. Unplug all the chips PAYING ATTENTION TO WHERE THEY CAME FROM AN HOW THEY WERE ORIENTED (a digital camera is a good friend in times like that), lay them besides the sockets where they came from, and utilize this spray stuph that Radio Shock used to and may still sell. It might be available from Digi-Key and other places too. Wash it all down, let it dry THOROUGHLY, overnight might not be a bad idea, and plug it all back in. There might be other more common solutions you could wash or even submerge your board in. Water won't necessarily do much harm, but won't by itself remove oxides duh.
I used this method on my original Tandy 2000 when it became intermittent and whatnot. Worked like a charm. Oxides don't have to totally mess up a board. Can simply cause delays, and crashes too I would imagine.
I was told by some dude long ago that the serial number could be an indication of it's age. Supposedly the company I worked for had one of the first 100 5150's that rolled off the assembly line.
Another indication of somethings age (though not the final word) is the date that's stamped on nearly every IC. Look below the part number *usually*. F'rinstance, if it's a 74ls244, below that you'll see say 8234, which would mean it was manufactured in 1982, the 34th week. This applies to that particular IC, and generally every IC on the board will be similarl in age, but this isn't absolute with regards to the whole puters age.

September 16th, 2006, 10:01 AM
All right, I've taken a better look at it - no date on the mainboard, or the case, but there are of course dates on all the ICs now that I'm looking at the numbers correctly.

All of the chips date to before the 17th week of 1982 except for one: the chip in DIP socket U33 dates to the 22nd week of 1983, I suppose that's probably the BIOS chip.

A lot of the chips date from late 1981 but all are from well after August.

September 16th, 2006, 11:42 AM
there is the possibility that the unit had a bios upgrade, and is actually much earlier then the rom chip indicates.

September 16th, 2006, 03:38 PM
I'd say near probability myself. Haven't got around to snagging the original IBM monochrome video adapter yet...

April-May 1982 is a fairly early PC, if I may say so myself...

Terry Yager
September 16th, 2006, 06:38 PM
I'd say near probability myself. Haven't got around to snagging the original IBM monochrome video adapter yet...

April-May 1982 is a fairly early PC, if I may say so myself...

I'll throw one in the box with your keyboard.


September 23rd, 2006, 06:34 PM
This is first BASIC chip (there are three more in U31, U32 and U33).
Luke's info is probably based on the BIOS info I put in Mike's '5150 vs. 5160 FAQ' thread.

When I added the "(U29 BIOS = 8K, U30-U33 BASIC = 8K each)" text in the 5150 BIOS listings post, the bit about U29 being the BIOS chip was based on an Internet site I located.
Now that I have a 5150 of my own (with Technical Reference on the way), I just proven to myself that U29 is not the BIOS - the BIOS is U33.

U29 = F600-F7FF = BASIC
U30 = F800-F9FF = BASIC

And so Luke's, "This is first BASIC chip (there are three more in U31, U32 and U33)." should now be "This is second BASIC chip (there are three more in U29, U31 and U32)."

I've modified my post in Mike's '5150 vs. 5160 FAQ' thread, and I'll attempt to contact the author of the Internet site I mentioned.

September 25th, 2006, 04:31 AM

If you had a 5160 or a 5170, then I could have provided a replacement BIOS chip. Not the exact IBM part, but a clone.
Replacing a BIOS chip in a 5150 is a different story.

For those who will comprehend:

If a BIOS chip in a 5160 (U18/U19) or 5170 (U27/U47) fails, I can easily supply a replacement. I simply burn a commonly obtained 27256 EPROM. I have copies of those BIOS chips (as files) and I have spare 27256's. Obviously the replacement needs to be done as a matching set, and some BIOS' are motherboard specific (eg. 16/64K versus 64/256K).

Unfortunately, in the 5150, the BIOS chips are not so easy to replace. IBM used a PROM chip that nowadays is expensive to purchase. The AM9264DPC (or equivalent) only seems to be stocked by specialist IC supply companies that deal with orders worth $500 or more. Even if I obtained some, finding (or making) something to burn them is the second hurdle. Doable but a lot of expense/effort, particularly when you consider that periodically, 5150 motherboards can be obtained on eBay for around the $10 mark (plus shipping).
I can't find a pin-for-pin EPROM equivalent for the AM9264DPC.

A 'messy' EPROM based solution is on the Internet at: http://groups.google.com/group/comp.sys.ibm.pc.hardware/msg/a2a940c74751409e?hl=la&lr=&ie=UTF-8&oe=UTF-8
In that solution, a modified 2764 EPROM (after being burned) is used. The result will look bad. Not only will the chip have wires running over/around it, but a 28 pin chip is being fitted into a 24 pin socket (i.e. overhang on both ends).

Creating a binary file from a 5150 BIOS chip
In this example, a binary file named F600_U29.BIN is created that contains the contents of U29 (8K block at F600:0)

CX 0000
-MF600:0 2000 0100
Writing 2000 bytes