View Full Version : Drive not ready error when using Catweasel, 8in and 5 1/4" in drives *together*

April 20th, 2014, 09:44 AM
I have tried flipping things around and I have found that I can't get the following combination running together.

Tandon 848 (-02) 8"
Qumetrak 142 5 1/4"
Catweasel 4 (last one they made)

Cable from PC -->Catweasel-->cable to drives. I have a DBIT adapter for the 8". The twist end of the cable is installed on the intended A drive. BIOS matches drive types (5 1/4 360k or 5 /14 1.2m).

Assuming the terminator is in the right place (B drive) the Qume always works (it can be drive A or drive B) while the Tandon is also installed. The problem is, the Tandon only works if I detatch the drive cable from the back of the Qume.

For example, I get Drive not Ready error from DOS 6.0. The system correctly inspects the drive when it boots up (lights check A then B as part of the post without interference, no drive error code displayed, one beep post...).

So I was wondering before I go away to Easter dinner and have to take a break...Do I just need to activate the READY signal from the Tandon (assuming that there is a jumper for this, I need to check) ? Or is this a limitation of the "simulated 5 1/4" drive that I am attempting to do with the DBIT, or is it the catweasel? As I said alone the 8" seems to work as I expect.


April 20th, 2014, 10:14 AM
AFAIK, the CW doesn't pay attention to READY/, but rather determines ready status from the INDEX/ line.

I don't have a CW 4, but use a 3 all the time. I found that it didn't have sufficient drive capability to handle 2 8" drives, so I constructed a buffer board that provides the needed drive.

I don't care much for the 4--it has an FPGA that needs firmware uploaded. The CW 3 does not and is essentially a board that's very easy to program--not terribly different from a CW 1.

April 20th, 2014, 06:45 PM
So I was thinking...After trying to find something wrong with the Tandon 848 -02 that I have (P1 Index pulse seems ok)....If the 8" drive works fine whenever the 5 1/4 drive is unplugged, maybe try another type of 5 1/4" drive. Maybe the 5 1/4" drive is interfering with the inde pulse coming from the 8" drive somehow, or there is a "terminator conflict" or something....I swapped things around in every possible combination...I thought I read someplace that IBM branded Qume Trak 142's were not ideal choices for this kind of work. So, going on a hunch I made sure there was a terminator in the 8" drive (B/1) and switched in a teac YD-580 in place of the Qume Trak 142. It worked. Now for "catweaseling" I have an 8" and a 5 1/4" drive on the same system. The BIOS on my Pentium III does not allow for a 3rd drive (3.5"), at least not in an obvious way.

The YD-580 has HM and DS0 jumpered

April 20th, 2014, 07:13 PM
I just run the catweasel output to a DC-37 female on a bracket and plug in any drive I want as external. I've even got some oddball (e.g. 3.0" and 100 tpi) drives that work with this setup.

I do have a couple of Qume 142s; other than being a little power-hungry, I don't think that they're any worse than non-Japanese drives of the same era.

April 20th, 2014, 07:26 PM
Maybe there was something wrong with the Qume, I should try another one. I posted this experience to my web site, with better grammar and a mention of ChuckG....and will update if I learn more. huh thinks I.

But now I can start making and distributing images, which is really want I wanted to accomplish. thanks for your help.

April 21st, 2014, 05:00 PM
Just a follow up...I was able to image everything I tried...TRS 80 model 1, Apple ///, 8" CP/M disks. Pretty cool. Next I'd like to try a 100TPI drive as a 720K 3.5 see how that goes. My holy grail is the hard sectored Micropolis format, and the Northstar. Have not tried these yet. I want to work through what I have and get more acquainted with the hardware I already have.

April 21st, 2014, 06:10 PM
Chuck (and anyone who knows)
For Cromemco disks would the "closeness" of the timing to write at the beginning of the disk (for lack of a better understanding) make it easier for a high TPI drive to read and write these kinds of disks, and is that why it's hard to image them? Or is it all the controller's job?

Similarly, is there an advantage to using a higher TPI drive to image/write a hard sectored disk, or is it all just the right settings to nail the pattern? Or does the pattern need to shift track by track as you move up the tracks? I am starting to see why Andrew Lynch went the programatic route to accomplish the imaging task, but I need to learn more about how one would do this.