PDA

View Full Version : Booting old Dos's via Flash drive on a P4



Malc
May 18th, 2014, 01:13 AM
I recently started playing around with an old 2 gig flash drive, I flipped the RMB and windows XP sees it as a fixed disk, I set up Dos 6.22 on the flash drive with a couple of extra partitions and booted my HP P4 desktop and it booted into Dos no problems, i can access the extra partitions in Dos and XP just fine. I was quite surprised at how well my USB Floppy drive worked as when i use it in Windows XP it can be a bit hit and miss as to whether it reads / writes a floppy or not but in Dos it worked fine on all the discs i tried to read.

I wiped the Flash drive and setup Dos 3.3 which seems to work fine too, I haven't done any other testing yet.

With my HP having a nice clear 17" screen it's so much easier on my eyes, I'll try installing some old software later.

Anyone here running old software via flash drive on newer hardware ?.

Chuck(G)
May 18th, 2014, 08:30 AM
I keep a "rescue" system around on flash pen drive with DOS and a few utilties . Also a couple of live Linux distros.

Very handy when you need them.

Malc
May 21st, 2014, 12:30 AM
Yes very handy indeed, My main problem is lack of space even though i have gotten rid of 90% of my collection, It's amazing how fast that free space got filled up with new bits of furniture :-( At least the ear bashings are not so frequent any more. I mainly wanted to use a few old dos programs and this has worked out very well so far.

Mad-Mike
May 21st, 2014, 04:34 PM
I use my copy of MS-DOS 6.22 at work for some PC repair functions. Works great, I've run that on something as new as a XEON or Core I7.

Craziest thing I did to see backwards compatibility though was the time I put the black 360K Floppy drive in my Pentium-D dual-core box and played Microsoft Adventure and ran DOS on it off old floppies....I wish I still remembered how I pulled a nifty trick though where I managed to "reboot" DOS over itself....ie. something I did with a DOS command re-initiated MS-DOS's boot sequence (STARTING MS-DOS_) without having to go through POST again.