PDA

View Full Version : More Amstrad strangeness



Phil Saunders
May 26th, 2014, 03:41 PM
Hi people....

Another strange 'Amstrad only' problem I think .....

PC1512 DD with 20MB Hard Card fitted in the expansion bay.

Everything works exactly as it should. The hard drive was FDISKed to a single 20MB partition and configured with the original Amstrad disks, resulting in a dual-boot system (DOS/DOSPLUS)

Both the options work as expected.

The problem is - I can't find a way to produce a bootable floppy disk with this set-up. If I 'format a: /s' for example, the resulting disk produces a 'can't find fxldr' error on booting.

I assume this is because FORMAT has transferred the now non-standard boot sector from the hard drive to the floppy disk, which does not have the dual boot software installed? Is there a way to get around this? I seem to remember having this issue way back, but I cant remember ever solving it!

Phil

krebizfan
May 26th, 2014, 04:08 PM
Have you tried using SYS instead of FORMAT /s? I think early DOS versions didn't have a /s switch available.

That is to say:
FORMAT A:
SYS A:
COPY COMMAND.COM A:

Phil Saunders
May 27th, 2014, 10:25 AM
Thanks for the reply - yes - tried that - same result

I've even tried 'building' a system disk the hard way - IE taking a disk that DOES boot, delete ALL the files (including the hidden ones), then copying the hidden system files from the problem machine to the disk. This works. If I then SYS this disk, then remove/replace the files again, the problem re-appears.

It definitely has something to do with the boot sector that is written by the system when it has the dual boot option installed (there doesn't seem to be a problem when the hard drive only has one OS)