PDA

View Full Version : Generic XT PC Hard Drive Problem



Phil Saunders
June 2nd, 2014, 12:26 PM
I have a no-name XT clone. It says 'Roldec' on the case, but no other identification inside or out.

This machine works as it's supposed to when fitted with a WD RLL controller card and matching 21MB MiniScribe drive (so I know the machine is basically OK).

I want to fit a 40MB drive - I have a ST351A/X jumpered for XT mode, and an Acculogic sIDE-1 (note NOT the /16 version)

With this combination, I get a LONG delay (about 2 minutes) in the boot process, but the machine eventually boots the floppy in the A: drive.

I can then access the built in LLF program with the usual debug g=c800:5 command (WD Super Bios Version 3.1), and (apparently) successfully format the drive. During this process, the drive can be heard stepping through the cylinders.

When the process completes, and I reboot, I get the same long delay, and FDISK gives ' Unable to access fixed disk'

I even tried an ancient copy of Ontrack Disk Manager written specifically for Seagate drives (although not this one). The DIAG module of this program gave similar problems, indicating 'time-out' errors whenever a read or write operation was attempted, although seek tests were successful.

I have reluctantly concluded that the drive is toast - does anyone have any other ideas?

Phil

Stone
June 2nd, 2014, 12:43 PM
You could try SpeedStor. If it still doesn't respond I'd sadly concur with the toast conclusion.

SpidersWeb
June 2nd, 2014, 12:48 PM
My ST351A/X has this cute sticker on it say "DO NOT LOW LEVEL FORMAT". The reason being that the drive has a different number of sectors per track - so a generic LLF will mess everything up. However, I did LLF mine, and it survived using the translation settings - 820 cylinders, 6 heads, 17 sectors per track. If you didn't use those settings - it might be worth trying again.

The delay is probably because the drive can't find the sector or track it's looking for. Hopefully this is because of a bad format, and not because of a mechanical issue.

Going back on old newsgroup posts I discovered that quite a few people killed this model by doing an LLF. But I also found posts of people who used the translation setting (like me) with success, and another person who jumpered for AT mode - and used Seagate's Disk Manager - although I'm not sure what version.

18940

Phil Saunders
June 2nd, 2014, 02:18 PM
No sticker on my drive. I used 976 x 5 x 17 because there is a (hand written) sticker on it with those numbers (which also works out at 42 meg). I'll try again with 820 x 6 x 17.

I agree that it's probably looking for a valid boot sector (I'm assuming that even if booting floppy it will still check so DOS knows if there's a C: drive or not) - question is as you say - is it a messed up format or failed drive logic? I'll persevere with it for a bit - of course the possibility exists that the controller is bad - but it's just a ROM and a few support chips, so unlikely?

I'll also try SpeedStor as Stone suggests - think I've got a copy on 5.25 somewhere.

george
June 2nd, 2014, 06:20 PM
First try the HDD on an AT machine with the proper jumpering and normal IDE controller.