PDA

View Full Version : SWTPC & PERCOM, No one warned me that it would be addictive!



JamesSpears
June 6th, 2014, 09:56 AM
Month I dug out my old SWTPC & PERCOM system. and thought I'd play around and see if I could get it work some. It has been siting around collecting dust and other debris for 25 years.

oops, No one warned me that it would be addictive! ;)

So the system:

SWTPC MP-B2 Mother board in original chassis.
Percom SBC/9
Percom LFD-400 disc control w/ dirve
Percom Electric Window
Boaz 64k DRam card
MicroWorks System Board psb-08


Processor card works ok, so does the LFD-400 and the MicroWorks card, the only causality of time is the Boaz memory card and monitor for the Electric Window. Using the serial port I have been able to work with the system and extract most of the data on disk to my host system. That combined with some old source listings of MPX/9 (Percom's "OS") I have been able to work in emulation and boot most of the system.

While searching for other things I'd like to have, like a MP-T card for it. I came across Bob Anderson's pages at http://www.corshamtech.com, He is in the early stages of cloning the SWTPC 6800 system. Much to my surprise, he was getting close to having prototype memory cards out. This will work out well and I expect to be able to boot the system on real hardware some time soon.

I have been having fun with tweaking the MPX/9 sources and adding some features to it.

Once I have the full system functional, I am thinking of working on porting Nitros9 for it.

--James.

JamesSpears
July 2nd, 2014, 09:12 AM
The prototype memory card I'm testing for Bob Anderson (http://www.corshamtech.com) arrived Monday it is a full 64k of static ram that can be mapped out in 4k chunks. I configured it for the lower 48k of memory and, put it in the system last night and did a quick check using the monitor to write and read memory everything looked good. I then booted MPX/9 for the first time on real hardware in about 25-30 years. I reconfigured the card for only 32k and repeated the experiment, everything worked fine. in both cases I verified that the OS loaded at the top of available memory as it should.

The system appears fairly healthy, I have some issues with the serial connection to the host, the LIST command only outputs one character at a time waiting for a key press from the user, probably the polling for cancel is not playing nice with the terminal software on the host. I also tried to load BASIC and Forth from floppy with out success. I'll have to investigate those issues.

All and all I'm a happy camper at the moment :-)

--James.

BobApplegate
July 3rd, 2014, 10:15 AM
It's Applegate, not Anderson. Don't worry, no offense taken ;-)

Thanks for the good news on the memory card! So now I've got an MP-S clone serial board and a 64K memory board tested and working... just need to finish debugging the CPU and motherboards and I'll have working system.

Bob

smp
July 3rd, 2014, 11:42 AM
James & Bob, welcome!

This is a very exciting project you are doing, Bob. I just signed up on your site, and I look forward to hearing about your progress.

I always wanted a SWTPC way back in the day, but I ended up going with an Altair, because that was available locally to me.

I anxiously await word on price and availability of your SWTPC clone!

smp

JamesSpears
July 8th, 2014, 01:57 PM
I have had Bob Applegate's 64k RAM card for a week now, and run memory tests repeatedly with no problems. I have tested everything $0-$BFFF,and $Dxxx everything else has dedicated devices. I am quite happy with the card. It is great to have my vintage (well mostly now) SWTPC/PERCOM system up and running.

--James.

JamesSpears
July 18th, 2014, 06:16 PM
More Progress on my old SWTPC & PerCom system. I found a copy of PerCom's Super Basic and it loaded just fine. Debugging the copy of FIG-Forth I determined that the patches made to make it work with the PerCom Electric Window and a parallel keyboard interface, so of course it would not work with the standard ACIA on the SBC/9 (what can I say it was 30 years ago and I did not know any better ;-j

The revised patches for console input/output are in-place and working :-) Now it appears the the Forth block read/write to disk are having some issues.

The homemade PIA card also appears to still work.

--James
"Computer... Computer... Aye. Hello computer."
"Just use the keyboard."
"Keyboard. How quaint."

BobApplegate
July 26th, 2014, 05:24 AM
I now have the complete board set running. The 6800 CPU board has 8K EPROM with SWTBUG and 8K RAM. The next step will be to test the other 8K RAM/EPROM socket to make sure it works for both devices, then putting BASIC into the EPROM which still has lots of free space.

The motherboard has one of my serial boards and the CPU board plugged in and works fine. It still needs more extensive testing but it's working.

However, I'm leaving tomorrow for a two week backpacking trek and will be off the grid completely until returning on August 10th. There should be enough time to get boards debugged, clean PC boards ordered/assembled to show at VCF MW.

Bob

JamesSpears
August 13th, 2014, 08:59 PM
Feeling much better now, Yesterday I put the new Psymon extension ROM in the system to add new monitor commands. I forgot that the Percom SBC/9 has all the IC's mounted pin 1 down :-( after debugging the dead system I determined that the -5v regulator circuit was fried, and noting else appeared damaged. Tonight I replaced the dead transistor, tested the supply and was able to bring the system up :-) I don't need any more foobar's like that...

I picked up a GQ-4X USB Universal Programmer and some AT28c16's and am happy with it, I have revised the Psymon extensions and everything is working as expected.

I have a working version of Forth again (fig-forth) and it talks to the disk and other IO devices ok now. I need to cleanup the main forth screen disk, it appears to have the sector forward and back links messed up.

stay tuned...

--James