PDA

View Full Version : IBM XT 5160 Motherboard fault



3pcedev
June 9th, 2014, 02:50 AM
Hi all (again!)

Most of you probably saw my earlier thread about the Laser Turbo XT POST problem... however now I have another one!

I also own a IBM XT (5160) which I decided to dust off (since the Turbo XT isn't going yet). As luck would have it this one wouldn't power up either......

I followed the excellent guide on minuszerodegrees.net about powering up / troubleshooting the 5160 and here is what I found:

- Cleaned the board with some Isopropyl alcohol.
- Checked PSU voltages - all OK
- Removed all ISA cards; set the video adaptor (Dip Switch) type to monochrome and powered it up.
- No beeps or any signs of life except the PSU running.
- Swapped ram from bank 0 to bank 1 (and vice versa). No signs of life.
- Put video card back in and tried again. No beeps or anything displayed.
- Tried another 8088 processor I had lying around - no go.

I also searched on these forums about repairs; but it seems that most people have short-circuit problems with capacitors. Since the PSU isn't cutting out it's not a short circuit problem. Even so I also visually inspected all the capacitors and couldn't see anything suspicious. The PC worked about 15 years ago; so I am guessing something has aged or corroded.

My guess is the motherboard is now a brick. Just thought I would see if anyone else had any ideas?

Also if anyone has a working motherboard (256k type) complete with RAM they would like to sell please PM me.

Just for interests sake the main reason I really want to get this one going is the history behind it. The last owner used it for simulation work in Chemistry (lots of mathematical computations). It's got a flying lead from the CPU socket to an expansion board with what appears to be a 80286 with a mathematical coprocessor (note I did actually remove this and test with a normal 8086 processor). It also has the biggest memory expansion card in it I have ever seen. If people are interested I can take some photos of the above.

Stone
June 9th, 2014, 03:25 AM
You could also try the chips from banks 2 and 3 in bank 0. I've found that where there's one bad ram chip there's a possibility of more bad ones. Keep in mind that if there happens to be one (or more) bad ram chip(s) in each bank you're not going to find the answer with this method. The only sure method is to replace the chips in bank 0 with nine known good chips.

modem7
June 9th, 2014, 04:53 AM
My guess is the motherboard is now a brick. Just thought I would see if anyone else had any ideas?
If I was in your position, one thing that I would try would be use of a Supersoft/Landmark Diagnostic ROM in place of BIOS chip U18.
One of the first things that the diagnostic ROM does is to get video up and running. Then it does the tests.
More information is [here (http://www.minuszerodegrees.net/supersoft_landmark/Supersoft%20Landmark%20ROM.htm)]. On that web page is also an image of the ROM that you can burn to a 27256.

3pcedev
June 9th, 2014, 05:16 PM
You sir are a legend. This will also be useful to diagnose problems with the Laser Turbo XT as well.

3pcedev
June 18th, 2014, 03:18 AM
Made myself a ROM yesterday - what a fantastic tool! Can't recommend this enough. The how-to says its a bit limited in what it does (and possibly has bugs in it) but I found it excellent to at least confirm the machine still had a working bus/logic/CPU.

Turns out I have bad RAM.... quite a bit of it actually. Something like 3 errors, 1 of which was in the first 16k. Rest of the board seems healthy.

For those interested I used a minipro TL866 EPROM burner I found on ebay. Its made by a Chinese manufacturer (autoelectric.cn); cost $40 and totally exceeded my expectations.

RAM is now on its way. Fingers crossed this solves it!

modem7
June 18th, 2014, 03:44 AM
That is good news. Thanks to Chuck(G) for the diagnostic ROMs.

Had the diagnostic ROM not worked (i.e. displayed absolutely nothing), then I would have suggested the deeper diagnostic method of using a POST card and a U18 ROM containing custom code (code that outputs to a POST card).

modem7
June 18th, 2014, 04:03 AM
I have added the failure to the list at http://www.minuszerodegrees.net/vcf_motherboard_failure_history.htm

3pcedev
June 28th, 2014, 01:26 AM
Hmm not so great news on this front.

I replaced the entire 256k of RAM on the motherboard. Hoping this would be an end of it I replaced the BIOS chip and powered it up. This gave me the blank screen of death (again).

Put the supersoft back in and it passed the RAM test; but then failed the interrupt 0 test..... I had a spare 8088 lying around so I took out the 80286 processor expansion board and put the 8088. It then failed the RAM test??? but passed the INT0 test.

After a power cycle it then passed the RAM and other tests which was odd. I then replaced the BIOS and it got as far as the memory test (about 100k) then the video corrupted and the speaker beeped continuously. After yet another powercycle it was the blank screen of death again. I reseated all the RAM and did some swaps; same result. Either it gets partially into the memory test (then screen corruption and lockup) or it just blank screens.

I'm 99% convinced there is a RAM controller fault. The mainboard isn't in great condition (think it's had mice on it); so for brevity's sake I have eBayed another one. I'm hoping the 80286 processor expansion works in the new board (no reason why it shouldnt). The INT0 failure is probably something to do with how it interfaces rather than an actual fault. As previously mentioned you need to take the supersoft ROM diagnostic results as a guide; it seems to have a lot of bugs.

3pcedev
June 28th, 2014, 02:11 AM
Also as promised earlier I have attached some photos of the 80286 expansion board.

Just in case the pictures don't show the requisite detail it has an 80286 processor and an 80287 math coprocessor on the board. Basically this plugs into the processor socket on the motherboard via the pictured ribbon cable. All it says on the board is 'Hypatec research' and 'made in Australia'. I have never seen anything like this before - but it seems to work.

The jumpers on the motherboard are set such that a coprocessor is NOT installed; so it obviously requires some software in which to operate.

I have no idea how it interfaces and if there are indeed any performance differences. When I last used the PC I was much younger and didn't realise what it was. I recall it was slow; slower than a 286 anyway. If I ever get it working I will try to learn how it works in more detail.

http://i296.photobucket.com/albums/mm170/81x-flow-xd/DSC_1793.jpg (http://s296.photobucket.com/user/81x-flow-xd/media/DSC_1793.jpg.html)

http://i296.photobucket.com/albums/mm170/81x-flow-xd/DSC_1785.jpg (http://s296.photobucket.com/user/81x-flow-xd/media/DSC_1785.jpg.html)

modem7
June 28th, 2014, 04:00 AM
I then replaced the BIOS and it got as far as the memory test (about 100k) then the video corrupted and the speaker beeped continuously. After yet another powercycle it was the blank screen of death again.
I presume that you are writing about the original BIOS ROM chip. That could be 'flakey'. Now that you have an EPROM programmer, have you tried burning a replacement?

For all 5160 BIOS revisions, either chip U18 or U19 can be replaced by a 27256 (or 27C256) EPROM.
ROM images are [here (http://www.minuszerodegrees.net/bios/bios.htm)].