PDA

View Full Version : HP/Apollo 425t



commodorejohn
July 14th, 2014, 02:55 PM
http://i.imgur.com/oUnT5o5.jpg
Nabbed this at the recycle center today for a paltry $10. I was guessing and trying to remember off the top of my head whether it was one of HP's FOCUS machines, since I love weird old architectures, but what the hey, I love the 68k too. It powers right up and reads from the hard drive without a fuss, but according to the manual I found online, it doesn't support using the serial port as a console, so seeing what's actually on it will have to wait until I get it into work tomorrow, where I've got a BNC-to-VGA cable and a monitor that speaks sync-on-green.

I'm curious, does anyone know where I can get a keyboard + mouse for this thing? I have no doubt that the recycle center already destroyed whatever might have come with this, though I'll check in tomorrow just to be sure.

Jack.
July 15th, 2014, 12:13 AM
Heh, you lucky devil! :p
Seems strange that it has no serial support. That would be plain awesome!
Could you post a photo of the back? It's highly likely that HIDs are proprietary, but maybe you can figure out something...

commodorejohn
July 15th, 2014, 05:24 AM
The keyboards are definitely proprietary - there's one jack for an Apollo/Domain keyboard (if it's set to boot Domain) and one for an HP-HIL keyboard (if it's set to boot HP/UX.) The rest of the ports are pretty standard - BNC video, SCSI, RS-232, AUI Ethernet, and an Apollo Token Ring (http://www.recycledgoods.com/product/27694-apollo-computer-inc.-015891-token-ring-network-card) card in the ISA slot. Anyway, the video works, and if I'm reading the memtest information correctly it's got the minimum configuration of 8MB RAM. It's apparently set up for network boot over the token-ring connection, as the hard disk is non-bootable, but it does try to boot from SCSI, so I could probably get it to boot off an external CD-ROM. I know a couple of the BSDs support it, but of course it'd be more useful with a keyboard and mouse.

lowen
July 15th, 2014, 06:24 AM
I have a PS/2 to HP-HIL adapter here someplace....

The HP 9000/425e could have either HP-UX or Apollo DomainOS installed; those are very different OS's, and have very different FAQ's.

The Apollo 0W3 video connector, if that is what that one has, is, IIRC, sync on green. You can find a lot more information by looking for the comp.sys.apollo FAQ, as well as from Jim Rees' website at http://jim.rees.org/apollo-archive/

I had a dozen DN3500's years ago; they are long gone, though, as they both took up too much room and generated way too much heat for way too little processing power. No, I don't miss them, actually, since DomainOS is just too weird in too many ways. It's just another Unix workstation for me; even though I enjoyed using them, if I want the vintage Unix workstation experience I have a couple of SGI's and several Sun Ultras i can fire up.

But I saw my old PS/2 to HP-HIL adapter not too long ago.....

This question would be more appropriate in the 'Unix' forum here, BTW.

commodorejohn
July 15th, 2014, 06:38 AM
The video is just three BNC connectors doing RGB with sync-on-green. (It's an HP 735 CRX framebuffer board.) Luckily, I already had a suitable monitor and a BNC-to-VGA cable I use with a 3w3-to-BNC cable on my VAXstation, so it wasn't any trouble.


I have a PS/2 to HP-HIL adapter here someplace....
I'd be happy to trade for it, if you find it :)


This question would be more appropriate in the 'Unix' forum here, BTW.
I suppose so. A mod can feel free to move it there, if they like.

lowen
July 15th, 2014, 07:15 AM
I found it; it's a Rose model CNV-HIL/PS. I have no idea whether it works or not, nor what sort of keyboard mappings or whatever. And for what it's worth, real HIL keyboards and mice are available on eBay, but they're not exactly cheap.

commodorejohn
July 15th, 2014, 07:41 AM
Yeah, I looked; I'd probably be shelling out $120 or so for a keyboard and mouse, and I certainly don't want it that badly. Such are the perils of legacy business equipment...

paul
July 17th, 2014, 04:57 PM
I have a 9000/735 and you can see the family resemblance. Aside from the video card the case, power/reset buttons and LEDs are similar if not identical. I looked at the service manual though and not much is similar inside apart from the cost-is-no-object construction.

commodorejohn
August 29th, 2014, 11:48 AM
Well, thanks to lowen I now have a PS/2-to-HIL converter (and I must say that, while I can't stand proprietary cabling/peripherals, at least HP had the sense to make their unidirectional cabling for HIL with keyed connectors!) Unfortunately, the boot ROM doesn't seem to be speaking to it - lowen didn't know for sure whether the thing worked, but since the boot ROM mentions a test for the presence of a Domain keyboard but not one for an HIL keyboard, my suspicion is that it's set for Domain/OS and isn't even checking. The service manual for this thing claims that you can switch the boot ROM to HP-UX mode by punching in C-F-Enter during the boot process, but this accomplishes nothing - I hope they don't mean that you have to do that from a Domain keyboard before you can use the HIL keyboard!

Anybody know anything about this?

Update: found the answer in the BSD hp300 FAQ - you have to press the Service button and reset the machine to get into the configuration menu, where it will respond to either keyboard. Kinda silly, but at least it works now.

Jack.
August 29th, 2014, 02:06 PM
Whoa, I'm glad you sorted it.
That seems a pretty neat 68k system, which version of HP-UX does it run?

PS.
Did you see my PM?

commodorejohn
August 29th, 2014, 02:53 PM
Curiously enough, it doesn't appear to run anything at the moment - the Domain/OS side of the boot ROM claimed the hard disk was non-bootable, and the HP-UX side isn't even listing it as a bootable device. What's odd is that it's a whopping 2GB (twice the size of what seems to have been the largest stock option for the thing,) so I can't imagine why it wouldn't have an operating system on it. As soon as I can figure out how to make a bootable OpenBSD CD for the thing, I'm gonna poke around and see what the drive does have on it.

lowen
August 29th, 2014, 04:44 PM
Update: found the answer in the BSD hp300 FAQ - you have to press the Service button and reset the machine to get into the configuration menu, where it will respond to either keyboard. Kinda silly, but at least it works now.

So the beast works? Cool.

commodorejohn
August 29th, 2014, 05:02 PM
Yep, my nice clacky Model M works just fine with it :) Haven't gotten to test the mouse yet since I can't boot anything with X at the moment, but I have no reason to think it won't be just as functional.

lowen
August 29th, 2014, 05:37 PM
Absolutely marvelous; glad it worked for you!

commodorejohn
September 11th, 2014, 01:10 PM
Can anyone tell me anything about the boot process on this sucker? I'm trying to get OpenBSD started, and I'm having a devil of a time doing it. I made two nearly-identical CDs, one with a standard ISO9660 filesystem containing the CD boot image and all the packages/etc., and one with that, but the CD boot image pasted into the first ~25KB of the ISO courtesy my favorite hex editor, as some of what I've read suggests that the HP300 boot process just loads the start of the disc into memory and executes it directly. Using the CD-ROM drive from my VAXstation (which is set for 512-byte sectors,) I managed to get the hacked version to boot once, at which point it started the BSD boot process and ran until it tried to read files from the CD, at which point it panicked because it couldn't read the disk label (I'm assuming because it's not expecting a boot image at the start of the volume.)

Since then, I haven't even been able to repeat the experiment, with either CD; it just sits there searching for a boot volume indefinitely. Both the HP manuals and the OpenBSD install instructions (http://ftp3.usa.openbsd.org/pub/OpenBSD/5.5/hp300/INSTALL.hp300) are spectacularly unhelpful. Supposedly you can press the spacebar to get a list of boot options, but doing so just pops up a prompt telling me to enter the boot device I want, without listing any options or giving me any idea what a valid boot device is. I know it can boot from the CD-ROM drive because it did, I just can't figure out how to make it do it again...

On the bright side, OpenBSD supports the framebuffer, and there's actually a whole 32MB RAM installed instead of just 8MB.

tingo
September 18th, 2014, 09:55 AM
and "help", "?" or even just ENTER at the boot prompt doesn't give any clues?

commodorejohn
September 18th, 2014, 02:57 PM
I got a little further with it before leaving to visit family for a couple weeks. Pressing the spacebar right off the bat once it's recognized the keyboard will make it list any boot files it finds, but it's still oddly spotty with the OpenBSD boot CD - sometimes it will recognize it, and sometimes it won't. More problematically, when it does, it still does that panic-because-it-can't-read-the-disk-label deal, and I can't just swap CDs because it doesn't show the BSD boot prompt (I need to check and see if it does that over the serial port.)

I did get ahold of a set of HP-UX CD images from the guy at hpmuseum.net, and these boot reliably, but there's a snag with that, too: it complains that the installation requires a disk of at least 55MB, but of course the drive in there is 2GB...

I'll get back to it when I return home.

Jack.
November 13th, 2014, 10:53 AM
Hi there, did you get it to boot after all?
-Jack

commodorejohn
November 13th, 2014, 11:09 AM
It's currently packed up after a cross-country move, but I did take another stab at it before packing. I put the BSD universal boot binary on the beginning of the hard disk, hoping that I could then use the bootloader-less BSD CD-ROM to install from. Unfortunately, it's still having difficulty getting past the whole "no valid disk label" thing, so I haven't actually gotten it up and running yet.

(Did image the hard drive before mucking around with it, though.)

Jack.
November 14th, 2014, 12:25 PM
Good thought! Did you try the netbooting procedure too?
- Jack