PDA

View Full Version : Strange behaviour from 5150 floppy drive controller



bobba84
July 20th, 2014, 07:46 PM
Hi guys,

I'm progressing in my 5150 build (still lacking a genuine case and power supply!) but have hit a snag. My floppy controller is insane!

Please view this youtube video to see what I am going on about:

http://www.youtube.com/watch?v=o4471qGULYY

I have tried two drives and two cables. I have not tried this controller in another motherboard or another controller in this motherboard as yet. I just wanted to see if anybody recognised this behaviour?

Thanks in advance for any help!

Bobby.

bobba84
July 26th, 2014, 04:44 PM
Sorry this is a duplicate thread. Can I delete it?

ibmapc
July 26th, 2014, 06:19 PM
Looks to me like the socket for the resistor pack is empty. On a 360k drive, if it is on the end of the cable, which yours is since it's the only drive, you need to install a resistor pack(Terminating Resistor) in that empty socket on the pc board on the top of the drive. I've seen some really strange behavior from drives without the resistor pack installed. So that might be all that's wrong with your setup. I believe it should be a 150 ohm resistor pack but I'm not positive if that's the correct value. Some one please confirm this for me.