View Full Version : AT&T 7300/UNIX PC RS232 terminal setup

August 16th, 2014, 07:25 PM
Does anyone have experience with setting up a dumb terminal to operate the AT&T 7300/UNIX PC?

I now have a working UNIX PC machine, and I have never done this before.

If someone could at least point me to the correct manual PDF download, that would be extremely helpful.

So far, fumbling around on my own, I found this menu, and set the device type to TERMINAL and speed to 9600. (this is the speed of my terminal, set to 9600-8-N-1)

I tried both with and without a null modem adapter (crossing only lines 2 & 3) between the RS232 port on the back of the 7300 and the "dumb" terminal

I appreciate everyone's ideas here. This is a great group!


August 17th, 2014, 05:40 PM
We just got a dumb terminal connection to work. Thanks to Neil at MARCH (https://groups.yahoo.com/neo/groups/midatlanticretro/conversations/topics/37166) and DoN at comp.sys.3b1 (https://groups.google.com/forum/#!topic/comp.sys.3b1/6wIubwEeaRg)

The full handshake null modem configuration worked! See the adapter I used here: http://bit.ly/Vx8Bfr

Here is what I have on my terminal now: The prompt appears boot-up of the UNIX PC, simultaneously with the prompt appearing on the UNIX PC built-in monitor:



Welcome to the AT&T UNIX pc

Please login: aj

Please type the terminal name and press RETURN: ?

The following terminals are supported for use with the Office windows and
menus. To select one of these terminals, respond to the prompt by typing
the numbers or numbers and letters shown in the first column.

Bad termcap entry
510a 510A - AT&T Personal Terminal
510d 510D - AT&T Personal Terminal
513 b513 bct513 att513
- AT&T Teletype
4410 - AT&T Teletype
4420 - AT&T Teletype
5410 - AT&T Teletype
5420 - AT&T Teletype
5425 - AT&T Teletype
610 - AT&T Teletype
620 - AT&T Teletype
PC6300PLUS pc6300plus 6300plus
- AT&T PC6300+
unixpc 3b1 pc7300 PC7300 s4
- AT&T UNIX pc
hp2621 - Hewlett-packard
tvi925 - Televideo
vt100 - DEC

<Press RETURN for more instructions>

Some other terminals may work with the Office windows and menus, but not
all terminals have been tested.

Most terminals will work with most character-based software on the
UNIX PC. If your terminal is "not supported", it will probably work
only for simple text and line-by-line data entry. Consult your Remote
User's Guide or the Hot Line for more information.

Please type the terminal name, '?' for help, or 'exit' to exit,
and press RETURN: exit

Welcome to the AT&T UNIX pc

Please login: root

Please type the terminal name and press RETURN: vt100

74% of the storage space is available.

# ls -l
total 707
-rwxr-xr-x 1 root root 0 Aug 16 21:54 .history
-rw-rw-rw- 1 root root 15360 Aug 16 21:55 .phdir
-rwxr-xr-x 1 root root 73 Jan 1 1970 .profile
drwxr-xr-x 2 root root 32 Aug 16 21:54 Notes
-rwxr-xr-x 2 root root 167692 Jan 1 1970 UNIX3.5
drwxr-xr-x 2 bin bin 1424 Feb 9 1992 bin
drwxr-xr-x 2 root sys 1648 Feb 8 1992 dev
drwxr-xr-x 5 root sys 1328 Aug 17 17:47 etc
drwxrwxr-x 3 bin bin 320 Feb 9 1992 lib
drwxrwxrwx 2 root root 1024 Aug 6 1986 lost+found
drwxrwxrwx 2 root root 32 Jan 1 1970 mnt
drwxrwxrwx 2 root root 32 Jan 1 1970 mnta
drwxrwxrwx 2 root root 32 Jan 1 1970 mntb
drwxrwxrwx 2 root sys 240 Aug 17 17:50 tmp
drwxr-xr-x 6 bin bin 96 Aug 17 16:05 u
-rwxr-xr-x 2 root root 167692 Jan 1 1970 unix
drwxrwxr-x 14 bin bin 224 Feb 9 1992 usr
# exit

Welcome to the AT&T UNIX pc

Please login:


Now, when I login as a user that boots directly to the "office" application, the window looks very nice in my ZOC terminal emulator. When asked:

Please type the terminal name and press RETURN:

I answer "vt100"

See http://bit.ly/XtwhCV

The arrow keys of my keyboard move the cursor up and down through the menu, but the "enter" key only moves the cursor to the next menu item, it does not send the command to "accept" the selected option. ON the UNIX PC, there are separate Enter and Return keys, but not so on my modern PC keyboard which I use with the terminal emulator running on Windows 7.

Does anyone have any ideas what setting I might look into changing to assign a key to send a code that the UNIX PC interprets as "enter"?

Thanks again to all for your input...this is a lot of fun!


August 17th, 2014, 07:34 PM
I find the answer for escape sequences on PDF page 35 of the

AT&T UNIX PC Remote Access User's Guide (http://www.tenox.net/docs/att_unixpc_remote_access_users_guide_3b1_3.51_90.p df)

So, creating quick "send text" buttons in my ZOC terminal emulator allows me to create these keys.

^[ex for Exit, for example.

On to the next challenge...

October 11th, 2014, 08:58 PM
Carrying this thread another notch...I set up my 7300 today to use an external Zenith Z-19. I played around with different terminal settings, settling on the VT-100 because I just wanted command line access. Thanks for the tips, this thread helped me troubleshoot the signals.

Unfortunately I was not able to get a previously untested VT-220 to work. Not sure if it's an incompatibility with all VT-220's or just this VT-220 has an issue. Anyone have a comment as to why / why not a VT-220 would work with the AT&T UNIX PC? Given the Z-19 worked I assume my null modem wiring is correct. I also built a little box to make sure the signals were correct just to be sure.

I used to work with VT-220's when they were new, but I have not touched one since. Until today. This particular VT-220 was lying around here for a few months, had not gotten to it yet. I have a device to show RS232 signals, did not see anything coming from the VT-220.


October 11th, 2014, 09:31 PM
VT-220 should work wherever a VT-100 does. Have you tried testing the terminal with a loopback connector?

October 12th, 2014, 05:21 AM
VT-220 should work wherever a VT-100 does. Have you tried testing the terminal with a loopback connector?

No testing other than a rs232 breakout box that appeared to show no signals coming from the terminal. Because I was focused on the UNIX PC, I just grabbed another terminal. The vt220 will be a separate project. Some sort of 1488/1499 type thing.