PDA

View Full Version : hard drive problem



dongfeng
September 20th, 2006, 08:43 AM
I have a MiniScribe 8450 MFM drive which came with a Seagate ST11R controller. I am trying to install it on an XT Clone board (Turbo 8MHz with NEC V20).

When I first installed the card and drive it booted into a Seagate menu, with LL format utility. I put the details, and couple of bad track, but after about 3 minutes the utility quit (bad track, I think but not sure).

Anyway, I cannot seem to get it back to the LL utility.

I tried G=C800:5 but it just locks up the computer.

Any ideas what I can do? :)

Luke
September 20th, 2006, 08:58 AM
Boot from floppy and run LF utility HDAT (maybe the name was ATHD?) or SpeedStor.
Then try to LF it.

dongfeng
September 20th, 2006, 09:54 AM
Actually, the problem is solved. It is quite a strange one!

The drive has the model number MiniScribe 8450, which is a ~40MB drive. With this settings, the LL format fails.

Someone wrote with marker on the drive "8438". I enter the settings for MiniScribe 8438 ~30MB drive and it is working!!!

Formatted with PC-DOS 3.3. I think I can have fun with this 8MHz XT clone board :)

dongfeng
September 20th, 2006, 11:30 AM
Hmm.. another problem.

The hard drive boots fine, but does not when I turn off the computer and reboot it.

The second time, the interrupter arm on the side turns around, then makes a BZZZZ sound (it runs out of turns) and the computer will not detect the drive. If I turn off the computer, spin the interrupter arm around the other way as far as it will go, the computer will then boot.

I also found that if I park heads with XT Diagnostics Disk (SHIPDISK.COM) before power off, it will be fine next time I boot.

Anyone know why it does this? I've looked in Google but no solution :(

nige the hippy
September 20th, 2006, 02:15 PM
It's not had a head crash has it?

I had a really huge 80 MB!! drive once that had lost it's last head. stripped it in a freshly kettle-boiled (fairly dust free) room, snipped off the head & swooshed loads of alcohol round it. ran it "dumb" for a while, then said it had 1 less head in the drive parameter table. worked a treat for a good while until I blew it up with a cheap and nasty PSU connector going in backwards.

it could be that it parks outside the grinding zone (shudder)

Nig.

Just checked...it has 4 heads, if they're real ones, that would make sense.

dongfeng
September 20th, 2006, 02:18 PM
Not that I know if. I've scanned the disk in Norton Disk Doctor and SpeedDisk, and both report no problems. Also scanned it in CheckIt.

I am wondering if this has anything to do with the setting "starting write precomp cylinder" that the LL format utility prompted me for. I couldn't find any info for it, so I just left it blank (I think it said NONE).

nige the hippy
September 20th, 2006, 02:43 PM
god! I can't remember anything about precompensation.

no! if it's set to be a 30MB rather than 40 MB drive, norton won't find anything, because if the 4th surface has crashed, it won't be looking there.

just wondered if it wasn't physically able to spin-up due to the drag of rough aluminium against the head, in the damaged? area, which may be being avoided by parking the drive.

If when it's running, after a non-parked start, you feel gyroscopic precession when you gently(!) rock it, it's spun-up ok and i'm talking bo????ks


Write precompensation- http://www.pcguide.com/ref/hdd/geom/tracksWrite-c.html aaaahhhh google