View Full Version : XT clone - A few teething troubles

September 21st, 2006, 12:40 PM
My XT clone arrived today. 640k and an 8088 that appears to have a turbo feature. There is an LED that has the option to change colour (orange or green) with speed written underneath it, but I don't know the key combo to use it. At the moment it is yellow. The unit is yellowed, but not too much, but the keyboard is nearly brown (Eugh). The entire thing is fairly small, the unit is about as wide and deep as it's 5151 monitor.

The MFM HDD (Learning from my last HDD thread, definately MFM, has the controller card and 2 ribbon cables) does not seem to be working but the floppy drive does, it boots from my one remaining trusty boot floppy (I ought to have it sewn into my trousers on a string ;)), but the keyboard is intermittent. I assume this has previously been stored on the floor in a garage, the backing plates and the front keyb connector are rusty, but inside it's pretty clean. I'm experiencing keyboard problems, on bootup there will be repeat beeping indicating a stuck key. A press on the spacebar after boot makes the cursor travel all the way across the screen, instead of one space. The O key seems to come and go as it pleases.
This could be the rusty keyb connector but probably the keyb itself. Although the keyb is ugly it is original to the unit and I would prefer to keep it, but not desperately.

Never used this type of hardware before, any tips/tricks on getting the HDD and keyb to work or troubleshoot them would be great. I will be able to write a setup disks hopefully at the weekend or when one of Nig's drives arrive.

Please bear in mind I'm treading new ground here...

September 21st, 2006, 01:02 PM
You might have to dismantle the keyboard and clean the key backs, the keys can get sticky at times. Is it an 83-key keyboard? If so, don't remove the space bar they are nearly impossible to put back on.

If condensation gets inside a keyboard it can cause the keys to stick on, but they are usually stuck on ALL the time, not just when you press it. I think a slight dismantling, cleaning, and reassembly might be required! Firstly, just remove the individual keys and see if you can get them working.

If it is an XT, you will probably need an XT keyboard for it... or one of those mythical XT/AT switchable ones.

For the HDD, you'll need to tell us the make/model of both the drive and the controller card and we can advise futher!

September 21st, 2006, 01:07 PM
Try holding the keyboard upside down and tilted 45 degrees towards the back. If no joy, remove the dodgy key's cap and try again. I found that on an IBM keyboard when the key is removed the buckling spring base falls into the "on" position. Sometimes keys can get stuck on too.

Also try swapping the caps over and see if that helps.

September 21st, 2006, 01:08 PM
Right, I will do tomorrow, I can't now as its getting late...
A whole Keyboard stipdown, eh? sounds like fun...
I think Samsung must have made a switchable keyboard, as mine has a whole in the back where underneath it is written XT/AT but there isn't a switch there, just a space of PCB so it must have been optional.

Also, If XT's have a BIOS, how much is it like the BIOS I know and love of modern PCs? Is it all done buy DIP swithces? Setup program? or a bit of both?

September 21st, 2006, 01:38 PM
They don't have a BIOS CMOS setup like the one in a modern PC ;)

The hardware - floppy drives, FPU, display card and memory - is selected by a DIP switch on the mainboard. Hard drives have a BIOS in the controller card which is detected automatically on startup.

My clone XT Turbo board has a Phoenix BIOS.

Do you get any error messages on boot? It should be along the lines of 1701 (blah blah blah). It might also specify the drive card, but the best bet is to take it out and look at it, or even better post some detailed photos on here!

If it has been in a garage, chances are the drive is dead. But you might be able to low-level it.

September 21st, 2006, 01:39 PM

1 2 34 56 78
| | | | | NO. FLOPPY DRIVES:
| | | | 11 = 1 floppy drive
| | | | 01 = 2 floppy drives
| | | | 10 = 3 floppy drives
| | | | 00 = 4 floppy drives
| | | |
| | | 00 = Monochrome display Adapter
| | | 01 = Colour Graphics Adapter - 40x25
| | | 10 = Colour Graphics Adapter - 80x25
| | | 11 = Video Adapter w/onboard BIOS
| | |
| | 11 = Bank 0 only
| | 01 = Banks 0 and 1
| | 10 = Banks 0, 1 and 2
| | 00 = All 4 Banks
| |
| 0 = Installed
| 1 = Not Installed
0 = Boot From Floppy Drive
1 = Do Not Boot From Floppy Drive
0 = Normal POST (Power-On Self Test)
1 = Continuous Looping POST

September 22nd, 2006, 05:26 AM
My Clone only has 4 DIP switches.

No error message, in fact after memory count it will say "1 hard drive" and then try and boot from floppy.

Cannot access the C:\ drive

Will open up later. Right now I'm in DT class. Absoluetly no response from HDD that I can see or hear on bootup.

Are MFM hardrives expesive these days? I know their not reliable but its better than 2 floppies

Will post more info later.

September 22nd, 2006, 06:01 AM
Now you should think of hard drive, DIPs should be next.

You propably have DTC controller as they say '1 Hard Drive'.
That's good, that it see the HDD.
Does it spin up?

You sould tell use models of HDD and controller, then we can say something more...

September 22nd, 2006, 06:23 AM
There is an LED that has the option to change colour (orange or green) with speed written underneath it, but I don't know the key combo to use it. At the moment it is yellow.

Many of the XT clones used CtrlAlt+ or CtrlAlt- (using the +/- on the number pad) to toggle turbo mode.

The hard drive may just need to be reformatted too. Don't know how if it is a DTC controller, but I'm sure you can find out using google (once you know the make of the HD controller).

September 22nd, 2006, 07:36 AM
Controller, No name but lotsa numbers dotted all over;

5150 CRH

Hard drive itelf;

KYOCERA model KC-20B
Serial KB2104244

3 556 8095
3 557 8096
3 559 8097

The HDD didn't light up because the HDD activity light was cut, and the current drive has its own and there are no loose wires or sign of, so this drve is probably a replacement.

The 4 DIP switches are on the motherboard, not controller, and are accesible by the back panel.

I will plug this drive in and see if it spins up, I can see it properly now it isn't under a floppy drive.

Any info to offer on this drive/controller?

September 22nd, 2006, 07:45 AM
Some success!

I had the drive upside down so I could lee the HDD activity light, after boot it made a short noise which I though was the floppy drive checking for a disk every boot, but turns out it was this. After POST (Or whatever) it entered a cycle of a few grinds, a beep and a few very brief flashes of activity on the light in rapid succesion. After 1 minute there was a loud juddering noise and

1701 (04)ng

0 Hard Disks

Error. Press f1 to continue.

Al least I know there is some life in it. What do I do next I may have put the cables in the wrong way, I'm not sure.

OK, now it just makes a large clattering noise, like the heeads are banging agains the sides.

September 22nd, 2006, 07:57 AM
Controller is DTC 5150
according to Micro House Encyclopedia:

Address jp1 jp2 jp3 this block set is located on left bottom side
disable n/a n/a O next to 5pin connector
C800 O O C (default)
D000 C O C
D800 O C C
F400 C C C

jp5 1-2 = irq2
jp5 2-3 = irq5 (default)

jp7 io port 320-323h Closed (default)
jp7 io port 324-327h Open

jp3 DACK3 2-3 (default)
jp3 DACK1 1-2

jp4 DREQ3 1-2 (deault)
jp4 DREQ1 2-3

jumper order - starting on left side
5 pin connector, jp2, jp7, jp1, jp4, jp3, jp5

KC20B 20 meg MFM:
616 Cylinders
4 Heads - M
5 ms step rate
65 ms access time
17 Sectors per track

September 22nd, 2006, 07:59 AM
So, what do I do with these numbers?
Sorry to be dense :(

September 22nd, 2006, 08:04 AM
Here you have settings for controller.
It's DTC5150CRH, looks strange.


It's RLL controller.
I don't know how to set the type, maybe you need special utility?

And the disk is just similar to ST-225

615 cyls, 4 heads, WPC: 300

Strange noises are not good sing...
And controller should detect the drive, even if it would be unformatted.

September 22nd, 2006, 08:07 AM
If there is no other hd contoller:
set JP3 to Open, Open, Close
set JP5 over 2-3, and all other default setting above.
If you can get the machine to recognize the drive again, boot with a dos 3.22disk, start debug, and try entering G=c800:5 at the prompt. This MAY start a formatting routine. If it doesn't try finding a piece of software called hdprep.exe.

September 22nd, 2006, 08:29 AM
Jumpers were already set as above. Now after startup, it will judder until the memory count starts, then the HDD activity light will just blink regularly, and won't make any noise.
Oh, and then it shows a 7170 or whatever error

September 22nd, 2006, 09:14 AM
You must be sure, what error it gives.

This drive will propably not work anymore or work bad.

You can buy RLL of MFM drive with controller for I think max. 10$?

September 22nd, 2006, 09:19 AM
It shows the 1707 error.

Is there absolutely no way to remedy this?
If not then what is causing the problem specifically? I dont mean 'the drive' or 'the controller', I mean, really specifically if it is possible to tell.

Terry Yager
September 22nd, 2006, 09:26 AM
From your description of the sounds, I'm betting that your drive has gone tits-up.


September 22nd, 2006, 09:29 AM
1701 Fixed disk or adapter general error
1707 Drive track 00 error

Here is nice page:


I'am not an expert so I can't tell you what you can do...

September 22nd, 2006, 09:36 AM
So, I could get a new drive and keep the controller? I hope so. I don't know how easy half length controllers are to get hold of. Or controllers at all for that matter.
Any offers for a new drive?

Also, the computer wont boot from floppy at even with hard drive unplugged until the controller is removed. How do I stop this as I would like to keep everything in the machine until the problem is solved

September 22nd, 2006, 09:46 AM
How long have you waited for it to boot? From the 1707 error, I'd leave the drive and adapter set up and wait for 3 or 4 minutes to see if it booted from floppy. If so, I'd then try to format with debug or fdprep.

September 22nd, 2006, 09:57 AM
If I leave it, it will say "Error, press F1 to continue."
If I try, I get no response. I don't know it it is the keyboard or something else.
The keyboard doesn't seem to be reponding to treatment either.

September 22nd, 2006, 09:59 AM
Dumb questions ahead ;-)

Is it an XT keyboard?
Does the keyboard work if you remove the controller and boot from floppy?

September 22nd, 2006, 10:12 AM
Yes and yes
It's specific to the computer. I think the F1 keys on the blink as well.

September 22nd, 2006, 10:38 AM
OK, this is weird.

I had one more go, it didn't boot of my harddisk, but it booted from the floppy in it which started copying files to the C:\ drive! After a few files it said error reading drive C:\, abort, retry, ignore, and thats as far as I got. I tried to use g=800c:5 but I now know that practically all the keys that arn't required in DIR and CD do not work...

September 22nd, 2006, 10:40 AM
It's standart DIN connector?
If so get another XT kboard.

If you look will you can find one after 1 or 2 days ;).
It will be propably one with XT/AT swich.

September 22nd, 2006, 10:45 AM
it should be g=c800:5 ;)

Or whatever the card is set to.

September 22nd, 2006, 10:45 AM
I dunno, what is standard DIN? mine has 5 pins
After reboot the drive was recognised at POST and no error messages, but it was not there as C:\ anymore. Another reboot and it made clacky noises again and gave an error message. Looks like I missed my chance to do some work thanks to a crappy keyboard. :(

So, I need
1) a new keyboard
2) an new drive.

Oh joy. I'd better post in the Wants forum.

September 22nd, 2006, 10:48 AM
Here are the settings for your card:


Make sure the W2 block has the settings for C800h, then you can use the g=c800:5 under DEBUG.

If the drive is LL formatted, it might be able to be saved. If not... look for another drive.

September 22nd, 2006, 11:12 AM
You have RLL controller (!)

I heard, that not every MFM drive can be used with it.
RLL is more reliable that MFM method.

Someone know how it is whit using MFM drives under RLL controllers?

September 22nd, 2006, 11:13 AM
Laready got the settings.
I cant ll format because I can't use the keyboard. The spacebar is completely kaput as is the O,0 and F1 keys that I know of. Cleaning didnt acheive anything.

RLL? Oh dear. Sounds expensive.

I suppose a last resort would be another floppy drive. Can the onboard controller handle 3.5" drives?

September 22nd, 2006, 11:22 AM
It will propably handle 3,5" drive, but recognize as 720kB one.

Your keyboard connector is like that on 486s or 386s?

September 22nd, 2006, 11:26 AM
Look like this:

September 22nd, 2006, 11:30 AM
3.5" drives could work, but as Luke said a 1.44MB drive would only be registered as 720kB (or you might be lucky! you never know with clone mainboards). You can get a standard pin to slot adaptor easily enough to use it with the existing cable.

September 22nd, 2006, 01:19 PM
Recognised 720k disks. My card edge Connector/3.5" floppy cable is bad. Only the drive at the 3.5" end is recognised properly on my machines, so one 720k is better than 1 5.25" but not by much. When I'd had my fill, I put everything back as I found it, minus 1 HDD and controller card.
I suppose it will lie dormant until I can get my mits on a keyb and HDD that will work with my card.

Thanks for all your help, it's been an interesting learning experience :)

September 22nd, 2006, 01:57 PM
A hard drive isn't really needed, but a keyboard is. Keep a look out for the parts, they will turn up eventually. It is better outside of eBay, since the prices on there are crazy (the last PC/XT keyboard on there sold for 25 pounds).

Unfortunately I don't have any spare keyboards, but I will keep a look out for you :)

September 22nd, 2006, 02:04 PM
Thanks. It always seems that I find the things I was looking for after I need them... If that makes sense.

September 22nd, 2006, 03:53 PM
No. His controller is NOT RLL. Only the 5160 is RLL. The 5150 is MFM. MFM drives are cheap here in the US. I find them regularly for $10 plus shipping on EBay. I gues that would be about 6 pounds sterling plus shipping. Look for an ST-225, a Tandon tm-506, or something similar.

September 25th, 2006, 01:10 PM
The ideal solution would be to use something like a hard card. I have one in my 5150, it's simply a 20MB SCSI drive and 8-bit controller on a single card that just slots in one of the ISA sockets. Much faster and more reliable than MFM. I've seen 8-bit SCSI controllers on eBay more often than 8-bit ISA.

October 5th, 2006, 12:17 PM
There is Samsung 8088 on eBay at the moment with working hard drive and keyboard. Maybe it is of use to you :)


December 6th, 2006, 01:18 PM
I have diagnosed the problem with the MFM drive!

Anyway, after carefully openening the drive in the most dustfree room in the house (The kitchen) And boiling a kettle nearby, I opened the drive to find that little thin metal number lying mangled in the arm mechanism slightly bent out of shape.

-------------- \\
|--------------- 0=========== // =0==0

Please escuse my appaling ASCII representation, being out of proportion and whatnot, but thats the general gist.

Hmms, I thinks.

I boot the XT with the drive lid off. The platters spin up and the little stepper motor turns around as it should, but the arm doesn't move! Why? There's nothing driving it, thats why! The physical movement transfer must from motor to arm must have something to do with the little foil metal thingy.

After 10 minutes of Uhming and Ahing, I discover that the hole on the middle where the two arms conjoin (represented by the first 0 in the diagram) Goes around a nub on the stepper motor. The beginning of the strip clips around one end of the arm, and the other is screwed into the other end, and the middle is wrapped once around the stepper motor, the numb on it providing the grip and turn, and all aranged in the fashion of a bow around a stick to start a fire. Theortically, as the stepper motor turns one way, the arm moves down towards me and vice versa. The juddering noise mentioned in my last posts was the stepper motor turning around and around and not driving anything.

One problem. After looking, there is still a bit of the foil screwed into the arm! 0h n03s! Its snapped! (Illustrated by the '//'s on the 'diagram'). Thusly, a simple repair is not an option. I cant glue it together, for I fear superglue may not take the strain for a great lenth of time, I dont have any wire thin and strong enough to thread through and tie up, and thread will taugten and stretch with humidity changing position of the arm making it impossible to read previously written data, and its such a frail thing I fears that I won't be able to repair it anyway.

I thought I would tell y'all anyway so all that helped can go "Mmmm..." sagely and nod with inexpressable wisdom ;) and strike this off the list of mysteries.

Hopefully, Sandy's drive will arrive functional and sound as a bell around christmas time! Right now I have a nice white box thing for resting mugs of tea and biscuits on (On a coaster, of course!).

December 6th, 2006, 02:17 PM
I'm excited & can't wait till you get the HD & keyboard, I so hope it fits like a glove, sounds promising... the drive is half height (it's still a monster). Just found my old EGA monitor, it's a Hyundai, I don't have anything to test it on but the screen lights up, I am sure it is still good.

I had a friend who bidded on the old mainframe that belonged to the VA hospital here about 4 years ago, paid 32.00 for everything. I had about 50 monocrome monitors, my husband was so mad, our garage was stuffed, anyway, he threw them out, I know at least 3/4 of them were good, if not all.

Well, everyone on this site is way above my head but it sure brings back memories. I am learning alot and reading much I don't understand, I really do love working on old computers, time just flies by.

I hope it arrives sooner than they say!

nige the hippy
December 7th, 2006, 02:51 AM
It's possibly worth keeping hold of the drive for spares, if you have the space. you'll never be able to effectively replace the steel bow thingy, it's REALLY tough stainless. but if you end up with a drive of the same make with a head crash or something, they are (difficult but) not impossible to disassemble. also it's a handy book end.

December 7th, 2006, 06:50 AM
Yuhuh, I imagined it would be pretty impossible to fabricate a new one. Even if I did find something to make it with something that is thin, flexible and strong I wouldn't be able to make all the precision slots and notches

December 7th, 2006, 06:56 AM
Oh and Sandy, I know the feeling of not understanding! When I first came to this forum (Which wasn't even that long ago) I only understood 1/2 of what everyone is saying. Now I understand 1/2 to 80% on simpler threads, and get the gist on most. it'll come pretty soon! I've only even had a PC for 2 years, and I certainly don't know a quarter of what most on this forum know, I'm getting better!

Maybe some of that 'Invisible' plastic thread or fishing wire will work.

I have no intention of using this drive, just seeing how good I can get it to work purely out of curiosity now :)

December 7th, 2006, 10:20 AM
The platters with all the red-brown oxide on them are cute hanging on the wall.

Ooooo, you could likely make a great "hanging mobile" deal where they blow and swing around in the corner of a room somewhere ;)

December 8th, 2006, 02:30 PM
Or buy a clock mechanism and turn the drive into a clock.

December 8th, 2006, 04:34 PM
oOOooh! Shiiiiny!

I'll keep it intact for a few months, incase I need it as spares.

After that I think I might use the platters as clocks, coasters, frisbees, whatever. They are pretty!

December 8th, 2006, 05:56 PM
Someone should paint pretty pictures on them like they do the old saw blades.

December 8th, 2006, 06:38 PM
Nah, as you can see, very shiny by themselves. Make better objects just reflecting in the light.

December 8th, 2006, 07:01 PM
Maybe a painting of something really shiny, reflective? Maybe a painting of it!