PDA

View Full Version : Weird FDISK problem on NEC DS5126 drive



Denniske1976
November 7th, 2014, 06:29 AM
Hi guys,

Just a quick question about a problem I seem to be having with a NEC DS5126 20MB MFM drive on a Xebec controller that it came with:

Drive appears to be working just fine, or at least spins just fine. However, when I try FDISK (I tried IBM PC-DOS 2.10, 3.20 and MS-DOS 5.0 and 6.0), it seems to be making a partition but after the reboot is asks for this is gone again. So I boot from a DOS disk, run FDISK and when I choose option 4 it states "No partitions defined". Then I do option 1 and answer Y to the question of using the whole disk as one partition and marking it active. It seems to be making the partition (I hear the disk beeping and the drive light flickering for a few seconds), after that I need to reboot. So I do and from the same DOS disk, when I run "FORMAT C:" I get "Invalid drive specified". Then I get back into FDISK and when I choose option 4 again it says "No partitions defined". I can do the whole thing of making a partition and rebooting over and over again, but I keep making a partition and after a reboot I end up with a "blank" hard drive again...

Anyone?? I'm kinda stumped here :oops:

luvit
November 7th, 2014, 07:01 AM
assuming you have the correct controller and if the switches/bios are configured correctly -- i had this same experience and fixed it with a low level format.
shortly after i resolved mine, i found this thread (http://www.pre32.com/topic16.html) and would believe it's relevant.
do not follow the low level format instruction shown in the thread.. that would be likely be specific to the make/model and other characteristics..

Stone
November 7th, 2014, 08:19 AM
You could try a LLF but it's quite possible that track 0 is bad.

Chuck(G)
November 7th, 2014, 08:51 AM
You might have a bad positioner as well, so the drive never gets off of track 0. Check your control cable carefully. You can also get this effect if the geometry you specified isn't correct.

Denniske1976
November 7th, 2014, 10:41 AM
Thanx for the info guys, I'll have a go with a LLF tomorrow. The drive is a Type 2 drive, I checked and the Xebec controller is set for a Type 2.

SpidersWeb
November 7th, 2014, 10:45 AM
I just wanted to +1 checking the control cable carefully. I've had a few weird situations, removed that cable and found a pin pushed in and not contacting correctly.

Denniske1976
November 8th, 2014, 07:16 AM
Well, I tried to get it working on another controller. The IBM XT supplied Xebec controller and jumpered for Type 2, also to no avail... I even tried it in an IBM 5170 on the controller and I can't get it working there either (Disk 0 failure). So in that 5170 I now have a Rev2 XT-IDE controller and that hangs the system, different story and I'll post that in the XT-IDE testing thread.

So it looks like the disk is shot? I've been at it all day with HDD's that won't work anymore (one ST-4038, two ST-4026, two ST-412 and the DS5126... all gone to h*ll) :-(

Dennis

Stone
November 8th, 2014, 07:33 AM
Well, I tried to get it working on another controller.You're aware that changing controllers usually requires a new LLF and FDISK in order to use the drive?

Alternatively, more and more MFM drives are becoming doorstops as time marches on.

SomeGuy
November 8th, 2014, 09:04 AM
I recall having a similar problem a long time ago, but I don't recall what the solution was.

A few things to check:
- Cables, cables, cables. :p
- Is the smaller cable connected to the header for the first hard drive?
- And does pin one match at both ends? :p
- Is there a drive select jumper on the hard drive, and is it set correctly?
- Since FDISK seems to think there is a drive at all, perhaps you can use some BIOS level tool to poke around and see what drive number BIOS thinks it is and if anything is actually getting written.
- It could be a geometry mismatch somewhere. But I'm not familiar with the Xebec controllers.
- Perhaps try other format tools such as SpeedStore.