PDA

View Full Version : IBM XT/286 trouble



IBM_User
November 15th, 2014, 09:16 AM
I've recently tested my spare part 5162 motherboard with the following result:

21497

21498

Any ideas what's going on here?

I swapped memory and bios from my working XT/286, unfortunately no difference.
Power supply and MDA card came from the working one, which means they are ok.

Stone
November 15th, 2014, 10:33 AM
You need to run the setup program.

You also might need to replace the battery.

IBM_User
November 15th, 2014, 11:53 AM
Right, but that has nothing to do with this fault.
The battery on my working 5162 is also empty, but he is
fully functional except the battery.

mikey99
November 15th, 2014, 02:48 PM
Did you replace the motherboard in the 5162 case with the spare one and reattach all the cards/connectors ?

The 601 error is related to the diskette controller or drive. You could try cleaning the contacts on the MDA and
diskette controller cards with a pencil eraser and reseating those a few times. Maybe the contacts in the motherboard
are slightly dirty.

Robin4
November 15th, 2014, 03:20 PM
Maybe a bad cmos rom chip?? Mostly they wont get replaced on these older motherboards.. I guess its already 25 years old now..
For every rom, i would backup it when its was still working en replacing these rom chips for new ones. They dont live for ever..

IBM_User
November 15th, 2014, 04:10 PM
I've tested the board with the minium config (PSU, Speaker, MDA and Keyboard) and nothing else.
So it's normal that the 601 error appears, but why does it that twice (see first picture)?
The second picture shows some sort of the ROM BASIC, it's completely rolling over.

mikey99
November 16th, 2014, 06:32 AM
The second picture looks like the 5151 is losing sync. You should try attaching the diskette
controller/drive , run the setup diskette, and see if you can boot into DOS.

per
November 16th, 2014, 06:49 AM
Make sure the motherboard is set to default MDA and not CGA. There should be a jumper somewhere on the motherboard for this, allthough proper CMOS settings will override that.

But id does display the memory count correctly though...

IBM_User
November 16th, 2014, 07:19 AM
Running SETUP after connecting controller and floppy does not change this issue.
The switch on the motherboard is in the MDA position.
Booting into DOS fails.

Next thing I think to try would be to remove the BIOS roms and insert
the Landmark super soft diagnostic roms.

mikey99
November 16th, 2014, 10:25 AM
The display image is in sync when the errors (161,601 etc.) are displayed.....which is a good sign.
Maybe the 5151 display sync is more sensitive when running in ROM basic mode.
Did you try running the video tests in the SETUP program ?

Did the diskette fail to boot DOS or are you booting from the hard drive ?

IBM_User
November 16th, 2014, 11:50 AM
Further progress, now he boots into DOS, but the 286 chip runs that hot, I can't touch it longer than 3 to 5 seconds.
My POST card which has lots of diagnostic software onboard stucks at the first test which is the DMA Page register.
Also, the second picture only happens in BASIC, formatting a diskette as example works without any problem.

Booting was done via diskette.

Chuck(G)
November 16th, 2014, 12:20 PM
Do you have a copy of GWBASIC? It would be very interesting to see if that brings the same display.

If I were to guess, I'd say that the loss of vertical sync was due to the wrong video mode being used for the display. You have a huge range of horizontal frequencies that the monochrome display will sync to because it doesn't have a traditional horizontal oscillator--it just relies on the sync pulses coming in over the cable.

If things work okay with GWBASIC, it might mean a bad BASIC-in-ROM copy.

IBM_User
November 16th, 2014, 02:13 PM
No, unfortunately not.

The ROM chips are ok, I tested them on my second XT/286.
I also get the same result with AMI 286 chips.

Stone
November 16th, 2014, 02:26 PM
No, unfortunately not.MSDOS 3.3 has it. Several early versions of PCDOS have BASICA.

IBM_User
November 16th, 2014, 02:46 PM
I only have IBM DOS. BASICA displays the same result.

luvit
November 16th, 2014, 06:46 PM
do you have a video card to swap?
what happens when you change your MODE?
MODE CO40
MODE CO80

modem7
November 16th, 2014, 11:31 PM
Further progress, now he boots into DOS, but the 286 chip runs that hot, I can't touch it longer than 3 to 5 seconds.
I do not have an IBM 5162, but I have some 5170 machines, and the 80286 chip in those gets very hot.
I made some measurements and recorded those in the 'CPU gets very hot' section of [here (http://www.minuszerodegrees.net/5170/problems/5170_known_problems_issues.htm)].

IBM_User
November 17th, 2014, 12:15 AM
I tried several different MDA cards (clones and genuine IBM), nothing changes, also nothing changes when switching between 40 and 80 mode.

Today I tried one of my CGA cards (stock IBM Part) which works best, BASIC works just wonderful!

I never ran that much into electronics (unfortunately), but I think there must be anything on the motherboard wrong
which has only with MDA graphics to do.

IBM_User
November 17th, 2014, 07:42 AM
Update:

21510

That's the second Interrupt Controller (8259A) which seems to fail.
I do further investigation.

EDIT:

This test fails on both board's (the working one and the non working one).

I changed both BIOS ROM chips for a pair of diagnostic chips out.
Now I get two DMA transfer errors, one was during transfer RAM to IO (1st and 5th transfer),
and the other was during transfer IO to RAM (2nd transfer and Port lost value).
Maybe it's a RAM issue? Because both DMA controllers are working properly.

mikey99
November 18th, 2014, 11:33 AM
Very interesting.....what is the interrupt test program you're running ?
I have a 5162 XT/286 sitting here on my desk I could see if it passes that test.

per
November 18th, 2014, 01:19 PM
I've had issues with my XT-286 in the past, but only so that some versions of some programs fail to run properly. Maybe that has something to do with those results?

modem7
November 18th, 2014, 02:07 PM
We have seen the SuperSoft/Landmark diagnostics produce strange results. And we know that early versions of CheckIt diagnostics fail if an IBM EGA card has less than 256 KB of video RAM fitted.

So, I am not going to be surprised if the diagnostic software that the OP is running, turns out to fail a test whenever it is run on an IBM 5162 (XT 286). Maybe it predates the 5162, and a later version of the software corrects the issue.

mikey99
November 18th, 2014, 02:59 PM
I ran CHECKIT (version ?) on my 5162 ......the DMA and Interrupt controllers all passed.
My IBM EGA card has 256K.

IBM_User
November 19th, 2014, 03:00 AM
First of all, that's my diagnosis "tool":

21521

I bought that for troubleshooting 386 and 486 systems back in the day.

Anyway, with both diagnostic roms installed I get two DMA transfer errors, the errors are for DRQ5 and DRQ7.
Since all DMA tests checked out fine on my working 5162 (with diagnostic roms installed),
I think I may have a bad DMA controller at location U9 (that's the second 8237A).

But, DRQ5 and DRQ7 are only related to the 16-bit part of the ISA bus and not the 8-bit bus,
so I am a bit confused about the MDA issue.

modem7
November 19th, 2014, 09:53 PM
But, DRQ5 and DRQ7 are only related to the 16-bit part of the ISA bus and not the 8-bit bus,
so I am a bit confused about the MDA issue.
You are making the assumption that the DRQ5/DRQ7 symptom is related to the MDA symptom. They could be completely unrelated.

IBM_User
November 20th, 2014, 01:11 AM
They are completely unrelated, of course, but since I do not find any other issue it would be the first thing to get fixed.