PDA

View Full Version : Apple II Problem. HELP ME!!!!!!!!!



apple2fan
October 8th, 2006, 11:22 AM
I got an Apple II original today and turned it on, and did not beep, and the screen shows nothing!! It has some cards installed, that involved soldering, so maybe it is affecting the computer?
I NEED HELP!!!!!

Here are some pictures of the computer, look at the motherboard:
http://cgi.ebay.com/the-Original-apple-II-appleII-apple2_W0QQitemZ200031995657QQihZ010QQcategoryZ800 75QQrdZ1QQcmdZViewItem

Any suggestions?

Thank you

ahm
October 8th, 2006, 12:02 PM
look at the motherboard
What about it? Looks okay to me.

You might try re-seating the cards, and any socketed chips - with the power off, of course.
Something might have come loose during shipping.

applefreak
October 8th, 2006, 12:25 PM
is the power supply working?

hoke up a different display
replug the video-cable

remove all the cards
clean the gold contacts with a clean pencil eraser

put one back (disk drive II)

test

if OK

plug in the cards one by one, and testing

apple2fan
October 8th, 2006, 12:29 PM
Yea, I unplugged all the cards, and didn't make a difference. :dontgeti:
It turns out the card that was installed ("The Digital Video Multiplextor") bypass's the RCA out. In other words it needs a special monitor so you can see the screen output.
I think the speaker is just broken, or maybe something else.
The Red thing hanging out the back is a headphone jack!
The other thing hanging out is the new video out.
I think the computer is working, I just have to get this special monitor to work it.
BUT, I plugged in a disk drive and turned it on, and the drive didn't come on. But there was another card inside of it at the same time.
So I don't know what's the matter with it.
The power supply is working to. The power light comes on.

applefreak
October 8th, 2006, 12:35 PM
with no ("The Digital Video Multiplextor") card installed

can you still use the normal RCA out ?

apple2fan
October 8th, 2006, 12:38 PM
No, there are some daughter boards attached to the mother board from the card.

applefreak
October 8th, 2006, 12:40 PM
soldered or just plugged in ?

apple2fan
October 8th, 2006, 12:49 PM
Both.
But I just went back and plugged it in, and it beeped!!
Maybe I fixed it, and I didn't even realized I fixed it!!!:-D

apple2fan
October 8th, 2006, 12:53 PM
IT'S ALIVE!!!! IT'S ALIVE!!!!
I plugged it into a monitor, and the apple ][ screen with a blinking curser came on the screen!!! Along with the Beep!!
I fixed it!!:D

ahm
October 8th, 2006, 01:00 PM
What did you do to fix it?

apple2fan
October 8th, 2006, 01:00 PM
What?
Now I'm confused!!
It sometimes works, and it sometimes doesn't.
I think it needs a new power supply.
I'm going to leave my System Saver on it for a while.
I didn't really do any thing, just fiddled around with the mother board.
Maybe there is a micro chip loose, can anyone help me out?
Thank you.

apple2fan
October 8th, 2006, 01:16 PM
Okay, this is getting weird. Its working again.

applefreak
October 8th, 2006, 01:55 PM
on the photo i cann't see the powercord plug
is it plugged or soldered

if it is plugged, remove it and see if there is any corrosion
to remove the corrosion, remove the plug and replug several times

apple2fan
October 8th, 2006, 02:26 PM
I am sorry, but what do you mean?
The plug to the mother board, or the out side plug?
Thank you.

applefreak
October 8th, 2006, 02:37 PM
The plug to the motherboard

apple2fan
October 8th, 2006, 03:09 PM
It does not appear to be corroded, but I have not unplugged it yet.
Anyways, here is some pictures I took:

share.shutterfly.com/action/welcome?sid=8CZNXLVo5ZsMO


The first few pictures are not that great, but towards the end the pictures get a lot better. There are some motherboard pictures at the end.

For now, the computer appears to be working perfectly.. I don't need that special monitor ether.

Thank you.

Terry Yager
October 8th, 2006, 04:25 PM
What did you do to fix it?

Prob'ly had sum'n to do with red-headed virgins, dead chickens, or some such...

--T

apple2fan
October 10th, 2006, 12:57 PM
I think I might have figured out the problem!:yell:
On one of the Daughter boards from the card, there are four IC's that have been put there. They are in D-11-14, the chips are 74LS1615. One of the pins on D-13, there is one bent, but just barely hanging into the socket. I don't know If this Is the culprit, but I'm pretty sure It Is. I didn't see this last time I was looking at the motherboard, but I did this time. This would explain why the computer is not working, but since the pin is just hanging inside, that would explain why It works sometimes.
The reason why I am posting this Is because I'm not sure If this Is what's the matter with It. And If this Is what's the matter with It, what should I use to pry out the chip and fix the bent pin, without breaking the the computer, socket, and the chip?

Anyways, here is a complex list of things that should be cleaned or fixed.
This Is typed exactly how I wrote It In my notes about the computer.
(when I say corroded, I don't mean something extremely bad, like rust, I just mean a little bit of grime that I might want to clean off.)
Here you go:

Daughter board - IC D-13 74LS1615 PIN HAS BEEN BENT. Need IC extractor EDITED TODAY -74LS161 NOT 74LS1615
E-14 SN74L5283N - some corrosion on pins
C-13-14 SN74LS32N - Very little corrosion.
E-3-10 ITT'S (RAM'S) - Little To no corrosion.
D-3-10 'GOLD' ITT'S (RAM'S) - Almost no corrosion (small little pencil marks at the top of some.)
C-3-10 ITT'S (RAM'S) - Some corrosion.
J-1 - little corrosion.
Slots 0-7 Not damaged. (few scratches due to use. Normal.)
Power connector has not been damaged. (No corrosion.)
NOTE: Video out has some regular damage due to use.
D-1 Ram block - Good.
E-1 Ram block - Good.
F-1 Ram block - Good.
Video out Jack (pin) - Appear to be good.
USER 1 Jumper (solder pads) - Appear to be good.
Game 1/0 - Good.
Speaker connector - Good.
NOTE: Speaker works, and has been modified to shut off when ever Headphones are Entered into the Headphone Jack. Wires have been taped together - Why not soldered?
Keyboard connector - apparently is good.
Could PAL frequency crystal be the problem? doubt It.
All other connectors, IC's, ect. appear to be good.

That was a lot of typing!

Any suggestions on how I should take out the bent IC?
Please tell me What you think is the matter with computer.


Edited today:
Here are the REAL pictures:
share.shutterfly.com/action/welcome?sid=8CZNXLVo5ZsMs

Mike Chambers
October 10th, 2006, 01:01 PM
ouch! i dont have any apple's but that certainly doesn't look good :shock:

apple2fan
October 10th, 2006, 01:26 PM
Hea I know, I'm not sure how I didn't catch that the first time!
Edited today:
Here are the REAL pictures:
share.shutterfly.com/action/welcome?sid=8CZNXLVo5ZsMs
__________________

applefreak
October 10th, 2006, 01:29 PM
i can't use the link to the pictures
error .......

apple2fan
October 10th, 2006, 01:40 PM
Dang it!!:mad:
As soon as I can, I will get them put on to shutterfly.
Quick description:
BAD, someone forced the chip into the socket on the daughter board, and one of the pins apparently was not lined up with the hole, and It got bent, badly.
But It didn't break, so there is still hope for the original chip, cause I'm not soldering a new pin on there!

apple2fan
October 10th, 2006, 05:11 PM
Syntax Error?
Edited today:
Here are the REAL pictures:
share.shutterfly.com/action/welcome?sid=8CZNXLVo5ZsMs

Terry Yager
October 10th, 2006, 05:27 PM
Why does it insist I create an account?

--T

applefreak
October 10th, 2006, 05:40 PM
same here
i don't want an account
no access to the pictures

apple2fan
October 10th, 2006, 06:30 PM
ahhh!!!!
Stupid me!
I'm sorry.
I will fix it.
Edited today:
Here are the REAL pictures:
share.shutterfly.com/action/welcome?sid=8CZNXLVo5ZsMs

apple2fan
October 10th, 2006, 06:44 PM
Fixed It.
Now you don't have to make an account. I forgot to click share.
share.shutterfly.com/action/welcome?sid=8CZNXLVo5ZsMs

Click on view pictures and start at the second one. The second one shows the first full view of damaged pin.
It is the second one on the left one over, It is the first pin. You will notice It. If you can enlarge It.

apple2fan
October 10th, 2006, 07:57 PM
If the new windo does not work on your computer, please tell me.
Applefreak & terry, sorry about the mess up.
Edited today:
Here are the REAL pictures:
share.shutterfly.com/action/welcome?sid=8CZNXLVo5ZsMs

Terry Yager
October 10th, 2006, 08:14 PM
Looks ok now, but still no help. Are you sure of the chip numbers? I can't find anything anywhere on 74LS1615. Looks like ya may be stuck with soldering the pin after all.

--T

apple2fan
October 10th, 2006, 09:18 PM
Well, I might be able to find another motherboard, and switch out this particular chip.:)
I could just take one from an apple II+, there chips are almost exact.
The chip I'm talking about Is in one of the 74LS1615, D-13, that was removed from the motherboard, along with the other three, and the board (just sockets) was put in there original sockets. The 1615's where then inserted into the board, making It an daughter board. All this was just so It could hook up to the card with a ribbon cable. Apparently In the process of inserting D-13, the 'first pin' was bent, and not repaired.
I don't know who the original owner was, but I might be able to trace the serial # back to the original buyer. I don't know why I would do this, maybe just see who originally owned It. I just don't understand why he didn't fix It.
Edited today:
Here are the REAL pictures:
share.shutterfly.com/action/welcome?sid=8CZNXLVo5ZsMs
Edited today
Sorry Terry, you where right about the chip's being wrong. And I thought I new what I was doing!! (:

apple2fan
October 10th, 2006, 10:00 PM
Guys, I must be tired or something!
Terry, the chip that Is damaged IS NOT an 74LS1615, It Is a 74LS161.
You were right, sorry. I need to do my math.
Sorry I'm so unreliable today!:)
Edited today:
Here are the REAL pictures:
share.shutterfly.com/action/welcome?sid=8CZNXLVo5ZsMs

Terry Yager
October 11th, 2006, 09:42 AM
Ahh, in that case, try here:

http://www.datasheetcatalog.net/cgi-bin/helo.pl?text=74LS161&action=Search

AFAIK, those chips are still in production, so finding one shouldn't be a big problem at all.

--T

applefreak
October 12th, 2006, 07:07 AM
a hi-res photo of one of my apple II's
(3264x2448 pixels)

apple II motherboard (http://idisk.mac.com/lefevere/Public/DSCN3014b.jpg)

the cards are removed except the language card

ahm
October 12th, 2006, 07:11 AM
So is it just me, or does it look like apple2fan's D8 ROM is missing?

applefreak
October 12th, 2006, 07:27 AM
it' clear to see on his photo's 0619 or 0630
the ROM-D8 is missing
341-0012-D8

ahm
October 12th, 2006, 07:39 AM
the ROM-D8 is missing
I imagine that might affect the machine's operation in some way.

apple2fan
October 12th, 2006, 10:39 AM
Nice pictures. want to trade? -joke.:D
I noticed the ROM was missing, but I don't know If It was originally sold like this or not. On some other web sites, that particular ROM was missing too, but they never said If there's was working or not. I just don't understand why It worked a couple of times. I would go and take the 74LS161 out, but I don't have the proper tools. Someone else Emailed me, and suggested using dental tools, but I don't know where to get these. One of my manuals says to use an "IC extractor" to take the IC's out, whatever the heck that Is. Plus I don't Know If I can even fix the chip's pin. A needle nosed pare of pliers would probably work though.

applefreak
October 12th, 2006, 12:06 PM
using dental tools.
never use metallic tools to pull out chips
use a IC extractor and/or a smal plastic nife to lift the chip out of it's socket
IC extractor : a smal tool, and cheap, you can find this on the www (search)


Plus I don't Know If I can even fix the chip's pin
you have probably other chips from other old not working hardware and remove a pin of such an old chip (destroying the chip)

or buy a replacement (verify exact number with a magnifying glass)

applefreak
October 12th, 2006, 01:18 PM
missing ROM-D8 ...

The apple II reference manual (209 pages) at page 89
fig 10 The apple Main Board

ROM-D8 & ROM-D0 are not on the board

so they are not necessary !

apple2fan
October 12th, 2006, 04:06 PM
I will probably check Radio Shack first, but on this web sight there Is a yellow IC extractor, does It look like It would do the job?
Here:
http://www.abra-electronics.com/catalog/tools/icp_20.html
Thank you.

applefreak
October 13th, 2006, 09:24 AM
yes, this is good for the job
and use in combination a smal plastic knife(form) to helping lift up

disassemble the case so you have access at all chips and a better overview on the logic board

apple2fan
October 13th, 2006, 07:56 PM
I tested out my IC extracting skills today on a Disk II interface card and..... I didn't break it! Took three chip's out, and put three chips back in, as simple as that. Tomorrow I'm gonna fix the apple II, and hopefully that will be It.
5 pages Is a lot! Thank you. I will Inform you When I fixed It.
And applefreak, do you mean use the knife to lift It out or something else? thanks.
share.shutterfly.com/action/welcome?sid=8CZNXLVo5ZsNo
HPIM0610.JPG