View Full Version : Getting around root password on IBM RS/6000 Model 250

October 11th, 2006, 09:32 AM
I've recently fired up an old IBM RS/6000 (7011-26) Model 250 - one of the very first PowerPC 601-based machines, IIRC. I've discovered that AIX 4.x is installed, but not knowing root password, I can't login.

In the hopes that single-user mode would not be password protected, I flipped the key switch to service mode and rebooted. I was prompted for root login, also requiring a password.

Everywhere I've searched states that I have to have install media (tape or CD) in order to boot and get in to hack the password file.

Does anyone know any way around this? If not, I'll just have to keep searching for install media. (I've seen some go on eBay awhile back...)

Speaking of install media, since this is a MicroChannel (MCA) machine, I believe, I understand Linux is still not a viable option. If someone knows otherwise, please let me know.

October 11th, 2006, 09:40 AM
Linux does NOT get along with MCA at all. From what I've gathered from discussions with other people at the MCA Mafia sites, you have to write your own MCA stuff to get Linux to work with it. As far as I know, no root password, no access, no exceptions. I've never messed with AIX though, but I know there are people here who have worked with it their entire lives. SO Linux doesn't like MCA and since its Power Processor based, you would have to find a PPC distro, and I haven't really found too many. (Or just never noticed them.)


October 11th, 2006, 03:53 PM
Yeah, we had a few of those RS/6000 model 250 at the computer club. The MCA flavour of Linux didn't support PowerPC architectures, and the PowerPC flavours didn't support MCA bus. Back then, there was yet another of those enthusiast projects ongoing to port Linux to this particular machine. They had come as far as booting the machine and display some funny numbers on the display, if I recall correctly. It is about five years ago, so unless they gave up, one would hope they had reached further by today.

Sorry, I don't know how to bypass the root password other than reinstall the system. (on a different disk and mount this one?)

October 12th, 2006, 10:27 AM

Gimme a day or two to scrounge in the garage.
I'm almost POSITIVE I have a set of AIX 4.3.3 that I copied from a friend a few years ago. It's a 4-CD set.

Your box does have a CD-ROM drive, right?


October 12th, 2006, 01:54 PM
That would be great! I've an external SCSI CD-ROM drive I use on my Suns and NeXT occasionally. If that won't work (block size is an issue...?), then I have another SCSI CD-ROM that I can pull from a PC and put in an external SCSI enclosure.

Thanks for looking around for them!


October 12th, 2006, 02:14 PM
I believe the same CD-ROM we used to our Suns worked with the RS/6000 as well, give or take if it needs an adapter for the SCSI connector. We even had one 1X external Apple SCSI CD-ROM that worked about as well, perhaps with exception of burned CD-Rs.

October 12th, 2006, 07:30 PM
they're special, but not hard to find. The difference, is 512 B/sector, versus 2048 b/sector for standard PC ones.

Toshiba made a ton - XM4101 and up. Those actually have either a jumper, or trace on the rear you cut.

Brendan, I've never used these, so don;t be heartbroken if it doesn;t work!
I wrote "AIX 4.3.3" on the CD's, and there's 4 cd's - I assume you boot, and go to single-user mode. I do not know whether you have to manually mount the HD filesystem, or if it's automatic. I think google might be your friend here.
I know I have found info in the past on doing that with SGI Irix, and HP-UX.

BTW, for the rest of you, I have Irix 6.5.8, 6.5.10. 6.5.18, and 6.5.21, as well as HP-UX 11i.

Now - is there somewhere i can upload an .ISO to for you? FTP or otherwise?


October 12th, 2006, 08:11 PM
PMing you momentarily!

October 13th, 2006, 08:58 PM
First CD upping


November 17th, 2006, 11:05 AM
Thanks for all of the help and input from everyone. Last night, I ended up using my "Sun" (purple Toshiba-made) XM-4101B Version 204B ROM EA50624 set to SCSI ID 6 and termination (and all other jumpers, for that matter) off in the _internal_ SCSI chain (obviously, between the controller and the already-terminated hard drive). Then I was able to get into a single-user shell which mounted the hard drive for me and remove the 3 lines following root in /etc/security/passwd. Finally, I reset the password using the passwd command, synced, and rebooted.

Not sure why the external SCSI port doesn't work, unless there's either something wrong with my cable or it's considered to be a security issue.

Just thought I'd share in case anyone else ever has this problem. Thanks again for the input, all.

November 25th, 2006, 06:46 PM
BTW, for the rest of you, I have Irix 6.5.8, 6.5.10. 6.5.18, and 6.5.21, as well as HP-UX 11i.

Now - is there somewhere i can upload an .ISO to for you? FTP or otherwise?



Is there some way to get a copy of Irix 6.5.21? I grabbed a cd set of 6.4 when I left SGI (which was the most recent at the time), but it seems like all the public domain software is compiled against 6.5.

I'll check at work - you might be able to dump .iso's into my work's FTP server. Can iso's be made from these 512byte block size CDs?



April 4th, 2008, 09:54 PM

Are the copies of AIX still avalable, I am geting a RISC 6000 250.



June 14th, 2008, 08:58 AM
To MPATORAY, Matt check your mail here.

Take Care,

October 17th, 2010, 10:03 AM
Hi everyone. I have a RISC/6000 7011 model 250 that I want to make work again. At the boot process, it shows a bunch of numbers at the LED screen until it gets to c32 and then I see that AIX starts to boot on the serial console. I see a lot of messages appear, unit it hangs and I don't get a login prompt.

I don't have the root password anyway, so I was wondering if any of you guys can point me to where I can get the installation CDs.