PDA

View Full Version : Setting up NE-1000 compatible card to acces internet.



Luke
October 13th, 2006, 04:35 AM
Hello, I have 8-bit card with RJ45 port.
Here I found card similar to mine, because I haven't find it on TH.

It's Invisible Ethernet 1000/V2.4 (http://www.invisiblesoft.com/invlan/download/manual/1000v24.zip).

Only location of J4 and J11 jupers are different, but I think, that it doeasn't matter.
I want to acces internet using Lynx.

I have host computer connected to internet via ISDN and PLANET swich.
Computer is connected trough switch.
I put IP, network mask and gateway wich I got from ipconfig typed on XP machine to doslynx.cfg file.

I think, that I've put all jumpers in right way, but I can't load any web page.
When I connect RJ45 one LED is on, but even I'am trying to load website, second LED isn't flashing.

Packet driver tell me, that somethin is wrong with multi-bit and it will reset it...

chuckcmagee
October 13th, 2006, 05:06 AM
For starters, figure out how to read the LEDs on the switch. It will tell you the connection speed (10 Mbs) and half or full duplex. The next step is each card must have a unique IP address. I use the super standard 192.168.0.x range myself. I make 192.168.0.1 my router and use DHCP to assign the rest of them. Once you know some of the IP addresses on the local network, you can use the "ping" program to see if you have any packets going around. Like I will ping "192.168.0.100" and it will come back with an answering ping (0.100 is the first DHCP address). In addition to the IP address, you have the network mask (255.255.255.0) and the default router (192.168.0.1 in my case) and the primary DNS IP address (again I use 192.168.0.1 because my router chains to the correct DNS addresses). If you get DHCP working, it takes care of ALL that addressing stuff.

I just love networking (NOT!).

Mike Chambers
October 13th, 2006, 04:28 PM
i hope your card isn't broken... those ne1000 compatible boards are SO old now...

Luke
October 14th, 2006, 01:54 AM
Nothing works...

DOS Lynx is set correctly, LED is on, when RJ45 cable is connected.
One thing is strange - it doesn't matter what parammeters I enter packet driver always say me, that multicast bit is wrong and it will reset it...
Seems like driver isn't working... or card is set in wrong way.

Or maybe DOS Lynx need adress other than 0x60?

mbbrutman
October 14th, 2006, 05:47 AM
Did you read http://www.brutman.com/Dos_Networking/ ?

The packet driver gets told which software interrupt to use. 0x60 is generally available to use, but that depends on what other TSR software you are using. It's possible that 0x60 is in use so you would need to use 0x61, 0x62, etc.

The packet driver should tell you if it was able to load correctly. This includes being able to use the software interrupt that you specified, and being able to read the MAC address from the card.

I would never start with DHCP - there are too many variables, and there have been many changes over the years. Using a static IP address on your PC is the easiest setup option, and it makes debugging easier too. For a simple test you don't need the gateway or netmask parameters on the TCP/IP stack. Instead, just see if you can ping another machine on the same network.

chuckcmagee
October 14th, 2006, 08:54 AM
I just explained the whole thing in case he gets the card working. Lynx for sure needs all that other stuff to web browse.

mbbrutman
October 14th, 2006, 09:08 AM
And I told him to use static addressing instead of DHCP because DHCP is a rathole on earlier TCP/IP implementations. He can add the gateway, netmask and DNS addresses later once he verifies that he has basic connectivity.

chuckcmagee
October 14th, 2006, 09:24 AM
:D :D Ok, I would have to agree on DHCP, especially in a vintage DOS environment.

Luke
October 14th, 2006, 10:25 AM
...where I can find something to ping host? :dontgeti:
Ping.exe is 32bit.

chuckcmagee
October 14th, 2006, 10:41 AM
See if you can find an old "Novell Dos Requestor" for dos installation package somewhere. It has a ping program that works in dos.

mbbrutman
October 14th, 2006, 10:51 AM
Luke:

http://www.brutman.com/Dos_Networking/

Has a pointer to Trumpet, which is a TCP/IP stack. It also has applications like ping, ftp, telnet, etc. It is also what Mike C. used for his VNC code.

You really have to read and experiment more first before asking. It doesn't seem to matter if anybody lays it out for you.

chuckcmagee
October 14th, 2006, 11:47 AM
Chuckle, which is why I told him to go looking for Novell instead of doing all the legwork myself.

Luke
October 14th, 2006, 11:50 PM
So... when I type 'ping2 192.168.0.1' it give me 'Error - TCP not loaded'.
Before I've loaded NE1000 pcket driver, but it seems, like Trumpet need it's own driver wich is not working for me.

I also can't ping 386 from host.
I think, that's because I don't have IP set on old machine...
how can I set it?

I'am trying to get hub with BNC and use original NE1000 from Novell...

mbbrutman
October 15th, 2006, 06:32 AM
First you need to load the packet driver.

Next you need to load the Trumpet TCP/IP code. I use NTCPDRV, which is supposed to be smaller and more appropriate for older machine. NTCPDRV is the DOS TSR that provides the TCP/IP function. You will have to tell NTCPDRV what IP address to use at a minimum.

Then you can run ping2.

Read the directions for NTCPDRV.

Luke
October 15th, 2006, 07:23 AM
Okay, TCPDRV see the packet driver.
But I can get anything pinging 192.168.0.1.

Maybe card is configured in wrong way?
My configuration:

- Remote boot ROM memory adress D800:0
- IRQ 7
- No DMA
- I/O base 300h
- Autopolarity function is distabled
- SQE function is distabled
- Cable lenght is set to normal
- Link test (?) is enabled
- and unknown J9 jumper not mentioned in manual is set on 2-3 pins

mbbrutman
October 15th, 2006, 07:33 AM
Are the lights on?

What parameters did you pass to NTCPDRV?

What machine are you trying to ping?

What is the error message from ping?

Luke
October 15th, 2006, 08:13 AM
One LED is on, when RJ45 is connected.
Second one indicates action on network, but I've never seen it in action.

I run something like this 'TCPDRV -ip=192.168.0.2 -gateway=192.168.0.1 -netmask=225.255.255.0'.
I also tried without netmask and gateway, but it doesn't matter.
It's something different? TCPDRV and NTCPDRV?

I'am trying to ping host, machine wich is connected via ISDN to the internet and via swich provides internet to other two computers.

Ping say 'Trying 192.168.0.1' and do nothing for long time.
I must press Ctrl+Break to exit it.

mbbrutman
October 15th, 2006, 03:31 PM
If you were to unhook that machine from the network and put a known good working machine there, would it be able to ping the same target machines?

Luke
October 28th, 2006, 05:46 AM
I'am very confused.

I have tried everything with JR45, now I'am trying to setup network on BNC cable.

I have only one terminator (I'll search for another on monday), so I can't get connection between two computers, but I should be able to ping 192.168.0.1 from 192.168.0.1, yes?
But I can't. I load NE1000 0x60 3 300 (parameters are good, exactly what I set by jumers), then TCPDRV -IP=192.168.0.1 and PING2 192.168.0.1, I don't get anything.

I do something wrong? Card is genuine Novell NE1000.

mbbrutman
October 28th, 2006, 06:29 AM
Did you try to put a known good working machine on that cable to be sure that it is not a cabling/switch/hub problem?

If you don't have enough terminators, it won't work. Or might might work a little bit, but you have very little chance of getting data back and forth.

Ever look through a glass window and see yourself? That reflection is similar to what happens when a signal 'hits' the end of a wire. The terminator is there to absorb the reflection.

Does the packet driver tell you the Ethernet address of the card? If so, then the driver and parameters are correct and the card is semi-functional at least.