View Full Version : AS/400 9402/f02 system I acquired a while back. Looking for some info and help.

May 10th, 2015, 11:52 PM
Let me start by thanking contributing members in some of the older AS/400 threads I found. I have read through and continue to look through these forums and others.
I have been pouring over the system builders guide found here:

Ok, so here's where I'm at now. I've had this system sitting in my shop for the past 2-3 years. The machine and all of the extras for it were acquired from a guy in town that used to teach RPG and Cobol at the local community college. Thinking about it, he probably still has the cabinet full of books for this unit. I powered it on and tinkered with it a couple of nights after getting it, but aside from that it's sat unplugged and dormant ever since. At some point I did enough investigating to have ordered a network card for the thing. To add to this, I found the document I had scribbled the main password and account info for it on.
As of right now, I'm off work following an operation last week (nothing major) so I have some time off that I'm stuck around the house. I've been thinking about getting a friend to move this thing to my office so I can hook it up and tinker with it. (I'm on restrictions for lifting right now.)

Pictures of what I have can bee seen in my Photobucket album.

So, here's what I am wondering. I was given a couple of tapes with the system, the guy said one of them was the main backup. I'm looking to find out how I would go about seeing what's on the tape(s) without actually restoring it. Are there any resources out there for getting a full system (all options) tape or is this unheard of. Next, let's say I have this thing up and running and I find out it has most of the available options installed on it, what do I need to do to do a full backup, something I can bare metal restore from?

Thanks for the responses, I had posted one or two replies to this post throughout the day, but neither have been approved yet. For some reason after coming back to this forum after about a year away, it's like I'm a new member on probation.

So just to update: I did manage to get the machine in the house, I got a terminal hooked up, I managed to lock the QSECOFR account, I managed to find out the tape drive is malfunctioning, I was able to get it booted into IPL B mode, I found out that I need the system password, and I'm now in the process of trying to get the system booted in Normal mode and log in with the now unlocked (I hope) QSECOFR account.

Please forgive me for the post being worded in a way that may seem incomprehensible. Part of the problem is that I'm not an IBM guy, in the 6 years I worked as a network admin I only ever had limited dealings with our AS/400 system. I guess some understanding of IBM jargon would help, but I'm at a shortage on that. My questions pertaining to backup and restore have a lot to do with my background, I don't like to tinker with something that I could kill beyond repair. I don't mind wading off in a system that I can restore, but with the age and condition of this thing, restoration media is not readily available. Of course, after all I've done tonight, I now know that the tape drive is non-functional at best, and it managed to cut a groove on the center roller of the backup tape I have.

May 11th, 2015, 08:10 PM
Well, an update to this post. I managed to persuade a neighbor into hauling this thing in from my shop for me. I'm in the process of booting it and getting logged in. I hit a small hiccup in the fact that one of the terminals has a power button that won't stay in. This is a problem because it was the 0 console and I believe the QSECOFR account was tied to it. I found out how to get one of the other consoles changed (hold the spacebar while turning it on), so wish me luck.

May 11th, 2015, 09:25 PM
Well, final update I guess. I tried to boot the unit in IPL mode d with what was supposed to be a good backup tape of the unit. Well, the unit fired up, acted like it was restoring and did nothing. I powered it off, pulled the tape, which now has a groove worn on the tape roller (QIC style tape) and the spools are all unwound inside it. It looks like I'm at a standstill unless someone knows how to get in a menu and reset the security on this thing.

May 11th, 2015, 11:11 PM
I'm not sure what you are trying to do. Get the machine running? If it was working when you got it, why do you want to restore the system?

In my opinion, if you have a working AS/400 c/w the QSECOFR password, I suggest that you start by learning to drive it. :-)

Edit. I forgot. When you have got it IPL'd and you have logged on, the command for switching it off gracefully is PWRDWNSYS

May 11th, 2015, 11:47 PM
I agree with beer hunter. Spend a couple of days looking round the system. The AS/400 is almost all menu and panel driven, and if the options you desire exist I am pretty sure you will find them.

May 12th, 2015, 09:23 AM
It is actually quite difficult to do much damage to an AS/400. You need to try really hard.

Remember these boxes were designed to be run by non-computer people. For example, they are massively more easy to use than PCs running under PC/MS DOS.

May 12th, 2015, 07:13 PM
The command wrkcmd follow by command string will help guide you. You can use the wild character * to get a list of commands as an example wrkcmd str* will display a list of the str for start commands. You can then type in a command then press the F4 key for valid options for the command. Then placing the cursor on any option and pressing the F1 key will provide help for that option.

What version of OS400 is installed, I probably have the manuals on CDs?


May 12th, 2015, 10:21 PM
Please don't get the impression that OS/400 is command line driven, that is only for those who know. Mostly, one can quite happily drive it via the menu structure.

May 13th, 2015, 09:40 PM
I spent an hour or two on the machine yesterday. I remember the local library running off of these. The six years I worked in IT for the state, we had a bunch of jobs that ran off of a couple IBM mainframes downtown. I used to set up the 3270 and 5270 clients on machines to access them. Oddly, my wife worked in the same office as a processor and ran data verification on batch jobs for about 8 of her years there. That is, up until those jobs were put onto a newer system. You're right BH in the fact that the menus are pretty intuitive.

The O/S on this machine is V3R2. I appreciate the offer for the manuals.
When I got the machine the guy gave me a number of the IBM 3 ring binder books (15 or so) along with several other AS/400, OS/400, Cobol and RPG books. I may have mentioned in the original post he still had 3 good shelves full of binders and whatnot. Also, while probing around on the machine, I found several entries that look like class materials that probably pertain to one of the textbooks he gave me.

I may try to call him tomorrow and see if he has the system password written somewhere to re-enable the system.
Would anyone know what is needed to connect this unit to my tcp/ip network at home? I ordered an expansion card, but I don't have a slot to add it in, there's a metal blank that looks like it covers an accessory slot. Then there's the issue of the defective tape drive, I've had pretty good luck repairing items like that. Would it be possible to get another one or is there some other media expansion I could use in this system.