PDA

View Full Version : TI Organizer (PS-6600?) extremely glitchy



Capt. 2110
May 23rd, 2015, 03:57 PM
Hi,
I have an 1991 TI Organizer PDA that has some issues. I got it for a dollar at an electronics surplus store. Sounds great right? Wrong. I got it with the plastic being extremely sticky (Fixed that with Windex.) and with Duracell batteries that expired in 1999 (That makes them from 1994, right?). When I put new batteries in, it didn't start. I didn't think it would, but one can hope. After pulling it apart, I saw tons of corrosion on the positive terminal. I cleaned it all off, put some batteries in, and it started! However, it crashes a lot, the keyboard seems to be... broken... in some ways, and its battery terminal (Positive) broke. After cleaning the main board and soldering the battery terminal back on, I'm right back where I started. Does anyone here know what's wrong with it?

Thanks,
Capt. 2110

P.S. Here are some photos of the inside of the unit.
I have some shots of the errors too, if you want to see them.

cobracon
May 24th, 2015, 02:15 PM
CE1 and CE2 in the last pic, don't look good. I would replace those caps and check the traces.

Capt. 2110
May 25th, 2015, 08:14 AM
I cleaned the keyboard a bit and it started working a lot better. I'm probably going to replace the caps anyways, since the unit is from 1991, and pretty much all of my 1990s devices have/had bad caps. When I was cleaning it some of the writing on the case came off. Instead of "Texas Instruments Organizer", it says "Texas Instrun(The M was damaged)s Organizer. How would I go about reprinting those?