PDA

View Full Version : Kaypro II - Two bad disk drives?



Zakarth
May 24th, 2015, 08:28 AM
Hello! First post. I am new to vintage computers but I have worked on some from my childhood. Recently bought a Kaypro II. I read through tezza's FDD woes and have come to conclusion my problem is different. In this case neither LED works from either Drive A or B. The spindle spins and never stops when disk goes in. Service manual implies that I may be looking at a logic board failure but I haven't done any extensive troubleshooting.

To save time I bought a known working drive on eBay. Until it arrives, any thoughts?

Thanks in advance!

MicrocomputerSolutions
July 1st, 2015, 01:07 AM
Hate to say it (you should have the drive you bought by now), but most known working drives sold on eBay are not function tested. If you read the Seller complete ad, it usually says that the Seller tested the drive to see if it would power on. No testing was done to see if it actually works. And the drives are never tested for proper alignment.

I usually suggest spending more money and either getting your non-working drives tested (and repaired if necessary), or only buy drives that the Seller states have been fully tested and aligned. Otherwise you're taking your chances with 30 year old drives, ripped out of a piece of equipment that is being junked, and you have no idea of the condition of the drive/s you are buying. Your new drive might be out of alignment or non-function, and may ruin every disk that you put in it.