PDA

View Full Version : Directory problems with PC-DOS 5.02



BanjoBoy
June 23rd, 2015, 08:10 PM
I really could use any help. I have a PC-DOS 5.02 system. I have a directory that will not delete. It is listed in the command line, DOSSHELL, and Windows, but DOS says (when I try to delete it) that it does not exist. There is nothing listed in this directory. I tried renaming it, and the same thing happens. I try doing it all through Windows, and still, the same thing. I have had this problem before on this machine, and the only way out I found was to reformat the drive, get rid of the partition, reinstall DOS, and then, reinstall all of my software. I am willing to do this as a last resort, but if there is any way to get rid of it other than re-doing everything, please, let me know. This would save a day's work (literally: I have tons of small programs on it). None of these programs created the directory, so it is not the programs fault. I got it in a download, a download I have used before, and extraced, but I have never got this problem from it.

The commands I used to try to delete it: RD, RMDIR, ERASE, DEL

The browser I used to download the zip file which created this directory among others that deleted just fine: LYNX

Version of Windows: 2.03

I put this information above just in case it might be relevant.

Any help is greatly appreciated!

Krille
June 29th, 2015, 01:17 AM
What is the name of this directory? If it has the same name as a device driver then DOS won't be able to delete it. The same applies if the name contains illegal characters.

You probably tried using something like CHKDSK, Scandisk or Norton Disk Doctor already? If that doesn't work then Norton DISKEDIT definitely will (assuming the machine can run DISKEDIT, I don't know the processor requirements for it and you didn't say what kind of machine this is). Just rename the directory with DISKEDIT and then delete it the usual way.

BanjoBoy
July 3rd, 2015, 11:09 AM
Thanks for the reply, but I just formatted it the day after I posted this. Under Windows 2.0, it showed a space (illegal character), but under DOS, there was a space originally, but somehow, it dissappeared. As for the programs you mentioned, I did not even realize that CHKDSK was on DOS 5 (I thought it was only DOS 6), but I do not have Norton Disk Doctor or Scandisk. But anyway, Thanks for the advise, as I will probably need it in the futre (this problem has happened to me before).

g4ugm
July 4th, 2015, 02:39 AM
There are a few tricks around using "%" wild cards for renaming or deleting of directories. Also ATTRIB will some times find files that DIR doesn't show....