PDA

View Full Version : Help with CompuPro DISK3 and Quantum Q540



retrogear
July 1st, 2015, 08:22 AM
This might be a 2nd thread. I haven't seen my previous one show up yet.

Step by step I'm trying to bring more items back to life on the CompuPro 8/16
system I recently obtained. My system configuration is an 8085/88 cpu, System Support I, Interfacer 4, RAM22 256k, 2 x M-Drive 512k and a DISK1 connected to a NEC1165 DSDD 8". So far I can boot cp/m 2.2LD and cp/m86 1.1PD which also creates a 1024k M: ram drive. I also received a DISK3 controller which I have soldered in 3 x 7805 regulators to use in this earlier version chassis. I have had a Quantum Q540 hard drive for years which has had very little use. I verified it is good by connecting it to a WD1002 MFM controller in my IBM PC then formatted and installed
MSDOS so I know the hard drive and cables are good. So I connected it to the DISK3 controller in the CompuPro but have the hard drive externally powered by the
IBM PC. Not sure if this is good but only way I have to externally power the Quantum. I have the Quantum jumpered as DS1 (the choices are DS1-4). My hard drive cable is straight thru, not twisted. I notice when I power on the CompuPro that the Hard drive LED comes on and stays on always. Not sure if that is normal? (In the PC it only lights when selected). I have an original DISK3 formatter disk. I booted cp/m 86 and ran DISK3 Q540 ALL command. It shows the drive parameters, then asks confirmation. When I press Y it just hangs. Anyone still around familiar with this? It's interesting I can use this same disk image in Altairz80 emulation and the disk3 program runs just fine. I'm pretty sure my solder job is ok. I read 5v out of each of the regulators I put in. I have an S100 extender card, voltmeter, oscilloscope but no experience / knowledge in S100 technology or waveforms so I'm "flying by the seat of my pants" as they say. Any help appreciated.

Larry G

retrogear
July 3rd, 2015, 01:03 PM
Got it !!!

Pardon my enthusiasm but after checking my settings over and over plus examining the DISK3 controller for the umpteenth time, I noticed the 8085 processor very slightly elevated. I went through all the chips and pressed them in and heard
a crunch sound on many of them indicating some further seating occurred and now at least the DISK3 is formatting the drive !!!

Larry G

pjh
July 25th, 2015, 10:56 AM
Glad you solved your problem with the board. A lot of times re-seating the chips in an old board will fix most board problems. Enjoy using your CompuPro.

Phillip

MicrocomputerSolutions
August 1st, 2015, 08:07 PM
I think you need to get later versions of Compupro CPM and CPM86. The versions that you have don't support the DISK-3 properly.

If I remember correctly the first version of CP/M80 that supports the DISK-3 is 2.2N, and there are bugs with varying severity in the versions up through version 2.2R or 2.2S. For CP/M86, you want at least version 1.1R.

If you want to boot direct from the hard drive without booting a floppy drive first, you need to get a DISK-1A or DISK1B. The later floppy controller boards will also allow you to run 3.5", 5.25", and 8" floppy drives at the same time.

retrogear
August 2nd, 2015, 04:30 AM
Thanks

I have a thread going on comp.os.cpm with updates but I'll post here too. I know
the DISK3 manual indicated I need at least cpm 2.2Q or cpm86 1.1R. I do have
cpm 2.2N booting on floppy. I'll check and see if it has the DISK3 driver.
I couldn't get 2.2Q to boot yet. I really do want a DISK1A card if anyone has one
for sale? My struggle has been with modifying the step rate for my NEC1165 8" drive.
Spec says it's 3ms but for the loader I've had to slow it to 5ms.
My biggest achievement so far is getting Concurrent DOS 3.1 DM to boot.
I have a laptop running Windows XP using ProComm for a terminal on the CompuPro
System Support - 1 serial port:

CP/M 8-16 1.1Sb loader --

Bdos Err On A: Bad Sector
Can't open CCPM.SYS
What CCPM*.SYS Do You Want To Read ? : 340
Loading CCPM340.SYS


CompuPro XIOS Ver 3.1D
Total Memory: 256K
1 Megabytes M-DRIVE/H active as M:
Disk 1 Controller present:
8 inch Drives as I: J:
5-1/4" Drives as K: L:
Disk 3 / Q540 unit #0 A: B: C: D: E:
8087 Numeric Co-Processor Present


Concurrent CP/M-86 3.1
Copyright (C) 1983, Digital Research
***** 3.1 DM Maintainance Release 9/3/85 *****
Concurrent CP/M 8-16 Copyright (C) 1984, 1985 CompuPro
PC Mode

XIOS, SW, SHELL, LOADER Copyright (C) 1981, 1982 1983, 1984, 1985 CompuPro.
Serial Number 0272-001837

3?:31:27 A:MFORM.CMD
0A>

The Bdos error puzzled me. I get that on most the disks I received with the system
and they won't boot further. They are copies and I didn't receive any disk drives
so I'm using my own. With this disk it gave a bdos error that it couldn't find ccpm.sys
even though it's on the disk. By chance I found that just pressing enter it would
ask for the name and then boot !!

It turns out this is actually a symptom of an incorrect floppy step rate. I went
thru the procedure in the Viasyn Customization Guide for Concurrent DOS 8-16 starting
on page 8 to customize the loader. Spec on my drive for seek time is 3ms but this was
set to 4ms. I changed it to 3ms and it made the problem worse - pressing enter after
the bdos error wouldn't prompt for a name. I set 1D88 to BF for 5ms and now it boots
entirely and is fully functional with my DISK3 !! I could hear an audible difference
in the loading process. I'm pretty sure my os is still set for 3ms but someone evidently
set the loader step rate to 4ms and I had to increase it further to 5ms. It must be the
seek rate for the loader has to be tweaked independently from the os itself? Now I'm
trying to patch other loaders but there isn't much documentation on how to patch other
os's like mp/m 8-16. I received 3 of those disk copies which only boot to the bdos error.

I soldered a cable to interface my NEC 8" drive with an Adaptec SCSI controller and boot
into Windows 98 dos mode and now I can use Dave Dunfield's ImageDisk to read and write
images !! I imaged my mp/m 8-16 disks and they boot in Altairz80 emulation:

<snip>

Connected to the Altair 8800 (Z80) simulator Serial Input Output SIO device, line 0


MP/M 8-16 Loader Rev. 1.0D.
Loading MPM.SYS

CompuPro MP/M 8-16 V2.1H

40 Megabyte Hard Disk Active as Drives A, B, C, D and E.
4 8-inch Floppies Active as Drives F, G, H and I.
4096K M-DRIVE/H Active as Drive M.

Total memory: 1 Megabyte


MP/M-86 2.1 [20 July 82]
Copyright (C) 1982, Digital Research

MP/M 8-16 Copyright (C) 1982, CompuPro

XIOS, LOADER Copyright (C) 1981, 1982 Sorcim, CompuPro.

SW, SHELL Copyright (C) 1982, CompuPro.


FORMATTING MEMORY DRIVE

0A>

In conclusion, the MPM 8-16 floppy disks can be read into images, the images boot in
emulation, BUT the disks will not physically boot. My drive could be out of alignment but I
really don't think so. I'm thinking since my floppies were copies made on a different drive
with maybe a different density, skew or step rate? I have gotten some images from the 'net
read onto my drive and they boot. Sorry for the long post but much has happened. Fun stuff !!

Larry G

new_castle_j
August 2nd, 2015, 04:02 PM
now it boots
entirely and is fully functional with my DISK3 !! I could hear an audible difference
in the loading process.

One of the things I find enjoyable about old computers is the sounds they make. I can relate to noticing that it sounds different when things are working properly.

retrogear
August 5th, 2015, 03:18 AM
>I think you need to get later versions of Compupro CPM and CPM86. The versions that you have don't support the DISK-3 properly.
>If I remember correctly the first version of CP/M80 that supports the DISK-3 is 2.2N, and there are bugs with varying severity in the versions up through version 2.2R or 2.2S.

I tried booting cp/m 2.2N with it's Q540 driver and it gives "NO DISK3" so my DISK3 card must be a later version firmware not recognized by that os.
My card is revision D which manual says requires 2.2Q. Maybe some bugs were fixed by the newer firmware? I haven't found a copy of 2.2R or S, just Q but it doesn't boot.

>For CP/M86, you want at least version 1.1R.

I have cp/m86 1.1R and 1.1T but haven't got them to boot yet. So far I've gotten 1.1PD to boot but had to use 1.1PC loader - weird.
Maybe my limitations are because of the DISK1 card and I need the DISK1A?

I'm glad Concurrent V3.1D runs smoothly. I have no real goal as far as what os to use, just want to see how much I can get to run on this beast for informational purposes.
It's interesting to note that running this stuff on Altairz80 emulation has occasional lockups or strange behavior so the mentioned bugs must be there too.

Larry G

retrogear
August 5th, 2015, 08:09 PM
I got CP/M 1.1R to boot:

CP/M-86 1.1h loader --

Segment Address = 0041
Last Offset = 34FF



CompuPro Systems CP/M-86 vers 1.1R

System Memory: 256K
TPA Base = 1221:0000

Configured for ...
2 M-Drive/H, active as M:
Disk 1 (8 inch floppy) I: J: K: L:
Disk 3 / Q540 A: B: C: D: E:


A>

Both the loader and the cpm.sys bios needed to have the step rate set to 5ms via ACTIVE.EQU parameter file.
I had to build cpm.sys to include the DISK1 driver (.DVR) file. The DISK1A driver for this version will not function on DISK1 controller.
Most of the boot floppies I have are based on the 3ms step rate and DISK1A so without a DISK1A card or source files I'm screwed :(
My newly built R version is stable for the DISK3. Previous versions were giving an occasional bdos error. It doesn't sound as fast as
the Concurrent DOS which is definitely the best coded.

fun stuff !!

Larry G