PDA

View Full Version : Zenith Z-100 boot ROM image wanted



1980s_john
October 18th, 2015, 01:11 AM
Hi,

I have a Zenith Z-100 (Z-120 all-in-one), but it has an early boot ROM that doesn't have a memory test, and I am looking for a more recent one.

When I turn the machine on and wait for the hand prompt, typing V gives 'Version 1.2'. Typing T just gives a beep, I understand later versions have a memory test.

Looking at photos I think the boot ROM is a 27128 EPROM so should be easy to dump to a file using an EPROM programmer. I don't know if the EPROM is in the memory space in either CP/M (8085) or ZDOS/MSDOS (8088 ) mode.

I have an EPROM programmer so can help reading ROMs of any UK owners.

Regards,
John

ronwoch
October 19th, 2015, 09:16 AM
I know that the early roms had a listing available, they are sometimes findable on ebay. I don't have a copy, and as I am in the middle of getting ready to move (in the process of buying a house) I can't really rip mine apart to try to dump the EPROM. Also, I don't recall what version my rom is anyway - might not be any newer than yours, at least in my main machine. The other two I have, also would need to be pulled apart etc. My EPROM programmer happens to be built into a CPM luggable, as well, so it would be - interesting - to try to get the dump onto a network-enabled machine, LOL.

Anyway, to answer the question about the memory space, I don't know off the top of my head, but either the User manual or the Technical manual should be able to tell you.
If you want to email me, my gmail is my username, so you can bug me to dig up my links from my home computer for online copies of the manuals, etc. etc. if you don't already have them.
Sorry I'm not very helpful atm, but I should be able to at least point you towards several resources for these awesome machines, so long as I remember to when I am at home with time to do it! :)

Best of luck,
Ron

Roman
November 1st, 2015, 01:34 AM
Here is the content of my Z100 boot eprom (Intel 27128-3)
27615
(ignore the .txt extension, it's a .bin file)
Roman

1980s_john
November 3rd, 2015, 01:18 PM
Many thanks, I burned the image to a 27128 EPROM and opened up my Z-100 (easier said than done). I removed the existing EPROM, this was a 2764, and inserted the 27128. On re-assembling and powering on, I got no response - blank screen, no disk activity, no beep.

Is there a jumper for selecting the ROM size please (2764=8kB, 27128=16kB)?
[EDIT]
Found this in the technical manual:

J101 Selects whether +5VDC or address line BA14 is
applied to pin 27 of the PROM. The position shown has
+ 5VDC connected to pin 27 for an 8K x 8 or 16K x 8
PROM. Move the jumper to the other position to use a 32K
x 8 EPROM.
J102 Same as J101 except for address line BA13 and
pin 26 of the PROM. The position shown is for using an 8K
x 8 EPROM. Move the jumper to the other position to use
a16K x 8 or a 32K = 8 EPROM.

So I need to move J102 - a bit late this evening to try now, so will do tomorrow.


I will upload my V1.2 ROM at some point for reference, but it clearly it is not as useful as the newer one.

Regards,
John

1980s_john
November 3rd, 2015, 01:45 PM
Anyway, to answer the question about the memory space, I don't know off the top of my head, but either the User manual or the Technical manual should be able to tell you.

Thanks, found this in the Technical Manual:

Memory Control Latch Port (FC)
This port controls the configuration of memory, both ROM and
RAM. It also provides an option for checking RAM parity. The
options, which affect how the ROM is addressed, are enabled
by writing to the memory control latch (MEMCTL) port.

The following chart shows which port bits control the four ROM
configurations.

BITS DEFINITION
3 ,2 00 = Option 0
10 = Option 2
01 = Option1
11 = Option 3

Option 0, the power-up or master reset configuration,
makes the code in ROM appear to be in all of memory
when reads are performed. Writes, however, occur normally.

Option 1 makes the ROM code appear to be at the top
of every 64K page of memory.

Option 2 makes the ROM code appear to be at the top
of the first megabyte of memory.

Option 3 disables the ROM.


Regards,
John

1980s_john
November 4th, 2015, 12:44 AM
With the jumper J102 changed to a 16Kx8 EPROM (27128 ) my Z-120 now beeps, but there is nothing on the display and no disk activity. I will have to revert back to the V1.2 and check all is OK.

Maybe the ROM is motherboard and model specific, mine has 64K RAM chips, and the video is monochrome with only one bank populated. What motherboard / model does Roman have please?

Regards,
John

Roman
November 7th, 2015, 02:53 AM
He has a different one :D

Here are the pictures of my Z100 motherboard, video and model number.
27693276942769527696
So you can see the board type, the memory chips, the jumper settings ....

Regards
Roman

(unfortunately i shot the power supply, so it has to be fixed before using the Z100 again)

1980s_john
November 7th, 2015, 02:04 PM
Thanks Roman! Sorry your PSU is faulty, I have fixed mine in the past (see earlier posts).

Your motherboard is part number 85-2653-1, which is the same as mine. As per:

http://www.retrotechnology.com/herbs_stuff/z100.html

this is the 64Kbit memory board (max 192KB), can you confirm what memory chips you have as I can't quite read the part numbers, mine has 64Kbit parts, 9 x TMS4164-Z20NL and 18 x MCM6665AL20.

I see your video card has 3 rows of RAM populated (RED/GREEN/BLUE), mine only has GREEN populated. I have a monochrome screen built into my Z-120.

I might try a different 27128 EPROM, not sure what other differences there are.

Here is a dump of my V1.2 ROM 27697 for a 2764 EPROM. I plugged this back in and reset jumper J102, machine booted again.

Hopefully there are also some more ROMs versions out there.

Regards,
John

Roman
November 9th, 2015, 10:18 PM
Hi, John !
The ram chips are all NEC D4164C-2.

Regards,
Roman

retrogear
November 10th, 2015, 03:19 AM
Hello John

I might have what you are looking for. I have the slim model (no display). I set S101 for manual boot and V reports version 2.5 !!! T takes me into a test menu.
I didn't know about ROM versions or how to check until reading this post. My video has slight pixelation and I had run the diagnostics program from disk to reveal I have bad video
ram chips U347 and U353. Those chips are TMS4164-15NL. I currently have some on order. Since I got into the ROM monitor, I ran it's memory diagnostic. It's very slow but
sure enough after about 10 minutes it reports a bad U353. When I get time, I'll post screen shots of the whole process and hopefully a fix with new chips.

I don't have an eeprom reader and don't want to pull out the rom. Is there a way to read it into a bin file? I can sure do that thru a series of monitor commands or whatever.

Larry G

1980s_john
November 11th, 2015, 04:24 AM
Thanks for replies. So my Z-120 has same motherboard and RAM chips as Roman's. I will test my 4164 RAM chips in another PC (IBM XT) to see if any are faulty, and also recheck my 27128 copy of Roman's ROM.

Larry - please see earlier post on mapping the ROM into memory, I suggest using DOS DEBUG command to read the top 16KB of memory and compare to ROM Roman attached. If ROM not found need to write to port FC (above only mentions 2 of the 8 bits - need to see Technical Reference if this port can be read or what other bits need to be set to). DEBUG commands should be in the Z-100 MSDOS manual - further research needed to list the commands to dump the ROM to a file!

Last question is, what Power on self test (POST) does the Z-100 ROM do? My V1.2 ROM doesn't write memory size to the screen, do any of the later versions do so?

Regards,
John

PS 10 minutes for a memory test is typical, my Dell laptop has a ROM based diagnostic that includes a memory test, after 10 minutes it says passed, then prompts 'For a more thorough test taking an hour press function key'!

1980s_john
November 17th, 2015, 03:49 PM
Thanks Larry for your post on your fix to video RAM chips. I notice both you and Roman have three banks of RAM in your video cards (3 x 64KB), whilst I only have one bank (probably 32KB - I need to check my jumpers, as per page 4.3 of the Z-100 Technical Manual). I have checked my main memory chips (4164) in my IBM XT motherboard and they all passed the IBM POST. I have yet to check my V2.5 monitor EPROM, but suspect maybe V2.5 ROM needs the additional video memory.

More memory would enhance my monochrome Z-120, as it allows greyscale video rather than just black/white (well shades of green actually!)

Regards,
John

retrogear
November 17th, 2015, 05:08 PM
To answer a previous question, my 2.5 ROM doesn't display memory size or any information at power on other than the finger of fate.
One question I have is since I have 3 banks of video memory, should I get color from the composite video output?
With color bars, I only get shades of gray. I don't have an RGB display.

>but suspect maybe V2.5 ROM needs the additional video memory

In ROM monitor, pressing S for System shows 192K RAM, 64K Video memory, color.
Curious it only shows 64k video even though disk based diagnostics test 3 banks of 64k video memory.
Maybe the 2.5 ROM only needs 64k ?

Larry G

1980s_john
November 17th, 2015, 11:43 PM
To display colour on a composite video output requires either NTSC (eg North America) or PAL (eg Europe) colour burst signals to be inserted. I haven't seen a reference to either in the Technical Manual, so I think you are limited to monochrome on the composite output.

The other point is that there are these two jumpers. text below copied form the Tech Manual:

J305 8 J306 — These jumpers select color or black and
white video. For color, both jumpers must be on
the side marked "RGB." For monochrome, both
jumpers must be on the side marked "G." When
you are using color, all three RAM banks are enabled
and must have RAMs installed. For monochrome,
only the green bank is used.


The monochrome setting gives the nice grey scale Larry kindly showed in his post.

Regards,
John

retrogear
November 18th, 2015, 05:26 AM
Mine does have J305 & J306 on RGB. The grey scale I displayed in the post about video ram was from the ROM 'C' command. 'S' command shows only 64K video memory even though other two banks of 64K are present and enabled. S command does report 'color' so it might just be looking at switch settings? I will put my scope on the video and look for color burst. Seems like I did read somewhere that the composite out jack is only monochrome. I'll report back here.

PS - yea, reading some more it says rca jack is only monochrome. The RGB out has jumpers for sync to make it CGA compatible which still won't help me :(


Larry G

1980s_john
November 19th, 2015, 02:47 PM
I see there is also a jumper to send composite sync out on pin 9 (rather than vertical sync as per CGA), so the Z-100 should be able to drive any RGB monitor that runs at 60Hz frame rate (like my 5 Sony RGB monitor). Saves having to find a working CGA monitor to try out the colour output, which I spent quite a few minutes researching!

Regards,
John

retrogear
November 19th, 2015, 05:10 PM
I've been researching too and I'm buying a combination of adaptors mentioned here in VCF to have my Z100 drive an LCD VGA display.
Hopefully it works.

Larry G

1980s_john
December 4th, 2015, 02:49 AM
Hi,

I'm still not able to get a new ROM working. I hooked up a monochrome monitor using connector P301 on the video card (as the all-in-one does not have a composite video out socket), and with my original V1.2 ROM I got a readable display (over bright - on the all-in-one this output goes to a brightness pot). This makes testing much easier, as plugging the all-in-one monitor in and out is tricky (uses a large multi-way connector) and prevents access to the video card and motherboard. nb The service manual says you should make up an extender lead for the monitor for testing.

I checked my video board jumpers, these were set for 64KB of RAM (so not 32KB as I thought earlier).

I reprogrammed another 27128 EPROM with the image that Roman supplied, changed the ROM size jumper and tried again, still no video output. So either I need to have three banks of video RAM (which I plan to anyway to enable colour) or the ROM image is not valid, or there is some other difference to be figured out.

Please can I ask for some more examples of ROM images?

Regards,
John
PS 128KB of video RAM now on order - 16 x MB8264A-15 (4164 equivalent)

retrogear
December 4th, 2015, 07:14 PM
>Please can I ask for some more examples of ROM images?

I saved mine with debug and it's an exact byte match with Roman's

Larry G

1980s_john
December 5th, 2015, 09:49 AM
Thanks, fingers crossed that the RAM upgrade helps!

Regards,
John

retrogear
December 5th, 2015, 06:45 PM
>Thanks, fingers crossed that the RAM upgrade helps!

Yea, cross all fingers AND toes :p I'm real skeptical that more ram is going to solve it.
I think your physical ROM chip is incompatible somehow, but ram is cheap and will be nice to have it filled.
If more ram doesn't fix it, be sure and put old ROM back in and test the new ram configuration with the diagnostic disk to be sure you didn't add another problem.

Larry G

1980s_john
December 10th, 2015, 03:03 PM
Hi,

I fitted the additional video RAM, enabled RGB on the jumpers, and as Larry expected still no luck with the v2.5 monitor ROM.

I plugged the original v1.2 ROM back in, and ran the disk based diagnostics (nb video now OK, had to switch the external monitor to 75 ohm termination - doh!). I had to run the diagnostic configuration to allow for 3 banks of 64K video RAM, and also for some reason had to change the main memory from 2 banks (128K) to 3 (192K). Previously I the system memory diagnostics failed due to insufficient memory, I see now this was a misconfigured. All the memory tests passed (yeah!), but I have a problem with the serial port loop-back test.

This was the reason for investigating the ROM in the first place, as I have not been able to get either CP/M ZIMP or Kermit to work, so now the memory is all good I have a way forward.

Shame I couldn't get the newer ROM to work, one for another day maybe.

Thanks for the help. if Roman needs assistance with his power supply please start a new thread.

Regards,
John

retrogear
December 10th, 2015, 04:08 PM
I just ran the disk based diagnostics for the serial port and with a plain 25 pin extension cable from J1 to J2 it passes all the external and remote loopback tests, synchronous and asynchronous.
The manual indicated a special cable was needed for synchronous tests but evidently not ...

BTW - I would be more than happy to help Roman troubleshoot his power supply if there is a schematic.

Larry G

1980s_john
December 11th, 2015, 01:15 AM
There's a power supply schematic in section 8 of the Service Manual:

http://planemo.org/retro/downloads/z100/manuals/

Best to check supply on a dummy load, maybe there's a short on the Z-100 or disk drive.

Regards,
John

1980s_john
December 19th, 2015, 11:37 AM
I fitted the additional video RAM, enabled RGB on the jumpers, and as Larry expected still no luck with the v2.5 monitor ROM.

Update on my searches for info on this found the following on comp.sys.zenith.z100 from 1987, looks like I have a way forward with the upgrade to the V2.5 ROM :)

====================
boot ROM version question

I have an "old" motherboard with version 1.2 boot ROM, and would
like to upgrade to a newer boot ROM version. What is the highest
boot ROM version (& part #?) that will work with the old motherboard,
and how should J101/J102 be set?
I bought a 2.x ROM from Heath over a year ago, but my system
would not boot with it (trying every combination of J101/J102),
so I sent it back for a refund. As I remember, the system would
beep once and that was it. Since I had S101 set for auto boot,
I don't know if it would have gotten as far as the "hand prompt"
or not.

Thanks in advance for any information.

----------------
To Upgrade Boot Monitor V1.X to V2.x (2.9 is latest) requires changing
EPROMs, moving J102, and changing/torturing a PAL chip. The exact
details will be forthcoming in a week or so in the ZUpGrade Series.
This should give me enough time to refind the info...
Cheers,
Gern

Zupgrade part 4 is here: https://groups.google.com/forum/#!searchin/comp.sys.zenith.z100/zupgrade/comp.sys.zenith.z100/1OirJiaerZg/rPUx6lsXImUJ

Key part for updating from the V1.2 ROM is:

Upgrade From Version 1.x:

If the current MTR-100 version is 1.x then 3 changes must be made:

1) The ROM Address Selector PAL IC at U161 (part number 444-129) must
either be replaced with a ROM Address Top 32K Selector PAL IC (part number
444-129-1, about $7.00) or the 444-129 PAL IC must be 'converted' to
perform the new function.

The 444-129 IC can be converted into the function of a 444-129-1 IC by
connecting input pins 2 & 3 high to Vcc at pin 20.

a) Remove the IC from the socket and bend up pins 2 & 3.

b) Bend pins 2 & 3 together and solder them both to a small wire one inch
long.

c) Carefully solder the other end of the small wire to the top of pin 20.
Do not bend pin 20 or impede the pin from normal insertion into the socket.

d) Insert the converted IC into the socket. Pins 2 & 3 must remain above
the socket, but pin 20 must go into the socket normally.

2) Move Jumper J102. This allows the use of a 16K ROM.

3) Replace the ROM at U190 with Heath part number 444-276-1 MTR-100 Version
2.9 . Upgrade completed.

retrogear
December 20th, 2015, 06:27 AM
360k capability confirmed - my U161 is a 444-129-1

Larry G

1980s_john
December 20th, 2015, 10:23 AM
I've finally got a working V2.5 monitor ROM! Thanks to Roman for the ROM dump and Gern from comp.sys.zenith.z100 for the instructions which worked fine, and Larry for running so many checks on his machine. I did the mod on the PAL to make it work like a 444-129-1 (which everyone except me seems to have I fitted!), the self test and color bar etc. all look good, and I can finally boot from 360K floppies (an option not supported on ROM V1.2).

Hope the next guy gets there more quickly than I did :)

Thanks again for everyone's help,
John

ronwoch
December 22nd, 2015, 09:57 AM
Congrats John! And thank you for the updates.