PDA

View Full Version : WFW hangs on startup after networking added



nc_mike
November 5th, 2015, 03:48 AM
I have a 486 Dell Dimension 8200 running DOS 7.1 and Windows 3.11. All was fine until I decided to add a NIC and enable networking. I have several NICs, but don't think the symptoms have to do with any of the NICs. I'm able to start WFW, add networking, add the correct driver the NIC, then I restart Windows (it adds Net Start to the AUTOEXEC as well). So I reboot DOS - all is well. I then start Windows, get the Windows splash screen, then the splash screen closes and the cursor just blinks (hangs). I tried various NICs with their correct drivers - same result. I then commented out the DEVICE=IFSHELP.SYS in CONFIG.SYS and Windows starts, but with a warning dialog that says that networking couldn't start (I believe networking is dependent on IFSHELP). What I can't determine is why the hang when IFSHELP is enabled. I also tried selective startup, allowing only essential CONFIG.SYS and AUTOEXEC.BAT statement to execute to eliminate any conflicts there - but same symptoms. I am not sure how to diagnose. I tried Win /B to create a BOOTLOG, but it didn't really tell me anything Not sure what to do next.

Regards,
MIke

Caluser2000
November 5th, 2015, 08:47 AM
IRQ conflict?

nc_mike
November 13th, 2015, 05:27 PM
I never did get networking to install without hanging on restart, but I did instead get an Intel 100B 10/100 PCI NIC, enabled it in DOS with its Intel packet driver and mTCP, then used a shim with Trumpet Winsock to get it also working under DOS 3.11. At first it just ran by default at 10Mbs, but after adding a few parameters to the packet driver I was able to get it to run at 100Mbs in full duplex.

Mike