View Full Version : Sun SPARC station mounting CD-ROM

November 13th, 2015, 10:25 AM

I am trying to mount a CD-ROM on sunos 5.5.1 but I am getting nowhere. The computer does display the device when the probe-scsi command is used but it will not mount when using the 'mount' command. It continues to give me errors like 'no such device' and 'CD-ROM busy' etc.

Does anyone have any idea what is happening?


November 13th, 2015, 10:33 AM
What model of CD-ROM are you using? Is it set to 512 byte formats? CD-ROMs intended to be attached to a PC default to using 2048 byte sectors. In some cases, there is a jumper that will switch the mode to work correctly.

November 13th, 2015, 10:35 AM
I not 100% sure but it has a strange connector on the end that won't fit into a standard PC so I would assume that it is an old one.

November 13th, 2015, 10:45 AM
Assuming you've got the termination correct that is almost certainly the problem.

November 13th, 2015, 10:49 AM
Sorry I don't know anything about these systems, what do you mean?

Thanks ,

November 13th, 2015, 10:49 AM
The drive should have a label indicating manufacturer and model number. That information should also show up in the OS information panels. Also, is the drive internal or external?

Termination keeps signals on the cable from going wonky. If the CD-ROM is the last drive on a chain, it will need to have termination. That is done by a jumper if internal. Some external drives have a termination jumper. For the rest, a terminating block needs to be installed which looks like the external cable connector plug without a cable.

With SCSI CDROMs, you will encounter several types.
1) PC/MAC targeted which can be modified to SUN standard.
2) PC/MAC targeted that can't be modified. Patch OS or trade to someone with a proper SUN supported drive.
3) SUN supported drive. Some other problem exists.

The SUN CDROM FAQ is about 20 years old. It will list some models that just can't be made to work and some methods for modifying a few common drives to work.

If still uncertain, take some pictures of the setup. Closeups of drives, connectors, and jumper settings will be most helpful in letting anyone else see problems.

November 13th, 2015, 10:56 AM
I just checked the drive model and it seems it is a toshiba XM-5701.

I'll check the FAQ's to see if that drive is listed.

I assume it must be okay as the original owner used it to install Solaris on it ages ago as it originally had next step on it.


It's not on the list.
Also the setup is two cables 1 power and another communications, that's it.

November 13th, 2015, 12:12 PM
How do you change the target of a device?

November 13th, 2015, 02:27 PM
It's a jumper setting. There are three jumpers for that, binary 1, 2, and 4.

November 14th, 2015, 10:29 AM

Which ones do I need to change?
The picture above shows my setup currently. There are 3 jumpers.

November 14th, 2015, 11:07 AM
If I read the image correctly, your CD-ROM is set to ID1 and normally the SCSI HD is set to ID 0 (no jumpers). Traditionally, SUN used ID of 6 for CDROMs which would require removing the left most shunt and placing shunts on the middle and right of the 3 ID jumpers.

The right side group of jumpers are for other things. The only documentation I can find suggests that the left most one is the termination. If the CDROM is mounted on the cable between the controller and the hard drive, the CDROM drive correctly has no termination. I can't find documentation that says what the other pins do.

Do you have a XM5701 or XM5701B? I think the B model is the one the works best with early SUN OS. I can't find any reference on how to modify XM5701 into a XM5701B though your image has a blank spot in the jumpers while the B is shown having an extra pin position. Can you go to a later version of Solaris? Solaris 2.6 was the first version that works with PC style CDROMs without modification.

Edit: More checking suggests early SUNOS specifically looked for ID of 6 for CDROM drives so change the ID jumpers. If that does not work, I will leave the project to more experienced people.

November 14th, 2015, 11:55 AM

Mine is a model B.

I changed the Target ID to ID 6 and it now responds to commands, like boot CD-ROM but it still won't boot. I tried mounting it again but it still says 'no such device' and won't automatically mount In Solaris. It also now ejects and passes the self test.

Any ideas?


November 14th, 2015, 02:41 PM
Is the CD being used a CDR? I remember XM-5701 having difficulties with some vendors recordable CDs.

Try running a cleaning disc through the drive.

November 15th, 2015, 12:31 AM

Yes I am using CD-R and I also have an original Solaris installation CD which it does boot from until it states 'data transfer overrun' and it then reboots.


November 15th, 2015, 01:19 AM
Any ideas?

You haven't mentioned if the termination is correct. I would suggest moving the jumper (from the left in your photo) that's currently in position 4 to position 5.

I think 4 disables parity (you want parity) and 5 enables termination.

Usually these drives have a jumper guide printed on the top label.

Apparently this drive is set to the correct 512 block size by a SCSI set mode command rather than a jumper. If it worked once before it should work again but otherwise an older drive with a block size jumper would be more likely to work.

Also, the PROM command is specifically 'boot cdrom' and is a shortcut allows booting from a drive normally on ID=6.

November 15th, 2015, 02:49 PM

Thanks for the help everyone as I have managed to get the CD-ROM to work. I just set the target ID of the CD-ROM to target 6 and it now boots correctly.

I want to install next step on the computer but it won't boot for some reason. Every time I boot from the installation cd it loads and after a minute I get the message "watchdog reset" and it returns to the "OK" prompt?

Any ideas on how to bypass this or get it to work?

The original owner had next step on it so it does work but he had to take it off as he couldn't remember the login details.


November 15th, 2015, 03:16 PM
It would be helpful if you would provide more information;

1. You haven't confirmed (yet again) if you have the SCSI termination right. Reset type errors are exactly what you might expect if it were incorrect. Post photos if needed.
2. What model of sparcstation?
3. Is this the same Openstep CD that was previously used successfully for the install?
4. Do you have a video display and keyboard or are you using a serial console?

November 15th, 2015, 09:58 PM
Sorry, I don't really know what information to provide.

If the termination is the jumper setting on the back of the CD-ROM marked "Term" then I'm fairly sure that is set to the correct setting.

Mine is a SPARCstation 4. If you want the exact model number I'll have to get that later.

I'm not sure as the original next step cd cannot be found. So I got the iso file off win world and burnt it to a cd. I did this will a Solaris cd to make sure it was reading my cd's okay and it worked fine.

I have a video display and keyboard attached. The keyboard and mouse are both original but I have a monitor adapter to work with most VGA monitors.


November 16th, 2015, 02:56 AM
I would suggest trying to burn the CD again. Do the burn at 1x not the faster speeds most software wants to use. If you have a different brand of CDR (or same brand with different coating), try that as well. Old CD-ROM drives would work with some CDR discs but not others. Used to be web pages listing all kinds of combinations of drives and discs but those seem to be gone.

November 16th, 2015, 04:49 AM
SCSI termination is not always so simple.

if you have added this drive to an already properly terminated system, odds are pretty good that it's incorrect now.

There needs to be exactly one terminator at one end of the bus and one at the other. Your bus as at least: the controller (built in), a hard drive, and the cd-rom. If they're chained in that order which they probably are, there needs to be one terminator before the controller, and one on your cd-rom (which you have).

If there's one on the hard drive, it needs to be disabled. The terminator before the controller may be turned on at the motherboard, or may need to be plugged into an external connector at the back of the machine. Most likely you need one plugged in the back if my memory is correct.

November 16th, 2015, 06:36 AM
So if the termination is incorrect then why does it boot the burned Solaris CD-R and mount them in Solaris?
It does begin to load next step but then shows an error code after I select option 1 which is begin installing next step.

I'll check the termination to see if it is the CD-ROM. The CD-ROM is the original one that came with it so I think it should work fine, but I am probably wrong.

The hard drive for mine is mounted onto the circuit board, is this a common place for the hard drive? I thought it would sit opposite the CD-ROM since there is a space there which is too small for a CD-ROM.

Also how do you burn at slower speeds that 10x? My computer won't let me burn any slower.


November 16th, 2015, 06:48 AM
So if the termination is incorrect then why does it boot the burned Solaris CD-R and mount them in Solaris?That's the nature of the beast! SCSI termination problems can cause all kinds of whacky things to happen.

It does begin to load next step but then shows an error code after I select option 1 which is begin installing next step.That could be any number of things, including SCSI termination. I would burn another disc first.

I'll check the termination to see if it is the CD-ROM. The CD-ROM is the original one that came with it so I think it should work fine, but I am probably wrong. The thing to remember about SCSI termination is that the bus is a straight line:
1: Terminator - Controller - Hard drive - CDROM - Terminator
2: Terminator - Hard drive - Controller - CDROM - Terminator
3: (missing terminator) - Plug on back of machine - Controller - Hard drive - Terminator - CDROM - Terminator

1 and 2 are correct. 3 is incorrect, but is a common situation. You'll need to determine which component is where in the bus. It seems straightforward but rarely is.

The hard drive for mine is mounted onto the circuit board, is this a common place for the hard drive? I thought it would sit opposite the CD-ROM since there is a space there which is too small for a CD-ROM.I've had Sparcstations 1, 2, 10, 20, some clones, and some UltraSparcstations. But, I don't remember too much about all of them. So I'm not sure what to make of that.

Also how do you burn at slower speeds that 10x? My computer won't let me burn any slower.It's a setting in the software you use to do the CD burning. Some software doesn't allow you to change it though.

November 16th, 2015, 11:29 AM

I've had a look at the hard drive and it doesn't have any pins anywhere on it. Could they be on the main motherboard/controller?

There are many jumpers on the main board.

I can provide pictures if that would help.

There is only on cable attached to the hard drive which is very thin and trapezoid in shape.


November 16th, 2015, 11:32 AM
Termination isn't always done by jumper.

A lot of times there are removable resistor packs.

November 16th, 2015, 11:44 AM

See above.

Just looked at the manual and it said termination is on the motherboard - but it doesn't say where. It said there is no need to set jumpers as the termination is handled by the motherboard, and is preset.

That picture is really bad, apologies. See link below for direct access to the manual.

It is chapter 9


November 16th, 2015, 12:17 PM
Provide pictures just in case there is some difference between your system and the documentation. Or for that matter, from the system I was thinking of.

Hard drive needs no termination because the cabling internal to the motherboard includes a terminator as the end of the chain.
CDROM needs to be terminated so looks like I was wrong and a shunt should be placed on the termination pins.
Check both drives for any bent pins. A very slight angle on insertion can push pins together which could cause bad results.

November 16th, 2015, 12:27 PM
Mine is definitely that setup. I can provide pictures but it will have to be later.

I think I'll just have to put up with Solaris. I just read another post on a different forum of someone else complaining that next step wouldn't install and the installation stopped at the same place as mine does, but they didn't seem to figure it out.

November 16th, 2015, 12:30 PM
From all that back and forth it sounds like the termination at the end of the SCSI is likely correct.

Have you tried to read other CDs? So far it sounds like the only difference from the previous successful install is the actual install CD itself. But, If you are not using the same CD drive as before, then perhaps that is the issue?

There is a FAQ here in case you haven't seen it.

I've installed this same OS CD on an HP Apollo workstation and it took perhaps 5 tries to get it to complete successfully. I burned my CD on a PC running windows. The HP, however, does not use a 512 block size drive.

November 16th, 2015, 12:47 PM
Okay, I'll try burning the cd again.

I found a PDF on 'watchdog resets', and it basically describes them as 'fatal errors' cause by either software or hardware problems. In answer to your question Paul I have successfully burnt a copy of Solaris and installed it on the computer so it could be a software fault.

November 16th, 2015, 01:51 PM
A "watchdog reset" means that the OS has crashed and is stuck in an infinite loop, therefore can't respond to an interrupt request generated by a watchdog timer.

November 19th, 2015, 12:36 PM

Just got some CD-R's and tried burning it again but I got the same error as before. This leads me to think that it is something to do with my hardware configuration and not the CD itself, or something to do with the actual software.
Did someone say that I should have a jumper over parity?


November 20th, 2015, 10:54 AM
To disable parity normally a jumper is installed. Parity was optional in the original SCSI spec, enforced in SCSI-2. You could always just try it either way but SS are normally SCSI-2 standard.